Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

Setting the BootProt fuse
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Setting the BootProt fuse

by ahrensd on Wed Jul 29, 2020 4:03 am

Using a itsybitsy M4, connected via a Segger J-Link.
Using Atmel Studio 7 - Device Programming - Fuses
Have tried to set BOOTPROT to 0 kbytes.
After i hit program all goes well (including the auto verify)
Read values back and BOOTPROT is still set to 16 kbytes.

This is all in the effort to use PlatformIO debugger with the J-Link, this locks up and following a suggestion that the bootloader gets in the way (yes I have to change the offset for the uploader). Had this working this morning, but I wanted to see if I could get things working under MicroVisual on Visual Studio.
Same ItsyBitsy worked this morning. Did try to run the more complex code under the working PIO IDE arrangement and found the target resetting constantly. Hence why I tried something else.

Need to debug some code that is using the WDT and external interrupts. every difficult to examine what is going on as I lose Serial connection over the USB.

Reason I'm using WDT is for power savings.

Host system is Windows 10.

Any ideas would be appreciated.
Thanks in advance.

ahrensd
 
Posts: 22
Joined: Sat Nov 12, 2016 6:58 pm

Please be positive and constructive with your questions and comments.