0

Arduino IDE not seeing Itsy Bitsy
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Arduino IDE not seeing Itsy Bitsy

by VE6TL on Mon Apr 19, 2021 8:16 pm

Hi,

Just picked up an Itsy Bitsy and tried to follow the Adafruit instructions to identify the board in the Arduino IDE V1.8.14 - Boards Manager. Selected "Contributed" and it isn't listed at all. What to do?

Thanks

Jerry VE6TL

VE6TL
 
Posts: 3
Joined: Mon Apr 19, 2021 8:13 pm

Re: Arduino IDE not seeing Itsy Bitsy

by blnkjns on Tue Apr 20, 2021 12:19 am

Double-tap reset?

blnkjns
 
Posts: 663
Joined: Fri Oct 02, 2020 3:33 am

Re: Arduino IDE not seeing Itsy Bitsy

by VE6TL on Tue Apr 20, 2021 11:51 am

Tried the reset. Arduino's IDE returns (from "Get Board Info"): BN: Unknown board, VID: 239A, PID: 800E.

VE6TL
 
Posts: 3
Joined: Mon Apr 19, 2021 8:13 pm

Re: Arduino IDE not seeing Itsy Bitsy

by adafruit_support_carter on Tue Apr 20, 2021 12:02 pm

Which specific Itsy are you using? 32u4, M0, etc?

adafruit_support_carter
 
Posts: 20625
Joined: Tue Nov 29, 2016 2:45 pm

Re: Arduino IDE not seeing Itsy Bitsy

by VE6TL on Wed Apr 21, 2021 3:12 pm

Found the problem. I didn't have the Arduino IDE preferences set to the additional website for Adafruit hardware. No wonder it wasn't in the boards list.

VE6TL
 
Posts: 3
Joined: Mon Apr 19, 2021 8:13 pm

Re: Arduino IDE not seeing Itsy Bitsy

by adafruit_support_carter on Wed Apr 21, 2021 3:46 pm

Cool. Yah, for the SAMD boards you have to install both the Arduino SAMD and Adafruit SAMD packages, which can be confusing. Glad you figure it out. Have fun!

adafruit_support_carter
 
Posts: 20625
Joined: Tue Nov 29, 2016 2:45 pm

Please be positive and constructive with your questions and comments.


cron