Due to high demand, expect some shipping delays at this time - orders may not ship for up to 2-3 business days.
0

Arduino Compiling Error for Adafruit Metro ESP32-S2 Express
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Arduino Compiling Error for Adafruit Metro ESP32-S2 Express

by charliechesney on Mon Jan 17, 2022 7:21 pm

Hi all, hope I'm posting this in the right place!
I have been struggling to load the Blink sketch onto the Adafruit Metro ESP32-S2 Express.

I'm using a Mac OS Sierra version 10.12.6 and Arduino 1.8.19
I am using Arduino IDE instead of CircuitPython because I need to connect to my university's wifi (WAP2 Enterprise) which can not be done in CircuitPython.

Here are my steps:
I followed the https://learn.adafruit.com/adafruit-metro-esp32-s2/overview tutorial and could not get esptool to work, so I used the Web Serial ESPTool to erase the board and then load the bin file and was able to see the METROS2BOOT on my computer. I didn't install the UF2 because I'm not using CircuitPython, but please tell me if this is incorrect.

I updated Arduino IDE and installed the esp32 board under the manager and selected the "Adafruit Metro ESP32-S2" board. Although connected using a data cable, my board did not show up under "Port." I put the board in bootloader mode and the port showed up: "/dev/cu.usbmodem1 (ESP32S2 Dev Module)"

I copy/pasted the Blink sketch from the tutorial and clicked compile but get the following error:

Code: Select all | TOGGLE FULL SIZE
Arduino: 1.8.19 (Mac OS X), Board: "Adafruit Metro ESP32-S2, Enabled, Disabled, Disabled, Internal USB, Enabled, Default 4MB with spiffs (1.2MB APP/1.5MB SPIFFS), 240MHz (WiFi), QIO, 80MHz, 4MB (32Mb), 921600, None"

[59808] Error loading Python lib '/var/folders/1f/16yxxxyx7lv6c3hn8htr35gr0000gp/T/_MEIEOgGvP/libpython3.8.dylib': dlopen: dlopen(/var/folders/1f/16yxxxyx7lv6c3hn8htr35gr0000gp/T/_MEIEOgGvP/libpython3.8.dylib, 10): Symbol not found: ____chkstk_darwin
  Referenced from: /var/folders/1f/16yxxxyx7lv6c3hn8htr35gr0000gp/T/_MEIEOgGvP/libintl.8.dylib
  Expected in: /usr/lib/libSystem.B.dylib
 in /var/folders/1f/16yxxxyx7lv6c3hn8htr35gr0000gp/T/_MEIEOgGvP/libintl.8.dylib
exit status 255
/private/var/folders/1f/16yxxxyx7lv6c3hn8htr35gr0000gp/T/AppTranslocation/12259308-1141-406D-AED2-4AE075195ACE/d/Arduino.app/Contents/Java/arduino-builder returned 255
Error compiling for board Adafruit Metro ESP32-S2.



I've been working on solving this problem for hours and am at a loss. I've tried uninstalling and reinstalling Arduino, but this did not solve the problem. I would so appreciate any guidance on how to solve this problem, thanks!

charliechesney
 
Posts: 7
Joined: Mon Jan 10, 2022 2:27 pm

Re: Arduino Compiling Error for Adafruit Metro ESP32-S2 Expr

by mikeysklar on Wed Jan 19, 2022 6:37 pm

We have two sets of instructions for the Arduoino IDE when using the Metro ESP32-S2.

You will want to checkout the “old” instructions with the 1.8.19 of the IDE you are using.

https://learn.adafruit.com/adafruit-met ... -ide-setup

Note that we are not using the Arduino board support package installer, instead we are going to be running the latest version from Espressif's ESP32 github repository and the v4.2 branch

mikeysklar
 
Posts: 7582
Joined: Mon Aug 01, 2016 8:10 pm

Re: Arduino Compiling Error for Adafruit Metro ESP32-S2 Expr

by charliechesney on Wed Jan 19, 2022 7:13 pm

mikeysklar wrote:We have two sets of instructions for the Arduoino IDE when using the Metro ESP32-S2.

You will want to checkout the “old” instructions with the 1.8.19 of the IDE you are using.

https://learn.adafruit.com/adafruit-met ... -ide-setup

Note that we are not using the Arduino board support package installer, instead we are going to be running the latest version from Espressif's ESP32 github repository and the v4.2 branch


Thanks for your reply! Unfortunately, the link you shared brings me to a 404 error page.

charliechesney
 
Posts: 7
Joined: Mon Jan 10, 2022 2:27 pm

Re: Arduino Compiling Error for Adafruit Metro ESP32-S2 Expr

by mikeysklar on Thu Jan 20, 2022 3:35 pm

Just click the link (do not try and select it). I verified that it is valid.

mikeysklar
 
Posts: 7582
Joined: Mon Aug 01, 2016 8:10 pm

Re: Arduino Compiling Error for Adafruit Metro ESP32-S2 Expr

by charliechesney on Thu Jan 20, 2022 3:41 pm

I did just click the link and get the 404 error. Please see image.
Attachments
Screen Shot 2022-01-20 at 11.33.23 AM 2.png
Screen Shot 2022-01-20 at 11.33.23 AM 2.png (243.21 KiB) Viewed 81 times

charliechesney
 
Posts: 7
Joined: Mon Jan 10, 2022 2:27 pm

Re: Arduino Compiling Error for Adafruit Metro ESP32-S2 Expr

by mikeysklar on Thu Jan 20, 2022 3:50 pm

I see what is happening.

I can still view the old (now removed public page) due to my admin privileges.

You will need to upgrade to Arduino 2.x for support on the Metro ESP32-S2 Express and follow the most recent set of instructions here:

https://learn.adafruit.com/adafruit-met ... de-setup-2

mikeysklar
 
Posts: 7582
Joined: Mon Aug 01, 2016 8:10 pm

Re: Arduino Compiling Error for Adafruit Metro ESP32-S2 Expr

by charliechesney on Thu Jan 20, 2022 3:59 pm

Thank you for your help. I'm unable to download Arduino IDE 2.0 because my Mac is only 10.12.6 and I am unable to upgrade my Mac. I think I'm at a dead end here and will need to use a different computer. Thanks anyway!

charliechesney
 
Posts: 7
Joined: Mon Jan 10, 2022 2:27 pm

Re: Arduino Compiling Error for Adafruit Metro ESP32-S2 Expr

by mikeysklar on Fri Jan 21, 2022 5:48 pm

Yeah, limited options being that far back on the MacOS side. I have to keep my primary MacOS on a dated 10.14.x to ensure support for a bunch of different devices.

If you have a Raspberry Pi, Windows or other Linux box handy those could also be options for installing a newer release of Arduino.

mikeysklar
 
Posts: 7582
Joined: Mon Aug 01, 2016 8:10 pm

Please be positive and constructive with your questions and comments.