Issues with serial communication MacOS

Please tell us which board you are using.

Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.
Post Reply
User avatar
chmod777
 
Posts: 1
Joined: Fri Aug 12, 2022 5:48 pm

Issues with serial communication MacOS

Post by chmod777 »

Hi,
I am trying to port my code base to a grand central m4, but serial COMS are only recognized when I kick the device into UF2 boot loader drive mode.

What I have already tried:
different cables/dongles/ports
Reuploading firmware thru drive mode
An M4 express board (exhibits same behavior)
Restarting computer

From the forum posts I’ve read regarding this issue, it seems to be related to a disk management kernel extension.

First off, I’m not as keen on deleting system kernel extensions as others with the same issue were. But, I checked for the problematic extensions and they’re not there. I checked the third party kernel extensions and found some that could be the issue, but I couldn’t find conclusive information online about what they actually are, and what uses them.

I should also mention that I tried programming from a PC and it worked fine, so I’m certain that my Mac is the issue.

I realize that this forum post is quite vague, and I can provide more details if someone thinks they can directly help with this issue, but I haven’t given up at trying to fix this problem myself so here are some more general questions I have which could help me debug:

What all does the red led labeled “L” indicate? I know that it comes on when the board is in boot loader mode, but it seems to blink at other times as well.

How can I tell if a bootloader update actually succeeds?

What is the interface on the board which facilitates firmware updates / bootloader mode or does the ATSAMD handle it?

Does the board have the capability to safely eject after uploading UF2? Every time the board is unmounted/ejected, it does it forcibly. I should also note that when I try to safely eject it manually, it immediately remounts itself.

Any help is appreciated, Thanks

User avatar
dastels
 
Posts: 11197
Joined: Tue Oct 20, 2015 3:22 pm

Re: Issues with serial communication MacOS

Post by dastels »

The red "L" LED is the standard LED on digital output pin 13 which dates back to the Arduino UNO.

To get the version of the installed bootloader see https://learn.adafruit.com/adafruit-gra ... er-3061298.

The SAMD51 handles bootloader and firmware updates.

Once firmware is updated (in bootloader mode) the board resets.

What is the problem behavior you are experiencing? Are you using Arduino?

Dave

Post Reply
Please be positive and constructive with your questions and comments.

Return to “Metro and Metro Express, Grand Central”