0

Metro M4 express bad SCL pin
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Metro M4 express bad SCL pin

by LouH on Thu Jan 10, 2019 12:51 pm

I ordered two Metro M4 express boards on order # 1899744-9095256836 November 13, 2018.
While trying to do the circuitPython example on bmp280 sensor using I2c, One of the Metro Me boards would not find the sensor.
The message on Mu was needing pullup on SCL or SDA pins. I had 4.7k resistor on each of the pins. So I tried the other Metro M4 express board and it worked fine.

On the bad Metro M4 express board, the bmp280 example would work using (board.A5, board.A4) but not with (board.SCL, board.SDA).

I also switch to Arduino IDE and tried doing analogRead(A6) and analogRead(A7) and using 3.3v with two 2.2k divider to GND.
I got 520 raw reading on the SDA pin but only got 3 raw reading on the SCL pin.

I feel that the SCL pin on this board is not working.

Please send me a replacement Metro M4 express board.

thanks for your help
Lou
Attachments
IMG_0159.JPG
IMG_0159.JPG (119.97 KiB) Viewed 60 times
IMG_0158.JPG
IMG_0158.JPG (118.34 KiB) Viewed 60 times
IMG_0157.JPG
IMG_0157.JPG (130.92 KiB) Viewed 60 times

LouH
 
Posts: 2
Joined: Sat Mar 19, 2016 6:47 pm

Re: Metro M4 express bad SCL pin

by adafruit_support_carter on Fri Jan 11, 2019 10:12 pm

Odd. Not working two ways? Does seem like something is up. Let's replace it. Send an email to support@adafruit.com with a link to this thread and your order number and they can send you a replacement Metro M4 Express.

Also - there are pull-ups on the BMP 280 breakout, you don't need external resistors.
https://learn.adafruit.com/adafruit-bmp ... wiring-4-2

adafruit_support_carter
 
Posts: 9847
Joined: Tue Nov 29, 2016 2:45 pm

Please be positive and constructive with your questions and comments.