0

metro station - can't find device in Mu serial
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

metro station - can't find device in Mu serial

by itzlow on Mon Jan 14, 2019 11:03 pm

I have a few feather boards that work fine with Mu, connecting to the serial console, but I’m getting an error with the grand central.

Using Mu on MacOSX, sending output to serial, clicking on serial button in Mu, and error says can’t find attached device, so serial console does not open.

Under the blinking light example, it loads up the code and runs however adding the print out does nothing.

Any help here would be appreciated
itzlow
 
Posts: 6
Joined: Sat Jan 18, 2014 1:47 pm

Re: metro station - can't find device in Mu serial

by adafruit_support_mike on Wed Jan 16, 2019 1:44 am

As a sanity check, verify your USB cable by using it to connect some other, known-working device to the computer.

There's a plague of charge-only cables out there with USB connectors at both ends by no wires for the data signals. We see people get caught by them every day, and it's become normal for people to say they had to try three or four cables before finding one that made an actual data connection. Just swapping cables isn't enough.. we need the positive of a working data connection to rule out the false negatives from a charge-only cable.

Assuming the cable is good, what do you see in the Device Manager or System Information USB pane when the Grand Central is connected?

adafruit_support_mike
 
Posts: 57131
Joined: Thu Feb 11, 2010 2:51 pm

Re: metro station - can't find device in Mu serial

by itzlow on Sun Jan 20, 2019 12:16 am

I can send updates to code.py over the cable, such as changing the red light flash and they work. i see circuitpy as device when plugged in.

trying to open serial in Mu i get "Please make sure the device is plugged into this computer.

It must have a version of MicroPython (or CircuitPython) flashed onto it before the REPL will work."
itzlow
 
Posts: 6
Joined: Sat Jan 18, 2014 1:47 pm

Re: metro station - can't find device in Mu serial

by adafruit_support_mike on Sun Jan 20, 2019 5:11 am

Hmm.. what output do you get from the command:

Code: Select all | TOGGLE FULL SIZE
ls -l /dev/cu.*
in Terminal?

adafruit_support_mike
 
Posts: 57131
Joined: Thu Feb 11, 2010 2:51 pm

Re: metro station - can't find device in Mu serial

by itzlow on Sun Jan 20, 2019 12:02 pm

metro station shows up as crw-rw-rw- 1 root wheel 21, 37 Jan 20 07:45 /dev/cu.usbmodem1411

what is the amber led L next to the red oN led? i saw that linux might need to disable modem manger if serial connection issues... same deal here?
itzlow
 
Posts: 6
Joined: Sat Jan 18, 2014 1:47 pm

Re: metro station - can't find device in Mu serial

by itzlow on Sun Jan 20, 2019 5:19 pm

everything works so far, with the exception of serial interaction.

can write files that store data on SD card and then SD card shows the data.
itzlow
 
Posts: 6
Joined: Sat Jan 18, 2014 1:47 pm

Re: metro station - can't find device in Mu serial

by itzlow on Sun Jan 20, 2019 5:28 pm

I just tried serial console from os x and it works just fine, so the issue is with Mu.

Any ideas?
itzlow
 
Posts: 6
Joined: Sat Jan 18, 2014 1:47 pm

Re: metro station - can't find device in Mu serial

by adafruit_support_mike on Mon Jan 21, 2019 7:28 am

I don't know of any offhand, but I'll check with the folks who handle CircuitPython.

What version of OS X are you running, and what version of Mu?

adafruit_support_mike
 
Posts: 57131
Joined: Thu Feb 11, 2010 2:51 pm

Re: metro station - can't find device in Mu serial

by itzlow on Mon Jan 21, 2019 5:07 pm

os x 10.13.6

mu 1.0.1
itzlow
 
Posts: 6
Joined: Sat Jan 18, 2014 1:47 pm

Re: metro station - can't find device in Mu serial

by jerryn on Mon Jan 21, 2019 5:21 pm

You may want to try upgrading to mu version 1.0.2 -- the definitions for the Grand Central were added fairly recently.

jerryn
 
Posts: 905
Joined: Sat Sep 14, 2013 9:05 am

Re: metro station - can't find device in Mu serial

by adafruit_support_mike on Tue Jan 22, 2019 1:31 am

Yes. The Grand Central requires the latest version of Mu.

adafruit_support_mike
 
Posts: 57131
Joined: Thu Feb 11, 2010 2:51 pm

Re: metro station - can't find device in Mu serial

by bebo on Sat Mar 09, 2019 2:11 pm

Thanks for figuring this out for the rest of us. This just made my day much easier.

bebo
 
Posts: 84
Joined: Tue Mar 29, 2011 8:22 am

Please be positive and constructive with your questions and comments.