0

Metro M4 Express microSD Shield Board
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Metro M4 Express microSD Shield Board

by neosamuri on Fri Feb 01, 2019 10:18 pm

Hi,

I have a sparkfun microSD shield board attached to my Metro M4 express and I can't seem to get the SD card to initialize. I have changed the code to be the proper pin and I have verified the shield and SD card initializes on an UNO I have. So I am not sure what could be the issue.

Any help into this would be appreciated.

neosamuri
 
Posts: 3
Joined: Fri Feb 01, 2019 9:52 pm

Re: Metro M4 Express microSD Shield Board

by franklin97355 on Sat Feb 02, 2019 2:48 am

What code are you running on the Metro?

franklin97355
 
Posts: 20511
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: Metro M4 Express microSD Shield Board

by neosamuri on Sat Feb 02, 2019 3:57 am

Sorry I should have specified. I'm using the Arduino IDE and just running some code I've written. But I've also tried it with the example code that comes with the Arduino SD library and that still fails to initialize the card.

neosamuri
 
Posts: 3
Joined: Fri Feb 01, 2019 9:52 pm

Re: Metro M4 Express microSD Shield Board

by franklin97355 on Sat Feb 02, 2019 2:34 pm

Can you post the exact code you are testing with and the connections you are making? The M4 does not use pins 11 to 13 for SPI as the Uno does.

franklin97355
 
Posts: 20511
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: Metro M4 Express microSD Shield Board

by neosamuri on Sat Feb 02, 2019 10:57 pm

OK that makes sense. I connected those pins on the right to my shield an now it work like a charm. Thank you for pointing me in the right direction!

neosamuri
 
Posts: 3
Joined: Fri Feb 01, 2019 9:52 pm

Please be positive and constructive with your questions and comments.