Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

Problem uploading Metro Mini
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Problem uploading Metro Mini

by rssutton9 on Mon Apr 20, 2020 11:57 am

I recently bought two Metro Minis, neither of which will upload. Running Windows 10 with latest update. The driver is Silicon Labs CP210x USB to UART Bridge. I checked their website to make certain I had the latest driver. According to SL and MS, the latest version is installed. I've double-checked cables, tried different USB ports, and computers. Neither will accept an upload. One mini shows the read LED blink program working, the other doesn't. The error message is "Problem uploading" with a reference to the adruino site. Here's what it says after compiling:

System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

Using Port : COM4
Using Programmer : arduino
Overriding Baud Rate : 115200
avrdude: ser_open(): can't open device "\\.\COM4": The system cannot find the file specified.



avrdude done. Thank you.

Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

It says it can't open COM4, but both the IDE and the Windows Device Manager show COM3 is the port being used.

I'm stuck, quarantined and looking for suggestions on what to try next.

Thanks for your help

Stan Sutton

rssutton9
 
Posts: 4
Joined: Thu Nov 21, 2019 11:25 am

Re: Problem uploading Metro Mini

by rssutton9 on Mon Apr 20, 2020 11:59 am

Ignore my previous post. I got it working. Just like driving, it was the nut behind the wheel.

Stan Sutton

rssutton9
 
Posts: 4
Joined: Thu Nov 21, 2019 11:25 am

Re: Problem uploading Metro Mini

by danhalbert on Mon Apr 20, 2020 2:28 pm

Glad you got it working!

danhalbert
 
Posts: 2138
Joined: Tue Aug 08, 2017 12:37 pm

Please be positive and constructive with your questions and comments.