Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

SAMD51 (M4) board users: update your bootloaders to >=v3.9.0
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

SAMD51 (M4) board users: update your bootloaders to >=v3.9.0

by danhalbert on Fri May 08, 2020 12:55 pm

If you have a SAMD51 board, including Metro M4, Feather M4, ItsyBitsy M4, Grand Central M4, Hallowing M4, PyBadge, PyGamer, PyPortal, or MONSTER M4SK, we highly recommend that you update the bootloader on your board to prevent internal flash occasionally being overwritten on power up.

For most boards this may just overwrite the loaded user program, but for a small number of boards that were shipped early in the product cycle, their bootloaders are not protected from overwriting, so this bug may brick the board, and require rewriting the bootloader manually, which can be difficult without external equipment or software.

There are directions for updating the bootloader in the primary product Learn Guide for each board, such as:
https://learn.adafruit.com/adafruit-fea ... bootloader
https://learn.adafruit.com/adafruit-pyg ... bootloader
https://learn.adafruit.com/adafruit-pyp ... bootloader
https://learn.adafruit.com/adafruit-pyb ... bootloader
etc.

danhalbert
 
Posts: 2122
Joined: Tue Aug 08, 2017 12:37 pm

Re: SAMD51 (M4) board users: update your bootloaders to >=v3

by llawrence4 on Wed May 20, 2020 7:47 pm

I just purchased a Grand Central board. After upgrading to the latest bootloader (UF2 Bootloader v3.10.0 SFHWRO), I can't get the LEDs to go off and I can't upload any sketches. To upgrade, I downloaded the update-bootloader-grandcentral_m4-v3.10.0.uf2 and just dragged it to the boot folder. The red LED flashed and then the drive window popped back open. Checking INFO_UF2.TXT, I now see the 3.10 version. Is there something else that needs to be done? Is there a way to roll back?

llawrence4
 
Posts: 1
Joined: Wed May 20, 2020 7:42 pm

Re: SAMD51 (M4) board users: update your bootloaders to >=v3

by danhalbert on Wed May 20, 2020 9:43 pm

I just tried this on a Grand Central, and it works for me. The NeoPixel is green, there is one LED at the edge of the board that is on, and the fourth LED from the edge is pulsing.

When you update the bootloader, any existing program that was on the board, including CircuitPython, is removed. You must now reload CircuitPython or upload an Arduino program. What happens when you try to drag something to GCM4BOOT or upload in Arduino?

danhalbert
 
Posts: 2122
Joined: Tue Aug 08, 2017 12:37 pm

Re: SAMD51 (M4) board users: update your bootloaders to >=v3

by danhalbert on Wed May 20, 2020 9:45 pm

OK, I may be reproducing your problem. Hold on.

danhalbert
 
Posts: 2122
Joined: Tue Aug 08, 2017 12:37 pm

Re: SAMD51 (M4) board users: update your bootloaders to >=v3

by danhalbert on Wed May 20, 2020 10:01 pm

I had your problem, but it went away after I unplugged the board and plugged it back in. I also had a reboot in between, due to a Linux issue.

What OS are you running, and could you try unplugging/replugging the board? Also try rebooting too, and see if that makes a difference.

danhalbert
 
Posts: 2122
Joined: Tue Aug 08, 2017 12:37 pm

Re: SAMD51 (M4) board users: update your bootloaders to >=v3

by Pedrinbeep on Tue Jun 02, 2020 5:44 pm

danhalbert wrote:I had your problem, but it went away after I unplugged the board and plugged it back in. I also had a reboot in between, due to a Linux issue.

What OS are you running, and could you try unplugging/replugging the board? Also try rebooting too, and see if that makes a difference.


I have similar problem with this version. Make macOS Catalina lagging a lot and don't show the drive in UF2 mode or USB devices... I go back to 3.7 and then everything great. On windows 10 do the same thing this version.

Pedrinbeep
 
Posts: 16
Joined: Sun Jul 14, 2019 10:37 am

Re: SAMD51 (M4) board users: update your bootloaders to >=v3

by danhalbert on Tue Jun 02, 2020 7:04 pm

I've tested with MacOS 10.15.4. and 10.15.5, and I don't have trouble. I similarly did not have trouble on Windows. Are you using a USB hub? Do you have any third-party antivirus or disk utilities in use? Thanks - I'd like to track this down.

danhalbert
 
Posts: 2122
Joined: Tue Aug 08, 2017 12:37 pm

Re: SAMD51 (M4) board users: update your bootloaders to >=v3

by Pedrinbeep on Tue Jun 02, 2020 8:46 pm

danhalbert wrote:I've tested with MacOS 10.15.4. and 10.15.5, and I don't have trouble. I similarly did not have trouble on Windows. Are you using a USB hub? Do you have any third-party antivirus or disk utilities in use? Thanks - I'd like to track this down.

No, directly on USB port and any antivirus. I make another test and updating from 3.7 to 3.10 cause this problem, but from 3.7 to 3.9 and then to 3.10 works fine. I will try to make a "custom board" to test it and check if this also cause any kind of problem. It is weird

Pedrinbeep
 
Posts: 16
Joined: Sun Jul 14, 2019 10:37 am

Re: SAMD51 (M4) board users: update your bootloaders to >=v3

by Pedrinbeep on Sat Jun 06, 2020 8:41 am

Same lag thing with a custom board from grandcentral_m4 build. With 3.9 and 3.10, Windows 10 and MacOS 10.15.5, and try with a virtual machine of Windows 10 on parallels from MacOS and lag the Windows 10 only, not the MacOS when I say to connect the USB to this system

Pedrinbeep
 
Posts: 16
Joined: Sun Jul 14, 2019 10:37 am

Re: SAMD51 (M4) board users: update your bootloaders to >=v3

by danhalbert on Sat Jun 06, 2020 8:48 am

I'm a little confused. So now:

1. On MacOS 10.15.5, the problem no longer occurs?
2. On Windows 10 running under Parallels, the problem does occur?

Do you have a native Windows 10 machine to try this on?

Are you running any kind of disk management, backup, or indexing software on the Parallels Win10 machine? You said no anti-virus, but are you using Hard Disk Sentinel, AIDA64, any backup program (e.g., Acronis), or any utility program that came with an external drive (e.g. Western Digital utility software)?

danhalbert
 
Posts: 2122
Joined: Tue Aug 08, 2017 12:37 pm

Re: SAMD51 (M4) board users: update your bootloaders to >=v3

by Pedrinbeep on Sat Jun 06, 2020 11:33 am

danhalbert wrote:I'm a little confused. So now:

1. On MacOS 10.15.5, the problem no longer occurs?
2. On Windows 10 running under Parallels, the problem does occur?

Do you have a native Windows 10 machine to try this on?

Are you running any kind of disk management, backup, or indexing software on the Parallels Win10 machine? You said no anti-virus, but are you using Hard Disk Sentinel, AIDA64, any backup program (e.g., Acronis), or any utility program that came with an external drive (e.g. Western Digital utility software)?


1. On MacOS 10.15.5 (new update) the problem stop. Just check it. Only occurs if the UF2 is custom
2. On Windows 10 running under Parallels the problem occurs only if the UF2 is custom too.
3. The Win10 machine is complete empty, only Atmel Studio 7 and Segger J-Link software.
4 . I try on native Win10 machine and everything the same as Win10 with Parallels.

Only with 3.9 & 3.10, with 3.7 everything is perfect.

Pedrinbeep
 
Posts: 16
Joined: Sun Jul 14, 2019 10:37 am

Re: SAMD51 (M4) board users: update your bootloaders to >=v3

by danhalbert on Sat Jun 06, 2020 12:03 pm

I'm not sure what you mean by a "custom" board UF2. Do you mean you made another version of the bootloader updater for your own custom board?

danhalbert
 
Posts: 2122
Joined: Tue Aug 08, 2017 12:37 pm

Re: SAMD51 (M4) board users: update your bootloaders to >=v3

by Pedrinbeep on Sat Jun 06, 2020 1:34 pm

Yes, without modified anything except some "names" (VENDOR_NAME, PRODUCT_NAME, VOLUME_LABEL, INDEX_URL, BOARD_ID, USB_VID and USB_PID") upload to the same board (Grand Central) and on custom board (same PCB design but with everything solder by me just for study electronics, etc).

Pedrinbeep
 
Posts: 16
Joined: Sun Jul 14, 2019 10:37 am

Re: SAMD51 (M4) board users: update your bootloaders to >=v3

by aklitman on Fri Jun 19, 2020 5:16 pm

I have a pair of older M4's which I would like to use. In following the UF2 bootloader update, I have a curious anomaly. I am using a Win 10 machine and have tried 2 different USB cables. The existing bootloader INFO_UF2.TXT is:
V1.23.1-adafruitUF2 Bootloader v1.23.1-adafruit.1-88-g797305f SFHWRO
Model: Grand Central M4 Express
Board-ID: SAMD51P20A-GrandCentral-v0

When I drag my new uf2 file (5.3.0.uf2), it flashes and reboots to the CIRCUITPY drive. I double click RESET and when I check the INFO_UF2.TXT file - nothing has changed.

I unplug and reboot the M4 and it still has the same INFO_UF2.TXT as listed above. I am open to input.

Austin

aklitman
 
Posts: 6
Joined: Fri Nov 11, 2011 9:08 am

Re: SAMD51 (M4) board users: update your bootloaders to >=v3

by danhalbert on Fri Jun 19, 2020 5:33 pm

A 5.3.0 UF2 is for CircuitPython. That UF2 is not a bootloader updater, it is CircuitPython. Its name starts with "adafruit-circuitpython".

You need to download the uf2 whose name starts with "update-bootloader...". See the box on the lower right on this page: https://circuitpython.org/board/grandce ... 4_express/, and click on the "DOWNLOAD UPDATER UF2" link.

danhalbert
 
Posts: 2122
Joined: Tue Aug 08, 2017 12:37 pm

Please be positive and constructive with your questions and comments.