Black Lives Matter - Action and Equality. ... Adafruit is open and shipping.
0

Feather M0 Express Maker.MakeCode Tone (not)
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Feather M0 Express Maker.MakeCode Tone (not)

by Virgil_Machine on Sat Jun 15, 2019 3:07 pm

I have been trying a simple play tone sketch on maker.makecode with a Feather M0 Express.

I get a lot of other stuff to work (on button press, light blinking, IR sensor), but when I try even the simplest example from their tutorial using a piezo connected ti A0 and GND, all I get is a single high pitched tone that does not stop. If tries multiple tones with "rests" in between, different feathers, different piezos--same result.

I've also tries similar arduino code with the same hardware, and that works as expected, as does the web simulator.

My hypothesis is that the maker.makecode play tone function does not work for the Feather M0 Express. Has anyone tried or heard any thing about this?

Here's a screen shot of a very simple example that behaves as described above (yes I know it's play sound, but play tone has the exact same problem).
makecode.jpg
makecode.jpg (115.85 KiB) Viewed 218 times

Virgil_Machine
 
Posts: 114
Joined: Sun Apr 13, 2014 6:39 pm

Re: Feather M0 Express Maker.MakeCode Tone (not)

by johnpark on Mon Jun 17, 2019 12:15 pm

I got the same response -- no audio. I'm adding this to an existing bug report for Trinket M0, as it may be related. https://github.com/microsoft/pxt-maker/issues/234

johnpark
 
Posts: 758
Joined: Wed Mar 25, 2009 2:15 pm

Re: Feather M0 Express Maker.MakeCode Tone (not)

by Virgil_Machine on Mon Jun 17, 2019 12:47 pm

Thank you. FYI--I just tried it with a Metro M0 Express with the same result. Does indeed sound like a bug.

I cross-posted on the maker.makecode forum. No response yet.

Virgil_Machine
 
Posts: 114
Joined: Sun Apr 13, 2014 6:39 pm

Please be positive and constructive with your questions and comments.