Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

Issue with Pygamer not starting
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Issue with Pygamer not starting

by ysiegel on Sat Mar 07, 2020 7:00 pm

Hello,
I have a pygamer that I use with makecode. It works well but regularly after few hours it does not work anymore, ie black screen, blinking red led.
Same if I plug it to power through usb (rather than battery). If I connect it to the computer, after a few reset I am able to upload the UF2 again and it works for few hours. Any idea what’s happening?
Thanks

ysiegel
 
Posts: 6
Joined: Mon May 27, 2019 8:13 am

Re: Issue with Pygamer not starting

by johnpark on Mon Mar 09, 2020 2:28 pm

Could you try loading the pygamer_test.uf2 file from this page https://learn.adafruit.com/adafruit-pyg ... duino-test

and see if you have any trouble running that for a few hours.

johnpark
 
Posts: 767
Joined: Wed Mar 25, 2009 2:15 pm

Re: Issue with Pygamer not starting

by ysiegel on Thu Mar 12, 2020 12:20 am

Hello,
Thanks for your reply.
I have tried yesterday evening. The example worked fine (although I discovered that contact on button A was not great).
It worked when connected to computer.
It worked after unplugging on the battery power
I have tried a few times to put it on back check and turn it off. No problem

This morning again it worked fine once.

But few minute later I tried again and it did not start and got all led red as with projects.

This was also the case if connected to power.
I guess it is not normal...

By the way another question: I saw the great Arduino Arvada examples which I did not know about and wanted to test some but could not upload from Arduino IDE despite installing all board and libs... it seems at compilation time it looks for the code in the individual lib folders rather than underlying src folder... any idea?
Many thanks!

ysiegel
 
Posts: 6
Joined: Mon May 27, 2019 8:13 am

Re: Issue with Pygamer not starting

by johnpark on Thu Mar 12, 2020 12:58 am

Something in that sounds like a hardware problem. Please email support @ adafruit . com to have a replacement sent out. Please reference this forum post and your original order number.

johnpark
 
Posts: 767
Joined: Wed Mar 25, 2009 2:15 pm

Re: Issue with Pygamer not starting

by ysiegel on Wed Mar 18, 2020 8:11 am

Many thanks, I did and already received a replacement!
Will check it

Did you have a chance to see my other question on Arcade example in previous post?
I would like to try the example but face an issue with compilation
May have done something wrong...

Thanks again

ysiegel
 
Posts: 6
Joined: Mon May 27, 2019 8:13 am

Re: Issue with Pygamer not starting

by ysiegel on Wed Mar 18, 2020 8:24 am

Actually fyi I just managed to compile and upload successfully few examples...
not sure why!
Thanks

ysiegel
 
Posts: 6
Joined: Mon May 27, 2019 8:13 am

Re: Issue with Pygamer not starting

by ysiegel on Wed Mar 18, 2020 8:32 am

Sorry, actually some example work and some other don't, not sure why

messages is Invalid library found in /Users/myaccount/Documents/Arduino/libraries/SD: no headers files (.h) found in /Users/myaccount/Documents/Arduino/libraries/SD

For SD, bridge, ethernet
Thanks,

ysiegel
 
Posts: 6
Joined: Mon May 27, 2019 8:13 am

Re: Issue with Pygamer not starting

by johnpark on Mon Mar 30, 2020 6:02 pm

Hmm, those ones are new ones to me -- which example code is trying to use SD card library? Maybe try to update those libraries (or uninstall/reinstall) in Arduino.

johnpark
 
Posts: 767
Joined: Wed Mar 25, 2009 2:15 pm

Please be positive and constructive with your questions and comments.