0

PyGamer - USB not recognized
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

PyGamer - USB not recognized

by Profshanks on Sat Feb 06, 2021 2:27 pm

I have a PyGamer that I received in an AdaBox. Used it with not problems; ignored it for a few months; now when I turn it on all I get is 5 red leds. The charge light is yellow; D13 blinks slowly. My computer claims "USB device not recognized." (see attached screenshot).

I am guessing that the firmware/bootloader is toast, but it won't come up as a drive, so I cant do the .uf2 thing. Which makes the MakeCode thing kinda impossible...

I have a good cord (with charge-only cords it does not throw the "USB device not recognized" error, it just sits there and tries to charge). I have tried ALL of my cords, and I have a lot of them. The cord is not the problem here...

Any ideas how I can try to refresh the bootloader/firmware if it won't recognize the USB?

Many thanks,
profShanks
Attachments
sqldeveloper64W_F6ixSTgvFz.png
sqldeveloper64W_F6ixSTgvFz.png (84.23 KiB) Viewed 265 times

Profshanks
 
Posts: 16
Joined: Sat Nov 04, 2017 11:39 am

Re: PyGamer - USB not recognized

by johnpark on Tue Feb 09, 2021 1:09 pm

With it plugged in over USB have you tried both single- and double-pressing the PyGamer's reset button?

There are also issues around having Kaspersky anti-virus running which blocks the appearance of the CIRCUITPY drive. That and some other troubleshooting tips on this page may be worth a look https://learn.adafruit.com/welcome-to-c ... leshooting

johnpark
 
Posts: 881
Joined: Wed Mar 25, 2009 2:15 pm

Please be positive and constructive with your questions and comments.


cron