0

Please downgrade Python in CLUE package Arduino
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Please downgrade Python in CLUE package Arduino

by blnkjns on Sat May 22, 2021 5:31 am

The Python runtime in the CLUE board file for the Arduino IDE is requiring OSX 10.13. I know there are python 3 runtimes that work on 10.11. Can you fix this in an upgrade to the nRF52 package, as the baseline for Arduino 1.8.13 is OS 10.11, not OX 10.13. It will increase the usable Mac types with a lot of models still at schools.
Now the Arduino IDE throws these errors:
Code: Select all | TOGGLE FULL SIZE
[11547] Error loading Python lib '/var/folders/gk/s9m9x2t13ys0493jh09b4k9c0000gn/T/_MEI3lRWu6/Python': dlopen: dlopen(/var/folders/gk/s9m9x2t13ys0493jh09b4k9c0000gn/T/_MEI3lRWu6/Python, 10): Symbol not found: _clock_getres
  Referenced from: /var/folders/gk/s9m9x2t13ys0493jh09b4k9c0000gn/T/_MEI3lRWu6/Python (which was built for Mac OS X 10.13)
  Expected in: /usr/lib/libSystem.B.dylib
 in /var/folders/gk/s9m9x2t13ys0493jh09b4k9c0000gn/T/_MEI3lRWu6/Python
exit status 255


Why is there Python code in Arduino board files uberhaupt? Feels very weird.

blnkjns
 
Posts: 663
Joined: Fri Oct 02, 2020 3:33 am

Please be positive and constructive with your questions and comments.


cron