Bootloop on Magtag

adafruit.io wippersnapper BETA support, discussions, and more!

Moderators: adafruit_support_bill, adafruit

Forum rules
If you're posting code, please make sure your code does not include your Adafruit IO Active Key or WiFi network credentials.
User avatar
ceedon
 
Posts: 4
Joined: Thu May 20, 2021 10:29 pm

Bootloop on Magtag

Post by ceedon »

After replacing demoboot bin with adafruit-wippersnapper-esp32s2-magtag-1-0-0-beta.3.uf2 from bootloader mode, the first reset results in solid red indictors.
Subsequent resets result in a flash of blue/cyan followed by a reset.
The WIPPER drive appears briefly.

Same process (with proper .uf2) works fine for FunHouse.

The MagTag is the newer version w/ black mask.
https://www.adafruit.com/product/4819

User avatar
brubell
 
Posts: 1711
Joined: Fri Jul 17, 2015 10:33 pm

Re: Bootloop on Magtag

Post by brubell »

Did you have the same issue with loading beta.2 (attached)?
Attachments

[The extension uf2 has been deactivated and can no longer be displayed.]


User avatar
brubell
 
Posts: 1711
Joined: Fri Jul 17, 2015 10:33 pm

Re: Bootloop on Magtag

Post by brubell »

Also, which operating system is on your host PC?

User avatar
ceedon
 
Posts: 4
Joined: Thu May 20, 2021 10:29 pm

Re: Bootloop on Magtag

Post by ceedon »

Win10. Will try loading the other file later today.

User avatar
ceedon
 
Posts: 4
Joined: Thu May 20, 2021 10:29 pm

Re: Bootloop on Magtag

Post by ceedon »

Same behavior in the loop. Green+Blue lights flash -> reset. No solid red first time, though.

User avatar
brubell
 
Posts: 1711
Joined: Fri Jul 17, 2015 10:33 pm

Re: Bootloop on Magtag

Post by brubell »

ceedon wrote:Same behavior in the loop. Green+Blue lights flash -> reset. No solid red first time, though.
What's the output of the 'wippersnapper_boot_out.txt' file on the WIPPER drive?

User avatar
ceedon
 
Posts: 4
Joined: Thu May 20, 2021 10:29 pm

Re: Bootloop on Magtag

Post by ceedon »

It doesn't stay up long enough to grab it. Any tips to work around that? Can figure out a script if not.
Can try from linux as well. Haven't done so yet.

User avatar
shamste
 
Posts: 8
Joined: Wed Jan 13, 2021 12:34 am

Re: Bootloop on Magtag

Post by shamste »

I'm having the same issues with Beta.2 and Beta.3.

User avatar
scottlnrd
 
Posts: 7
Joined: Mon Mar 10, 2014 10:37 pm

Re: Bootloop on Magtag

Post by scottlnrd »

I'm having the same issue as well. I'm loading it from a Mac running latest OS.

User avatar
brubell
 
Posts: 1711
Joined: Fri Jul 17, 2015 10:33 pm

Re: Bootloop on Magtag

Post by brubell »

shamste wrote:I'm having the same issues with Beta.2 and Beta.3.
Also with MagTag?

User avatar
brubell
 
Posts: 1711
Joined: Fri Jul 17, 2015 10:33 pm

Re: Bootloop on Magtag

Post by brubell »

scottlnrd wrote:I'm having the same issue as well. I'm loading it from a Mac running latest OS.
Also with MagTag?

User avatar
scottlnrd
 
Posts: 7
Joined: Mon Mar 10, 2014 10:37 pm

Re: Bootloop on Magtag

Post by scottlnrd »

Yes, MagTag.

User avatar
scottlnrd
 
Posts: 7
Joined: Mon Mar 10, 2014 10:37 pm

Re: Bootloop on Magtag

Post by scottlnrd »

I completely erased my MagTag and started from scratch. After I drag the Wippersnapper beta onto the drive and it reboots, the Magtag flashes it's LEDs two blueish colors for several times until it finally stops the cycle, ending in all red LEDs. But never mounts the drive long enough to see anything on it.

User avatar
brubell
 
Posts: 1711
Joined: Fri Jul 17, 2015 10:33 pm

Re: Bootloop on Magtag

Post by brubell »

ceedon wrote:It doesn't stay up long enough to grab it. Any tips to work around that? Can figure out a script if not.
Can try from linux as well. Haven't done so yet.
Any luck on Linux?

User avatar
scottlnrd
 
Posts: 7
Joined: Mon Mar 10, 2014 10:37 pm

Re: Bootloop on Magtag

Post by scottlnrd »

I don't think this is an issue of what OS it's running from. It would seem to be a boot loader issue from the wippersnapper uf2 file. There are also at least a couple revisions of this device if I'm reading correctly. Could it be that wippersnapper only works on one of them?

Locked
Forum rules
If you're posting code, please make sure your code does not include your Adafruit IO Active Key or WiFi network credentials.

Return to “Adafruit IO Wippersnapper Beta”