beta.7 Metro Airlift - drops offline

adafruit.io wippersnapper BETA support, discussions, and more!

Moderators: adafruit_support_bill, adafruit

Forum rules
If you're posting code, please make sure your code does not include your Adafruit IO Active Key or WiFi network credentials.
Locked
User avatar
SandPig
 
Posts: 44
Joined: Sun Sep 10, 2017 8:25 am

beta.7 Metro Airlift - drops offline

Post by SandPig »

beta.7 (and 6) on the MetroAirlift work fine, but lose connection to Adafruit IO
the device is not rebooting. serial is quiet while it's offline and dashboard commands issued while offline to not get applied once the board returns to an online state. For the brief moment it is online, commands (led blink) work fine.

07:08:43.002 -> Registering Board...
07:08:43.002 -> registerBoard()
07:08:43.002 -> Encoding registration message...Encoded!
07:08:43.002 -> Publishing registration message...Published!
07:08:43.283 -> -> Registration Message
07:08:43.283 -> Found hardware with:
07:08:43.283 -> GPIO Pins: 14
07:08:43.283 -> Analog Pins: 6
07:08:43.283 -> Reference voltage: 3.30v
07:08:43.283 ->
07:08:43.283 -> Successfully checked in, waiting for commands...
07:08:43.283 -> cbSignalTopic: New Msg on Signal Topic
07:08:43.283 -> 15 bytes.
07:08:43.283 -> decodeSignalMsg
07:08:43.283 -> cbSignalMsg
07:08:43.283 -> Sub-messages found: 1
07:08:43.283 -> Signal Msg Tag: Pin Configuration
07:08:43.283 -> cbDecodePinConfigMsg
07:08:43.283 -> configurePinRequest
07:08:43.283 -> Configured digital output pin on D13
07:08:43.283 -> cbSignalTopic: New Msg on Signal Topic
07:08:43.283 -> 12 bytes.
07:08:43.283 -> decodeSignalMsg
07:08:43.318 -> cbSignalMsg
07:08:43.318 -> Sub-messages found: 1
07:08:43.318 -> Signal Msg Tag: Pin Event
07:08:43.318 -> cbDecodePinEventMsg
07:08:43.318 -> Digital Pin Event: Set 13 to 1
07:08:43.387 -> Registered board with Wippersnapper.
07:08:50.672 -> PING!
07:08:58.651 -> PING!
07:09:06.635 -> PING!
07:09:14.333 -> PING!
07:09:21.988 -> PING!
07:09:29.693 -> PING!
07:09:37.678 -> PING!


the board drops offline and immediately the board LED goes solid blue
a few seconds later the led clears and the serial shows the PING and the board is now online and remains connected for 1-2 seconds (at best)
then the blue LED returns for several seconds until it clears and we get another ping
the wipper drive is accessible at all times after initial boot.

I hope this helps, please let me know if you need any other bits of info from me.

User avatar
jerryn
 
Posts: 1736
Joined: Sat Sep 14, 2013 9:05 am

Re: beta.7 Metro Airlift - drops offline

Post by jerryn »

FYI -- I had similar issues on Beta.6, but beta.7 has be staying online for me (Metro m4 Airlift). It's been up for several hours now.

User avatar
SandPig
 
Posts: 44
Joined: Sun Sep 10, 2017 8:25 am

Re: beta.7 Metro Airlift - drops offline

Post by SandPig »

inspired by jerryn's success, I fired up my Metro Airlift again to start poking around to see if I could get the same result and now there's no issue.
The board connects right up and there's no more drop between pings.
I don't like magic, but hey, it's working!

I'll update if the magic wears off

User avatar
brubell
 
Posts: 1740
Joined: Fri Jul 17, 2015 10:33 pm

Re: beta.7 Metro Airlift - drops offline

Post by brubell »

Could you please try this with the latest beta.8? Thank you!

User avatar
SandPig
 
Posts: 44
Joined: Sun Sep 10, 2017 8:25 am

Re: beta.7 Metro Airlift - drops offline

Post by SandPig »

after beta.8 load, no disk is mounted and I've got a solid red led - no serial output (no port to monitor)
reload beta.7, no issues

User avatar
brubell
 
Posts: 1740
Joined: Fri Jul 17, 2015 10:33 pm

Re: beta.7 Metro Airlift - drops offline

Post by brubell »

SandPig wrote:after beta.8 load, no disk is mounted and I've got a solid red led - no serial output (no port to monitor)
reload beta.7, no issues
Thank you for reporting, I'll be taking a look at this issue this upcoming week.

User avatar
brubell
 
Posts: 1740
Joined: Fri Jul 17, 2015 10:33 pm

Re: beta.7 Metro Airlift - drops offline

Post by brubell »

brubell wrote:
SandPig wrote:after beta.8 load, no disk is mounted and I've got a solid red led - no serial output (no port to monitor)
reload beta.7, no issues
Thank you for reporting, I'll be taking a look at this issue this upcoming week.
Could you try updating the UF2 bootloader version, then load Beta.8 onto the AirLift:

https://learn.adafruit.com/adafruit-met ... bootloader

User avatar
SandPig
 
Posts: 44
Joined: Sun Sep 10, 2017 8:25 am

Re: beta.7 Metro Airlift - drops offline

Post by SandPig »

from:
UF2 Bootloader v3.3.0-adafruit.10 SFHWRO
Model: Metro M4 AirLift
Board-ID: SAMD51J19A-Metro-AirLift-v0

to:
UF2 Bootloader v3.13.0 SFHWRO
Model: Metro M4 AirLift
Board-ID: SAMD51J19A-Metro-AirLift-v0

similar result:
beta.7 works, beta.8 does not
Load beta.8 and get a red led
No disk, no port to monitor, nothing

side note, I really appreciate you adding a link for uploading the boot loader - I am very short on time (stupid job) and little things like that really help me.

User avatar
brubell
 
Posts: 1740
Joined: Fri Jul 17, 2015 10:33 pm

Re: beta.7 Metro Airlift - drops offline

Post by brubell »

This is on Windows10?

User avatar
SandPig
 
Posts: 44
Joined: Sun Sep 10, 2017 8:25 am

Re: beta.7 Metro Airlift - drops offline

Post by SandPig »

brubell wrote:This is on Windows10?
MacOS 11.5.2 / MacbookAir M1

User avatar
brubell
 
Posts: 1740
Joined: Fri Jul 17, 2015 10:33 pm

Re: beta.7 Metro Airlift - drops offline

Post by brubell »

Is this still occuring with the latest beta.9?

User avatar
SandPig
 
Posts: 44
Joined: Sun Sep 10, 2017 8:25 am

Re: beta.7 Metro Airlift - drops offline

Post by SandPig »

same result from beta.9 - solid red neopixel, no disk, no port to monitor
reload beta.7 - no issue

please let me know if there's anything you want me to poke at

User avatar
SandPig
 
Posts: 44
Joined: Sun Sep 10, 2017 8:25 am

Re: beta.7 Metro Airlift - drops offline

Post by SandPig »

beta.10 is the same, as well
solid red neopixel

User avatar
brubell
 
Posts: 1740
Joined: Fri Jul 17, 2015 10:33 pm

Re: beta.7 Metro Airlift - drops offline

Post by brubell »

Could you try loading the circuitPython 7 UF2 on: https://circuitpython.org/board/metro_m4_airlift_lite/

Then go back to METROBOOT and load WipperSnapper?

User avatar
SandPig
 
Posts: 44
Joined: Sun Sep 10, 2017 8:25 am

Re: beta.7 Metro Airlift - drops offline

Post by SandPig »

brubell wrote:Could you try loading the circuitPython 7 UF2 on: https://circuitpython.org/board/metro_m4_airlift_lite/

Then go back to METROBOOT and load WipperSnapper?
loaded CP7
Adafruit CircuitPython 7.0.0 on 2021-09-20; Adafruit Metro M4 Airlift Lite with samd51j19
Board ID:metro_m4_airlift_lite

then reload beta.10
no change - solid red neopixel

Locked
Forum rules
If you're posting code, please make sure your code does not include your Adafruit IO Active Key or WiFi network credentials.

Return to “Adafruit IO Wippersnapper Beta”