0

Huzzah failure to connect
Moderators: adafruit_support_bill, adafruit

Forum rules
If you're posting code, please make sure your code does not include your Adafruit IO Active Key or WiFi network credentials.
Please be positive and constructive with your questions and comments.

Huzzah failure to connect

by vbrown202 on Wed Dec 15, 2021 1:06 pm

I have attached two boards to Wippersnapper - challenging but successful! I have failed to attach the Huzzah. I upload my wireless data thru the Adafruit_WebSerial_NVMGenerator - it looks like it is loading and asks for a reset. I reset the board and nothing . . . I then read the forum suggestion and uploaded an Arduino sketch - webclient test - which worked fine. Went back to the NVM and reloaded. Still nothing. Help!

vbrown202
 
Posts: 10
Joined: Tue Aug 07, 2018 12:01 pm

Re: Huzzah failure to connect

by brubell on Wed Dec 15, 2021 5:45 pm

It looks like you already have the Arduino IDE installed. Could you please set the port to the ESP32 and open your serial monitor. Copy and paste that data to this forum, as a reply.

I'll be able to look through the trace

brubell
 
Posts: 1678
Joined: Fri Jul 17, 2015 10:33 pm

Re: Huzzah failure to connect

by vbrown202 on Thu Dec 16, 2021 11:29 am

I am sorry but I don't know what it is you need nor how to do it. If I have the IDE open at port 60 the ESP says busy and when I have the ESP ready the IDE says port busy.
I don't know what you want me to display on the serial monitor??

Sorry.

vbrown202
 
Posts: 10
Joined: Tue Aug 07, 2018 12:01 pm

Re: Huzzah failure to connect

by brubell on Thu Dec 16, 2021 12:38 pm

vbrown202 wrote:I am sorry but I don't know what it is you need nor how to do it. If I have the IDE open at port 60 the ESP says busy and when I have the ESP ready the IDE says port busy.
I don't know what you want me to display on the serial monitor??

Sorry.

Is it possible to navigate to https://www.serialterminal.com, click connect, set the baud to 115200?

You should see some output from the board.

brubell
 
Posts: 1678
Joined: Fri Jul 17, 2015 10:33 pm

Re: Huzzah failure to connect

by vbrown202 on Fri Dec 17, 2021 11:15 am

ets Jan 8 2013,rst cause:2, boot mode:(3,7)

ets_main.c [/b]

Only at 74880 baud do I get anything that looks like English (above) from the Arduino monitor. The data at 115200 and all the other speeds are a combination of special characters.

Serialterminal.com would not connect.

This is after I hit the reset button - right??

VB

vbrown202
 
Posts: 10
Joined: Tue Aug 07, 2018 12:01 pm

Re: Huzzah failure to connect

by brubell on Mon Dec 20, 2021 10:53 am

vbrown202 wrote:ets Jan 8 2013,rst cause:2, boot mode:(3,7)

ets_main.c [/b]

Only at 74880 baud do I get anything that looks like English (above) from the Arduino monitor. The data at 115200 and all the other speeds are a combination of special characters.

Serialterminal.com would not connect.

This is after I hit the reset button - right??

VB


I'm not really sure what the issue is at this point. Could you try re-flashing the firmware via https://adafruit.github.io/Adafruit_Web ... MGenerator again?

brubell
 
Posts: 1678
Joined: Fri Jul 17, 2015 10:33 pm

Re: Huzzah failure to connect

by vbrown202 on Mon Dec 27, 2021 11:18 am

This board is the original that came with Adabox 004. The chip that is on this board is not the same as the one on the current Huzzah. Since this board works fine in every way except with Wippersnapper, I'm thinking there is a conflict in the older hardware.

I've tried erasing the board, uploading the Wippersnapper through the ESP tool (which tells me everything uploaded fine) and it still refuses to connect after reset.

I am now giving up. Thank you for trying and have a great new year.

vbrown202
 
Posts: 10
Joined: Tue Aug 07, 2018 12:01 pm

Re: Huzzah failure to connect

by brubell on Tue Dec 28, 2021 12:09 pm

Thanks for the message, we'll look into a possible chip incompatibility between older ESP32 Huzzahs and the current ones.

brubell
 
Posts: 1678
Joined: Fri Jul 17, 2015 10:33 pm

Please be positive and constructive with your questions and comments.