Huzzah failure to connect

adafruit.io wippersnapper BETA support, discussions, and more!

Moderators: adafruit_support_bill, adafruit

Forum rules
If you're posting code, please make sure your code does not include your Adafruit IO Active Key or WiFi network credentials.
Locked
User avatar
vbrown202
 
Posts: 10
Joined: Tue Aug 07, 2018 12:01 pm

Huzzah failure to connect

Post by vbrown202 »

I have attached two boards to Wippersnapper - challenging but successful! I have failed to attach the Huzzah. I upload my wireless data thru the Adafruit_WebSerial_NVMGenerator - it looks like it is loading and asks for a reset. I reset the board and nothing . . . I then read the forum suggestion and uploaded an Arduino sketch - webclient test - which worked fine. Went back to the NVM and reloaded. Still nothing. Help!

User avatar
brubell
 
Posts: 1711
Joined: Fri Jul 17, 2015 10:33 pm

Re: Huzzah failure to connect

Post by brubell »

It looks like you already have the Arduino IDE installed. Could you please set the port to the ESP32 and open your serial monitor. Copy and paste that data to this forum, as a reply.

I'll be able to look through the trace

User avatar
vbrown202
 
Posts: 10
Joined: Tue Aug 07, 2018 12:01 pm

Re: Huzzah failure to connect

Post by vbrown202 »

I am sorry but I don't know what it is you need nor how to do it. If I have the IDE open at port 60 the ESP says busy and when I have the ESP ready the IDE says port busy.
I don't know what you want me to display on the serial monitor??

Sorry.

User avatar
brubell
 
Posts: 1711
Joined: Fri Jul 17, 2015 10:33 pm

Re: Huzzah failure to connect

Post by brubell »

vbrown202 wrote:I am sorry but I don't know what it is you need nor how to do it. If I have the IDE open at port 60 the ESP says busy and when I have the ESP ready the IDE says port busy.
I don't know what you want me to display on the serial monitor??

Sorry.
Is it possible to navigate to https://www.serialterminal.com, click connect, set the baud to 115200?

You should see some output from the board.

User avatar
vbrown202
 
Posts: 10
Joined: Tue Aug 07, 2018 12:01 pm

Re: Huzzah failure to connect

Post by vbrown202 »

ets Jan 8 2013,rst cause:2, boot mode:(3,7)

ets_main.c [/b]

Only at 74880 baud do I get anything that looks like English (above) from the Arduino monitor. The data at 115200 and all the other speeds are a combination of special characters.

Serialterminal.com would not connect.

This is after I hit the reset button - right??

VB

User avatar
brubell
 
Posts: 1711
Joined: Fri Jul 17, 2015 10:33 pm

Re: Huzzah failure to connect

Post by brubell »

vbrown202 wrote:ets Jan 8 2013,rst cause:2, boot mode:(3,7)

ets_main.c [/b]

Only at 74880 baud do I get anything that looks like English (above) from the Arduino monitor. The data at 115200 and all the other speeds are a combination of special characters.

Serialterminal.com would not connect.

This is after I hit the reset button - right??

VB
I'm not really sure what the issue is at this point. Could you try re-flashing the firmware via https://adafruit.github.io/Adafruit_Web ... MGenerator again?

User avatar
vbrown202
 
Posts: 10
Joined: Tue Aug 07, 2018 12:01 pm

Re: Huzzah failure to connect

Post by vbrown202 »

This board is the original that came with Adabox 004. The chip that is on this board is not the same as the one on the current Huzzah. Since this board works fine in every way except with Wippersnapper, I'm thinking there is a conflict in the older hardware.

I've tried erasing the board, uploading the Wippersnapper through the ESP tool (which tells me everything uploaded fine) and it still refuses to connect after reset.

I am now giving up. Thank you for trying and have a great new year.

User avatar
brubell
 
Posts: 1711
Joined: Fri Jul 17, 2015 10:33 pm

Re: Huzzah failure to connect

Post by brubell »

Thanks for the message, we'll look into a possible chip incompatibility between older ESP32 Huzzahs and the current ones.

Locked
Forum rules
If you're posting code, please make sure your code does not include your Adafruit IO Active Key or WiFi network credentials.

Return to “Adafruit IO Wippersnapper Beta”