HUZZAH ESP32 Beta 19 Unable to connect to Adafruit.IO

adafruit.io wippersnapper BETA support, discussions, and more!

Moderators: adafruit_support_bill, adafruit

Forum rules
If you're posting code, please make sure your code does not include your Adafruit IO Active Key or WiFi network credentials.
Locked
adafruitguy
 
Posts: 187
Joined: Sat Jun 07, 2014 7:52 am

HUZZAH ESP32 Beta 19 Unable to connect to Adafruit.IO

Post by adafruitguy »

My Adafruit Feather HUZZAH ESP32 will no longer connect to WipperSnapper after upgrading from beta.16

It looks like it can't connect to Adafruit.IO, but the "Connecting to: " blank looks odd....

Code: Select all

rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
ets Jun  8 2016 00:22:57

rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
configsip: 0, SPIWP:0xee
clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
mode:DIO, clock div:1
load:0x3fff0030,len:1252
load:0x40078000,len:12732
load:0x40080400,len:3100
entry 0x400805ec
Subscribing to MQTT topics...
Added sub 0
Added sub 1
Added sub 2
Added sub 3
Added sub 4
Connecting to: 
Connect result: 0
Connecting to: 
Connect result: 0
Connecting to: 
Connect result: 0
Connecting to: 
Connect result: 0
Connecting to: 
Connect result: 0
Connecting to: 
Connect result: 0
Connecting to: 
Connect result: 0
Connecting to: 
Connect result: 0
Connecting to: 
Connect result: 0
Connecting to: 
Connect result: 0
Connecting to: 
Connect result: 0
ERROR: Unable to connect to Adafruit.IO

User avatar
brubell
 
Posts: 1711
Joined: Fri Jul 17, 2015 10:33 pm

Re: HUZZAH ESP32 Beta 19 Unable to connect to Adafruit.IO

Post by brubell »

Hi - thank you for reporting! I've added an issue on the firmware repository and will take a look at it.

https://github.com/adafruit/Adafruit_Wi ... issues/198

User avatar
brubell
 
Posts: 1711
Joined: Fri Jul 17, 2015 10:33 pm

Re: HUZZAH ESP32 Beta 19 Unable to connect to Adafruit.IO

Post by brubell »

We've resolved this issue in beta.20, please update your Huzzah ESP32 to beta.20 using the NVMGenerator tool.

p.s: Could you also try the feather which wasn't working prior, with this firmware too?

adafruitguy
 
Posts: 187
Joined: Sat Jun 07, 2014 7:52 am

Re: HUZZAH ESP32 Beta 19 Unable to connect to Adafruit.IO

Post by adafruitguy »

Thank you Brent!

Yes, Device 2: previously running beta.16, not connecting on beta.19, currently connects with beta.20.

No, Device 1: going back to ~beta.12, initially connects to share it's firmware version number with IO - but does not remain connected.
Yes and no
Yes and no
Screen Shot 2022-01-04 at 12.41.49 PM.png (290.29 KiB) Viewed 607 times
Something interesting is happening... Unrelated to WipperSnapper, but seemingly impacting Device 2...

I have a feed that comes in to Adafruit IO via NodeRed, originating via TTN. NodeRed does some rewriting of the TTN data to satisfy the Adafruit IO webhooks format.

Every 10 minutes or so, something in my NodeRed data is "missing a required value" and Adafruit IO throws an error for this unrelated feed.
Adafruit IO MQTT Error
Adafruit IO MQTT Error
Screen Shot 2022-01-04 at 12.55.42 PM.png (178.59 KiB) Viewed 607 times
This unrelated / errored other feed seems to trigger a watchdog on Device 2, causing it to reboot...

Code: Select all

Looking for subscription len 18
Found sub #3
Data len: 88
Data: "error saving data to adafruitguy/feeds/REDACTED, data missing required value"
IO Ban Error: "error saving data to adafruitguy/feeds/REDACTED, data missing required value"
Disconnecting from MQTT..MQTT disconnect packet:
          [0xE0],   [0x00], 
Client sendPacket returned: 2
E (234460) task_wdt: Task watchdog got triggered. The following tasks did not reset the watchdog in time:
E (234460) task_wdt:  - loopTask (CPU 1)
E (234460) task_wdt: Tasks currently running:
E (234460) task_wdt: CPU 0: IDLE
E (234460) task_wdt: CPU 1: IDLE
E (234460) task_wdt: Aborting.

abort() was called at PC 0x400ef60d on core 0


Backtrace:0x4008365d:0x3ffbea7c |<-CORRUPTED




ELF file SHA256: 0000000000000000

User avatar
brubell
 
Posts: 1711
Joined: Fri Jul 17, 2015 10:33 pm

Re: HUZZAH ESP32 Beta 19 Unable to connect to Adafruit.IO

Post by brubell »

1)
No, Device 1: going back to ~beta.12, initially connects to share it's firmware version number with IO - but does not remain connected.
To clarify, device 1 does not connect at all with Beta.20? What happens?



2) Could you email us the feed name so we can take a look into this? Please include your node red setup incl. the payload being sent. What does your device interface for Device 2 look like? Could you attach a screenshot?

adafruitguy
 
Posts: 187
Joined: Sat Jun 07, 2014 7:52 am

Re: HUZZAH ESP32 Beta 19 Unable to connect to Adafruit.IO

Post by adafruitguy »

Device 1, starts the connection, registers, and then quickly gets into a loop with...

Code: Select all

Polling for registration message response...2
Polling for registration message response...2
Polling for registration message response...2
Polling for registration message response...2
Polling for registration message response...2
Polling for registration message response...2
Polling for registration message response...2
Polling for registration message response...2
Polling for registration message response...2
Never getting "online". I will send detailed serial output via email.

adafruitguy
 
Posts: 187
Joined: Sat Jun 07, 2014 7:52 am

Re: HUZZAH ESP32 Beta 19 Unable to connect to Adafruit.IO

Post by adafruitguy »

Full Device 1 serial sent via email.
Last edited by adafruitguy on Tue Jan 04, 2022 5:40 pm, edited 1 time in total.

adafruitguy
 
Posts: 187
Joined: Sat Jun 07, 2014 7:52 am

Re: HUZZAH ESP32 Beta 19 Unable to connect to Adafruit.IO

Post by adafruitguy »

Device 2 Dashboard...
Device 2
Device 2
Screen Shot 2022-01-04 at 4.32.09 PM.png (286.16 KiB) Viewed 597 times
Device 2 Scan...
Device 2 Scan
Device 2 Scan
Screen Shot 2022-01-04 at 4.32.24 PM.png (57.12 KiB) Viewed 597 times
I will send the offending feed name via email.

adafruitguy
 
Posts: 187
Joined: Sat Jun 07, 2014 7:52 am

Re: HUZZAH ESP32 Beta 19 Unable to connect to Adafruit.IO

Post by adafruitguy »

MQTT feed between TTN and Node-RED, rewrite the data to meet Adafruit IO's sensibilities, and webhook to feed it to IO....
Node-RED Nodes
Node-RED Nodes
Screen Shot 2022-01-04 at 5.29.47 PM.png (233.88 KiB) Viewed 591 times
Rewrite logic...
Change to CO2 to format Addafruit IO is expecting
Change to CO2 to format Addafruit IO is expecting
Screen Shot 2022-01-04 at 5.20.34 PM.png (668.52 KiB) Viewed 591 times

Locked
Forum rules
If you're posting code, please make sure your code does not include your Adafruit IO Active Key or WiFi network credentials.

Return to “Adafruit IO Wippersnapper Beta”