Breaking Change for WipperSnapper on Feather Huzzah ESP32 an

adafruit.io wippersnapper BETA support, discussions, and more!

Moderators: adafruit_support_bill, adafruit

Forum rules
If you're posting code, please make sure your code does not include your Adafruit IO Active Key or WiFi network credentials.
Locked
User avatar
lorennorman
 
Posts: 3
Joined: Wed Mar 04, 2020 12:54 pm

Breaking Change for WipperSnapper on Feather Huzzah ESP32 an

Post by lorennorman »

If you're suddenly having WipperSnapper issues using a Feather Huzzah ESP32 or Feather Huzzah ESP8266, it is probably not your fault!

Perhaps you're seeing this error (or similar) when logged into Adafruit IO:

Code: Select all

`Firmware out of date! Quickly update this board (adafruit-huzzah-32) at: https://adafruit.github.io/WipperSnapper_Firmware_Uploader`
Like the message says, these boards will need to update to WipperSnapper Firmware version beta.28 (or higher) via our firmware tool:
https://adafruit.github.io/WipperSnappe ... e_Uploader

This is a breaking change we needed to make in order to support automation of the firmware tool going forward. Unfortunately, we don't yet have a good way to communicate to the board that it is using deprecated firmware, so the behavior you see may be a reboot loop.

In the future (once out of beta) we'll have better usability around these inevitable breaking changes.

Locked
Forum rules
If you're posting code, please make sure your code does not include your Adafruit IO Active Key or WiFi network credentials.

Return to “Adafruit IO Wippersnapper Beta”