0

can't get QT Py ESP32-S3 to connect
Moderators: adafruit_support_bill, adafruit

Forum rules
If you're posting code, please make sure your code does not include your Adafruit IO Active Key or WiFi network credentials.
Please be positive and constructive with your questions and comments.

can't get QT Py ESP32-S3 to connect

by BlitzCityDIY on Tue Jun 14, 2022 3:09 pm

Hello,

I'm working on the product guide for the QT Py ESP32-S3 and am trying to get the board connected to WipperSnapper. I'm on Windows 10 and am using a good data USB-C cable (purple one from the shop). I'm able to load the UF2 installer onto the board and see the file system.

I'm able to edit the secrets.json so that it matches this:
Code: Select all | TOGGLE FULL SIZE
{
    "io_username": "YOUR_IO_USERNAME_HERE",
    "io_key": "YOUR_IO_KEY_HERE",
    "network_type_wifi_native": {
      "network_ssid": "YOUR_WIFI_SSID_HERE",
      "network_password": "YOUR_WIFI_PASS_HERE"
    }
}


and that stops the neopixel from blinking yellow, followed by it showing solid yellow. I'm ejecting the drive and then hitting reset once with the WipperSnapper page open in IO, but the neopixel blinks yellow again and then eventually goes solid yellow without anything showing up on the WipperSnapper page. After a while (2 minutes-ish), it seems to eject itself, neopixel flashes purple once, and the cycle begins again. Any help would be appreciated.

BlitzCityDIY
 
Posts: 4
Joined: Sun Feb 11, 2018 10:20 pm

Re: can't get QT Py ESP32-S3 to connect

by BlitzCityDIY on Tue Jun 14, 2022 3:31 pm

I might be having WiFi issues in general with the board after some further testing with Arduino. Will do some further troubleshooting.

BlitzCityDIY
 
Posts: 4
Joined: Sun Feb 11, 2018 10:20 pm

Please be positive and constructive with your questions and comments.