0

I have no idea what i'm doing. Please help.
Moderators: altitude, adafruit_support_bill, adafruit, hamburgers, phono

Please be positive and constructive with your questions and comments.

I have no idea what i'm doing. Please help.

by Lucke on Wed Jun 09, 2021 6:10 pm

I'm just getting started with using MIDI and DAWs.

I'm using Ableton and trying to get a modded XOX to connect to it so I can program beats using the PC rather than the keyboard on the XOX.

So far from searching forums I've heard how the USB on the XOX is only for updating firmware and not for actually connecting for MIDI? But have also heard people say they've edited MIDI via USB?

I can't get my XOX to be seen in Device Manager. I've tried following links and doing FTDI installs. CDM21236 - if that helps?

I'm at a loss for what to do other than buy a MIDI interface and see if that works.

Any help and/or advice is much appreciated.

Lucke
 
Posts: 4
Joined: Wed Jun 09, 2021 5:34 pm

Re: I have no idea what i'm doing. Please help.

by Lucke on Sat Jun 12, 2021 12:13 pm

UPDATE: I've got c0nbx working and it says it is detecting the X0X!

I am now looking into getting MarOs for pattern editing on the PC. Not really sure how this fits in with Ableton yet as mentioned I'm totally new to all this, but should be fun to figure it out.

Currently when I go to check the firmware of my X0X on cbox it doesn't detect any... So trying to update the firmware... Could someone help with letting me know what firmware I need and where to get it?

As for getting Mar0S to work, I have the Mar0S15 and MarOS150 folders but don't really know what I'm supposed to do with them... When I go to select the hex's of them in cnb0x it says 'Error: couldn't get DeviceID string'. I am in bootload mode in case you're wondering.

NOTE: Cbox is a banned spam word apparently so I had to do a work around on how I spell it. Not ideal....

Lucke
 
Posts: 4
Joined: Wed Jun 09, 2021 5:34 pm

Re: I have no idea what i'm doing. Please help.

by Lucke on Sat Jun 12, 2021 5:57 pm

Seems it wasn't the x0x that was being detected which was the reason for the errors ins conb0x.

Apparently using different USB cables can work.

Lucke
 
Posts: 4
Joined: Wed Jun 09, 2021 5:34 pm

Re: I have no idea what i'm doing. Please help.

by Lucke on Sun Jun 13, 2021 2:18 pm

Even more confused now as I can manage to only sometimes connect to the box. And this is only when I am not using FTDI drivers. In order to even have the USB Serial Port come up I have to change my Communications Port driver manually, and I have to tick off the compatible drivers list.... When using FTDI drivers all I get is the USB serial port (COMx) but nothing in the USB Serial Converter. I also have a sign saying the COM port is not being used properly. When I go to manually update the FTDI driver it won't do anything. As in it doesn't make the USB Serial Converter. This seems like a big part of the problem, but I don't know what else I can do... And of course, when I've gone to use the FTDI driver with the box connected, it doesn't find the connection. I've tried matching Baud Rates, default was 9600, I changed to conbox's 19200 default etc. and vice versa.


On the case that I did manage to connect, when I went into pattern editor on conbox, I couldn't get anything to actually apply to the x0x. I tried pretty much all the modes on the x0x, but nothing. Is this because a MIDI cable is needed? If not then it could be the case that if I can't get MarOs to work then i'll stay with SokkOs and have to use the conbox editor if it will work...

Lucke
 
Posts: 4
Joined: Wed Jun 09, 2021 5:34 pm

Please be positive and constructive with your questions and comments.


cron