0
Please be positive and constructive with your questions and comments.

Re: c0nb0x

by antto on Mon Jul 22, 2013 12:40 pm

if it cannot connect to the firmware (Ping == BAD) that is already a sign that something isn't right with the serial port or the settings

make sure you have installed the USB<->Serial drivers (FTDI)
make sure the port is correct, also make sure the baudrate is 19200
you should be able to connect to the firmware without any problems

once you can connect - you can then try flashing the firmware
We are here too: irc.freenode.net >>> #x0xb0x
..:: c0nb0x v1.00 ::.. http://forums.adafruit.com/viewtopic.php?f=7&t=29282 (new control app - win/osx)
VCO Tuning: http://forums.adafruit.com/viewtopic.php?f=12&t=24759 (do it the EASY way)

antto
 
Posts: 1636
Joined: Thu Apr 15, 2010 3:21 pm
Location: 127.0.0.1

Re: c0nb0x

by antto on Mon Jul 22, 2013 12:46 pm

opening the serial port means that there IS such a port in the OS (it could be a real one, or a virtual one)
but that doesn't mean that anything is connected to it
if there's nothing connected to it (or there is, but is switched off) - the app will only send data to the port, but won't get any reply

on Windows, the USB<->Serial driver creates a virtual serial port only when the x0x is plugged in, and powered ON
this port dissapears when you unplug the cable or switch the x0x OFF

however, if it was a real serial port - it will never dissapear from the OS
We are here too: irc.freenode.net >>> #x0xb0x
..:: c0nb0x v1.00 ::.. http://forums.adafruit.com/viewtopic.php?f=7&t=29282 (new control app - win/osx)
VCO Tuning: http://forums.adafruit.com/viewtopic.php?f=12&t=24759 (do it the EASY way)

antto
 
Posts: 1636
Joined: Thu Apr 15, 2010 3:21 pm
Location: 127.0.0.1

Re: c0nb0x

by analogaddict on Mon Jul 22, 2013 4:31 pm

Tried another few time, after some trial and error c0nb0x uploaded the firmware using a different port. But as I said in the previous post after it completed the process, new firmware was not there :/
analogaddict
 
Posts: 25
Joined: Wed Jul 17, 2013 2:16 pm

Re: c0nb0x

by analogaddict on Mon Jul 22, 2013 5:14 pm

Do you think could be ATmega chip damaged?
analogaddict
 
Posts: 25
Joined: Wed Jul 17, 2013 2:16 pm

Re: c0nb0x

by antto on Tue Jul 23, 2013 4:56 am

damaged - i doubt

either the hex is not the "right" one, or for some reason it doesn't actually write it to the flash (lock bits or something)

how do you distinguish whether you've flashed MarOS or not?
We are here too: irc.freenode.net >>> #x0xb0x
..:: c0nb0x v1.00 ::.. http://forums.adafruit.com/viewtopic.php?f=7&t=29282 (new control app - win/osx)
VCO Tuning: http://forums.adafruit.com/viewtopic.php?f=12&t=24759 (do it the EASY way)

antto
 
Posts: 1636
Joined: Thu Apr 15, 2010 3:21 pm
Location: 127.0.0.1

Re: c0nb0x

by analogaddict on Tue Jul 23, 2013 5:02 am

There are some different function.. I tried with MarOs and Sokkos 2.0.

In MarOS 1.4.1 Tap tempo should be disabled and when in edit mode pressing chain could enter random mode or something I don't remember, the chain button should lit etc... I tried and tried, but the funcion I have are the old ones. I think I've Sokkos 1.9 burned at the moment.
analogaddict
 
Posts: 25
Joined: Wed Jul 17, 2013 2:16 pm

Re: c0nb0x

by analogaddict on Tue Jul 23, 2013 8:35 am

There's something I can do, like resetting it or trying to re-write the bootloader?
analogaddict
 
Posts: 25
Joined: Wed Jul 17, 2013 2:16 pm

Re: c0nb0x

by antto on Tue Jul 23, 2013 9:01 am

well, i'm out of ideas here :?

you could try a few things:

1) try on another computer / OS

2) buy a new chip from one of the x0xb0x sellers (willzyx / x0xsh0p / ...)

3) try to fix it yourself, you'll need some special tools like an AVR programmer, and some cables potentially soldering, and that's no guaranteed to work


i'd try #1 first
We are here too: irc.freenode.net >>> #x0xb0x
..:: c0nb0x v1.00 ::.. http://forums.adafruit.com/viewtopic.php?f=7&t=29282 (new control app - win/osx)
VCO Tuning: http://forums.adafruit.com/viewtopic.php?f=12&t=24759 (do it the EASY way)

antto
 
Posts: 1636
Joined: Thu Apr 15, 2010 3:21 pm
Location: 127.0.0.1

Re: c0nb0x

by analogaddict on Tue Jul 23, 2013 11:09 am

Should C0nb0x work on mac osx 10.4?
analogaddict
 
Posts: 25
Joined: Wed Jul 17, 2013 2:16 pm

Re: c0nb0x

by antto on Tue Jul 23, 2013 1:35 pm

i'm not familiar with osx at all, you can try it and see
We are here too: irc.freenode.net >>> #x0xb0x
..:: c0nb0x v1.00 ::.. http://forums.adafruit.com/viewtopic.php?f=7&t=29282 (new control app - win/osx)
VCO Tuning: http://forums.adafruit.com/viewtopic.php?f=12&t=24759 (do it the EASY way)

antto
 
Posts: 1636
Joined: Thu Apr 15, 2010 3:21 pm
Location: 127.0.0.1

Re: c0nb0x

by analogaddict on Tue Jul 23, 2013 2:28 pm

No way... tried on pc. Same thing it, firmware is loaded but after reboot x0xb0x old sokkos is still there :/
I this point I think it's the atmega chip, because I tried also to computer control and all works good.

Maybe I damaged bootloader using old 0.99 c0nb0x or something went wrong that I don't know.

I will order I new Atmega soon and will see :)

Tnx a lot for your help, you was amazing :)
analogaddict
 
Posts: 25
Joined: Wed Jul 17, 2013 2:16 pm

Re: c0nb0x

by antto on Tue Jul 23, 2013 5:48 pm

well, if it's uploading the firmware up to 100% without any warnings/errors - that means the bootloader isn't corrupted
so, it's very weird
We are here too: irc.freenode.net >>> #x0xb0x
..:: c0nb0x v1.00 ::.. http://forums.adafruit.com/viewtopic.php?f=7&t=29282 (new control app - win/osx)
VCO Tuning: http://forums.adafruit.com/viewtopic.php?f=12&t=24759 (do it the EASY way)

antto
 
Posts: 1636
Joined: Thu Apr 15, 2010 3:21 pm
Location: 127.0.0.1

Re: c0nb0x

by xlarge on Tue Jul 30, 2013 5:30 am

Strange fuse settings on the chip?
xlarge
 
Posts: 151
Joined: Wed Jul 11, 2007 2:02 pm

Re: c0nb0x

by analogaddict on Fri Aug 02, 2013 10:11 am

New chip is working well! :) Seems something wrong occured in the old one.
analogaddict
 
Posts: 25
Joined: Wed Jul 17, 2013 2:16 pm

Re: c0nb0x

by antto on Wed Sep 18, 2013 8:07 am

c0nb0x v1.01 is out (first post updated)
we had some trouble with the osx build, so to not delay it additionally, i'm releasing the win32 version alone, and will bump the thread up again when we sort out the issues with the osx version

in the new version i've tried to make the interface more clear about what function does what, because quite a number of people confuse the bootload process with the normal process of connecting to the x0xb0x.
a potentially annoying bug related to timing on osx/linux should be fixed (hasn't been tested on osx yet).
there's also implementations of some new Serial messages, and support for the n0nx0x2 pattern format
and now c0nb0x can convert patterns when you import a .cxm file which has been exported from one FW into the x0xb0x running another FW (if the pattern format is different). the conversion is lossy, it's basically equivalent to loading each pattern into the pattern editor and then saving it to the x0xb0x.
We are here too: irc.freenode.net >>> #x0xb0x
..:: c0nb0x v1.00 ::.. http://forums.adafruit.com/viewtopic.php?f=7&t=29282 (new control app - win/osx)
VCO Tuning: http://forums.adafruit.com/viewtopic.php?f=12&t=24759 (do it the EASY way)

antto
 
Posts: 1636
Joined: Thu Apr 15, 2010 3:21 pm
Location: 127.0.0.1

Please be positive and constructive with your questions and comments.