0

Button Not working in Face recognition Treasure Box Project
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Button Not working in Face recognition Treasure Box Project

by priyank1 on Fri Apr 21, 2017 8:12 am

Hello,
I have been doing this project Treasure box but facing problem in the last phase of the project related to the working of the Push button which is not working for me. I did the exact same connection according to the diagram on Pi 3 but my button wont work.. i used a multimeter to check whether the two wire joining the push button are getting voltage or not but they are getting the voltage. And also cross checked the push Button it works to. when ever i run the box file i get this


Loading training data...
Training data loaded!
Using hardware: PWM
PW increments: 10us
/home/pi/pi-facerec-box-master/hardware.py:19: RuntimeWarning: This channel is already in use, continuing anyway. Use RPIO.setwarnings(False) to disable warnings.
RPIO.setup(config.BUTTON_PIN, RPIO.IN)
Initializing channel 0...
Requesting 139264 bytes
mem_ref 20
bus_addr = 4252872704
virtbase 0x6d635000
after init virtbaseadd_channel_pulse: channel=0, gpio=18, start=0, width=110
init_gpio 18
Running box...
Press button to lock (if unlocked), or unlock if the correct face is detected.
Press Ctrl-C to quit.


I almost tried everything.But the button is not working.
It will be a great help if someone helps me..

priyank1
 
Posts: 5
Joined: Fri Apr 21, 2017 3:08 am

Re: Button Not working in Face recognition Treasure Box Proj

by adafruit_support_mike on Sun Apr 23, 2017 12:44 am

Post a photo showing your hardware and connections and we'll take a look. 800x600 images usually work best.

adafruit_support_mike
 
Posts: 38293
Joined: Thu Feb 11, 2010 2:51 pm

Re: Button Not working in Face recognition Treasure Box Proj

by priyank1 on Sun Apr 23, 2017 2:12 am

These are the photos of my circuit.
Attachments
img_20170423_111110.jpg
img_20170423_111110.jpg (330.06 KiB) Viewed 41 times
img_20170423_111000.jpg
img_20170423_111000.jpg (302.38 KiB) Viewed 41 times
img_20170423_110818.jpg
img_20170423_110818.jpg (301.84 KiB) Viewed 41 times

priyank1
 
Posts: 5
Joined: Fri Apr 21, 2017 3:08 am

Re: Button Not working in Face recognition Treasure Box Proj

by priyank1 on Sun Apr 23, 2017 2:13 am

continued
Attachments
img_20170423_111431.jpg
img_20170423_111431.jpg (292.06 KiB) Viewed 41 times
img_20170423_111407.jpg
img_20170423_111407.jpg (287.96 KiB) Viewed 41 times

priyank1
 
Posts: 5
Joined: Fri Apr 21, 2017 3:08 am

Re: Button Not working in Face recognition Treasure Box Proj

by adafruit_support_mike on Mon Apr 24, 2017 2:37 am

Those connections look right.

Have you measured the voltage on the RasPi's GPIO pin 25 to make sure it's 3.3v when the switch is open, and drops to 0v when the switch is closed?

adafruit_support_mike
 
Posts: 38293
Joined: Thu Feb 11, 2010 2:51 pm

Please be positive and constructive with your questions and comments.