0

Thermal camera project - White screen of death
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Thermal camera project - White screen of death

by ebeyer on Sun Mar 11, 2018 4:34 pm

I've assembled the electronics for the thermal camera kit (https://learn.adafruit.com/thermal-camera-with-display). I have installed the thermal_cam_interpolate
sketch onto my Adafruit ESP32 breakout and switched on the display. Unfortunately, no joy. The display is solid white and the serial monitor spits out a constant
"-511.75" as below. I've gone over my circuit as best I can and am pretty sure I have no shorts. Attached are imgur links to pictures of the hardware, as it stands.

I'm unsure where to go from here as far as testing and troubleshooting. Your thoughts as to what might be wrong and what I might do about it would be greatly
appreciated.

With advance appreciation,
EB

--
Photos: https://imgur.com/VV3i0Ld
https://imgur.com/gIM9Tnq
https://imgur.com/K48uoui

From the serial monitor: I got this "paragraph" over and over again:

Interpolation took 17 ms
[-511.75, -511.75, -511.75, -511.75, -511.75, -511.75, -511.75, -511.75,
-511.75, -511.75, -511.75, -511.75, -511.75, -511.75, -511.75, -511.75,
-511.75, -511.75, -511.75, -511.75, -511.75, -511.75, -511.75, -511.75,
-511.75, -511.75, -511.75, -511.75, -511.75, -511.75, -511.75, -511.75,
-511.75, -511.75, -511.75, -511.75, -511.75, -511.75, -511.75, -511.75,
-511.75, -511.75, -511.75, -511.75, -511.75, -511.75, -511.75, -511.75,
-511.75, -511.75, -511.75, -511.75, -511.75, -511.75, -511.75, -511.75,
-511.75, -511.75, -511.75, -511.75, -511.75, -511.75, -511.75, -511.75,
]

ebeyer
 
Posts: 69
Joined: Tue Mar 15, 2016 3:31 pm

Re: Thermal camera project - White screen of death

by adafruit_support_mike on Mon Mar 12, 2018 12:08 am

Move the 3V connection over to the Vin pin.

The ESP32 doesn't have built-in pull-up resistors on its I2C pins. The AMG8833 breakout does, but they're pulled up by Vin.

adafruit_support_mike
 
Posts: 52612
Joined: Thu Feb 11, 2010 2:51 pm

Re: Thermal camera project - White screen of death

by ebeyer on Mon Mar 12, 2018 6:57 am

OK. I moved my red wire on the AMG8833 from 3Vo to VIN (just to its left), powered up the circuit and.. still a blank white screen. Anything else I can do?

Thanks again.
EB

ebeyer
 
Posts: 69
Joined: Tue Mar 15, 2016 3:31 pm

Re: Thermal camera project - White screen of death

by adafruit_support_mike on Mon Mar 12, 2018 11:21 pm

Let's break it down into subsystems.

Does the display work when you use any of the graphics demo sketches?

adafruit_support_mike
 
Posts: 52612
Joined: Thu Feb 11, 2010 2:51 pm

Re: Thermal camera project - White screen of death

by ebeyer on Mon Mar 12, 2018 11:51 pm

adafruit_support_mike wrote:Let's break it down into subsystems.

Does the display work when you use any of the graphics demo sketches?


At the risk of being overly concrete, I'm not sure how I do that. Do I load graphics
demo sketches from the arduino IDE and upload them to the ESP32 breakout, reset
the breakout and the display and see if I get a test pattern?

ebeyer
 
Posts: 69
Joined: Tue Mar 15, 2016 3:31 pm

Re: Thermal camera project - White screen of death

by adafruit_support_mike on Tue Mar 13, 2018 12:23 am

Yep.. the tutorial walks through it step by step:

https://learn.adafruit.com/adafruit-2-4 ... phics-test

adafruit_support_mike
 
Posts: 52612
Joined: Thu Feb 11, 2010 2:51 pm

Re: Thermal camera project - White screen of death

by ebeyer on Tue Mar 13, 2018 3:12 pm

adafruit_support_mike wrote:Yep.. the tutorial walks through it step by step:

https://learn.adafruit.com/adafruit-2-4 ... phics-test


OK. I followed the directions to upload the graphicstest_featherwing. The upload appears to
have been successful (https://pastebin.com/DPcRbKEr) but the display is still solid white
(https://imgur.com/aVHeaKA). Another look at my wiring here: https://imgur.com/Vy7UdKw

So does this mean the problem has something to do with the ILI9341? Is there anything else
I can do to shed light on the problem?

Thanks again.
EB

ebeyer
 
Posts: 69
Joined: Tue Mar 15, 2016 3:31 pm

Re: Thermal camera project - White screen of death

by ebeyer on Tue Mar 20, 2018 8:13 pm

So.. progress.

I went ahead and purchased a pre-soldered ESP82 board to control for the possibility that I messed up a solder joint. I uploaded the
graphictest_featherwing sketch and.. SUCCESS! I can play the test pattern just fine.

Then I uploaded the thermal_cam_interpolate sketch, and now I get.. a purple screen of death instead of a white one:
https://i.imgur.com/bDw1Byu.jpg

This pattern of success and failure would appear to suggest the problem is between the ESP82 board and my AMG8833. I went over
my soldering and find no shorts, and the connections between the terminals on the AMG8833 and the ESP82 board appear to be OK.

So what else might I do to pin down the problem? Thanks again.

Here are new pictures of my electronics for comparison:
https://i.imgur.com/L5pBtBE.jpg
https://i.imgur.com/ptNYxMM.jpg

ebeyer
 
Posts: 69
Joined: Tue Mar 15, 2016 3:31 pm

Re: Thermal camera project - White screen of death

by adafruit_support_mike on Wed Mar 21, 2018 12:57 am

If you run the version of the AMG8833 sketch that prints the readings out as text, do you see the sensor respond to thermal input at all?

adafruit_support_mike
 
Posts: 52612
Joined: Thu Feb 11, 2010 2:51 pm

Please be positive and constructive with your questions and comments.