0

Dead/Defective powerboost basic
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Dead/Defective powerboost basic

by DevBen on Fri Jul 30, 2021 10:09 pm

Hello!
It’s my first time needing to use the forum but essentially I just ordered my powerboost 500c from adafruit and went to solder it together on my table with some jumper wires but as I was holding the battery contacts on the powerboost jumper wires/breakout wires I saw arcs forming across them as they touched and disconnected. I was a little concerned so I just touched the battery and wires together for a few seconds with my hand and immediately my finger was on fire (not literally) so I dropped the powerboost onto the floor and looked at it to find a small bubble on the chip. I am fairly sure it died or was defective on arrival as I’m unsure what I did to cause it. I double checked all the soldering joints for flux and touching and couldn’t see anything.
Also when it came I realized I ordered the wrong part as I originally wanted a powerboost 500c (the charger+ boost) not the just boost one (basic) but I didn’t even realize there were multiple models.
Is it possible for me to get a new powerboost 500 basic?
https://ibb.co/LpTMHj0
https://ibb.co/fqkMfZj
https://ibb.co/8dpx2wq

DevBen
 
Posts: 3
Joined: Tue Nov 19, 2019 7:04 pm

Re: Dead/Defective powerboost basic

by adafruit_support_mike on Mon Aug 02, 2021 12:16 am

Post a photo of your LiPo please, especially the connections that went to the PowerBoost. 800x600 images usually work best.

adafruit_support_mike
 
Posts: 63701
Joined: Thu Feb 11, 2010 2:51 pm

Re: Dead/Defective powerboost basic

by DevBen on Mon Aug 02, 2021 12:31 am

Here is the battery. It is a normal 3.7v lipo battery with a capacity of 10500mAh
Attachments
511B10BA-A818-47F6-B765-CB89AA9731AA.jpeg
511B10BA-A818-47F6-B765-CB89AA9731AA.jpeg (140.44 KiB) Viewed 111 times

DevBen
 
Posts: 3
Joined: Tue Nov 19, 2019 7:04 pm

Re: Dead/Defective powerboost basic

by adafruit_support_mike on Mon Aug 02, 2021 9:32 pm

Thank you.

The wires soldered to the PowerBoost in the first set of photos are both green. What kind of connection was between those and the LiPo?

adafruit_support_mike
 
Posts: 63701
Joined: Thu Feb 11, 2010 2:51 pm

Re: Dead/Defective powerboost basic

by DevBen on Tue Aug 03, 2021 11:48 pm

Well one wire is the vbat and one is ground; although I hate how close together they are, so I directly connected the battery to the vbat and gnd pins
Red/+ -> vbat
Black/- -> gnd

DevBen
 
Posts: 3
Joined: Tue Nov 19, 2019 7:04 pm

Re: Dead/Defective powerboost basic

by adafruit_support_mike on Wed Aug 04, 2021 3:10 pm

No other circuits or connectors in the path then, thank you.

The damage to the IC matches what happens when the power is connected backwards. It’s all too easy to do.

We don’t have direct proof of that happenung though, and there are other kinds of failure that could happen with the correct battery polarity.

Send a note containing a link to this page and your order number to support@adafruit.com. The folks there will get you a replacement PowerBoost.

FWIW, I’d suggest grabbing a JST-PH2 jumper and connecting that to the LiPo:

https://www.adafruit.com/product/261

If you want soldered connections at both ends, cutting a double-ended jumper in half will give you a breakable connection in the middle of the cable:

https://www.adafruit.com/product/1131

I’ve personally killed enough circuis that I don’t allow myself to make power connections with anything but keyed and tested connectors any more.

adafruit_support_mike
 
Posts: 63701
Joined: Thu Feb 11, 2010 2:51 pm

Please be positive and constructive with your questions and comments.