Due to high demand expect some shipping delays at this time, orders may not ship for 3-4 business days. On MLK Day no orders will be shipped.
0

Video looper installation issue with pyudev
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Video looper installation issue with pyudev

by jdjuggler on Mon Nov 22, 2021 1:25 pm

I have installed video looper many time using this same platform and software version 2.9.0.
There seems to be an issue with a repository location change. I am unable to find how to fix it or modify the location of the pyudev. I have also include the entire script execution below.
Here is error:
Processing dependencies for Adafruit-Video-Looper==1.0.8
Searching for pyudev
Reading https://pypi.python.org/simple/pyudev/
Couldn't find index page for 'pyudev' (maybe misspelled?)
Scanning index of all packages (this may take a while)
Reading https://pypi.python.org/simple/
No local packages or working download links found for pyudev
error: Could not find suitable distribution for Requirement.parse('pyudev')

ENTIRE SCRIPT EXECUTION:
pi@raspberrypi:~/pi_video_looper $ sudo ./install.sh
Installing dependencies...
==========================
Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
364 packages can be upgraded. Run 'apt list --upgradable' to see them.
Reading package lists... Done
Building dependency tree
Reading state information... Done
exfat-fuse is already the newest version (1.2.5-2).
ntfs-3g is already the newest version (1:2016.2.22AR.1+dfsg-1+deb9u2).
python3 is already the newest version (3.5.3-1).
supervisor is already the newest version (3.3.1-1+deb9u1).
omxplayer is already the newest version (20190607+gitf06235c-1).
python3-pip is already the newest version (9.0.1-2+rpt2).
python3-pygame is already the newest version (1.9.3+dfsg-2).
0 upgraded, 0 newly installed, 0 to remove and 364 not upgraded.
Installing hello_video...
=========================
Reading package lists... Done
Building dependency tree
Reading state information... Done
build-essential is already the newest version (12.3).
git is already the newest version (1:2.11.0-3+deb9u7).
python3-dev is already the newest version (3.5.3-1).
0 upgraded, 0 newly installed, 0 to remove and 364 not upgraded.
Cloning into 'pi_hello_video'...
remote: Enumerating objects: 41, done.
remote: Total 41 (delta 0), reused 0 (delta 0), pack-reused 41
Unpacking objects: 100% (41/41), done.
make: Entering directory '/home/pi/pi_video_looper/pi_hello_video/libs/ilclient'
for i in ilclient.o ilcore.o; do (if test -e "$i"; then ( rm $i ); fi ); done
make: Leaving directory '/home/pi/pi_video_looper/pi_hello_video/libs/ilclient'
make: Entering directory '/home/pi/pi_video_looper/pi_hello_video/hello_video'
for i in video.o; do (if test -e "$i"; then ( rm $i ); fi ); done
make: Leaving directory '/home/pi/pi_video_looper/pi_hello_video/hello_video'
make: Entering directory '/home/pi/pi_video_looper/pi_hello_video/libs/ilclient'
cc -DSTANDALONE -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -DTARGET_POSIX -D_LINUX -fPIC -DPIC -D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -U_FORTIFY_SOURCE -Wall -g -DHAVE_LIBOPENMAX=2 -DOMX -DOMX_SKIP64BIT -ftree-vectorize -pipe -DUSE_EXTERNAL_OMX -DHAVE_LIBBCM_HOST -DUSE_EXTERNAL_LIBBCM_HOST -DUSE_VCHIQ_ARM -Wno-psabi -I/opt/vc/include/ -I/opt/vc/include/interface/vcos/pthreads -I/opt/vc/include/interface/vmcs_host/linux -I./ -I/opt/vc/src/hello_pi/libs/ilclient -I/opt/vc/src/hello_pi/libs/vgfont -g -c ilclient.c -o ilclient.o -Wno-deprecated-declarations
cc -DSTANDALONE -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -DTARGET_POSIX -D_LINUX -fPIC -DPIC -D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -U_FORTIFY_SOURCE -Wall -g -DHAVE_LIBOPENMAX=2 -DOMX -DOMX_SKIP64BIT -ftree-vectorize -pipe -DUSE_EXTERNAL_OMX -DHAVE_LIBBCM_HOST -DUSE_EXTERNAL_LIBBCM_HOST -DUSE_VCHIQ_ARM -Wno-psabi -I/opt/vc/include/ -I/opt/vc/include/interface/vcos/pthreads -I/opt/vc/include/interface/vmcs_host/linux -I./ -I/opt/vc/src/hello_pi/libs/ilclient -I/opt/vc/src/hello_pi/libs/vgfont -g -c ilcore.c -o ilcore.o -Wno-deprecated-declarations
ar r libilclient.a ilclient.o ilcore.o
ar: creating libilclient.a
rm ilcore.o ilclient.o
make: Leaving directory '/home/pi/pi_video_looper/pi_hello_video/libs/ilclient'
make: Entering directory '/home/pi/pi_video_looper/pi_hello_video/hello_video'
cc -DSTANDALONE -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -DTARGET_POSIX -D_LINUX -fPIC -DPIC -D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -U_FORTIFY_SOURCE -Wall -g -DHAVE_LIBOPENMAX=2 -DOMX -DOMX_SKIP64BIT -ftree-vectorize -pipe -DUSE_EXTERNAL_OMX -DHAVE_LIBBCM_HOST -DUSE_EXTERNAL_LIBBCM_HOST -DUSE_VCHIQ_ARM -Wno-psabi -I/opt/vc/include/ -I/opt/vc/include/interface/vcos/pthreads -I/opt/vc/include/interface/vmcs_host/linux -I./ -I/opt/vc/src/hello_pi/libs/ilclient -I/opt/vc/src/hello_pi/libs/vgfont -g -c video.c -o video.o -Wno-deprecated-declarations
cc -o hello_video.bin -Wl,--whole-archive video.o -lilclient -L/opt/vc/lib/ -lbrcmGLESv2 -lbrcmEGL -lopenmaxil -lbcm_host -lvcos -lvchiq_arm -lpthread -lrt -lm -L../libs/ilclient -L../libs/vgfont -Wl,--no-whole-archive -rdynamic
rm video.o
make: Leaving directory '/home/pi/pi_video_looper/pi_hello_video/hello_video'
cp hello_video.bin /usr/local/bin/
Installing video_looper program...
==================================
Requirement already satisfied: setuptools in /usr/lib/python3/dist-packages
running install
running bdist_egg
running egg_info
writing requirements to Adafruit_Video_Looper.egg-info/requires.txt
writing Adafruit_Video_Looper.egg-info/PKG-INFO
writing dependency_links to Adafruit_Video_Looper.egg-info/dependency_links.txt
writing top-level names to Adafruit_Video_Looper.egg-info/top_level.txt
reading manifest file 'Adafruit_Video_Looper.egg-info/SOURCES.txt'
writing manifest file 'Adafruit_Video_Looper.egg-info/SOURCES.txt'
installing library code to build/bdist.linux-armv6l/egg
running install_lib
running build_py
creating build/bdist.linux-armv6l/egg
creating build/bdist.linux-armv6l/egg/Adafruit_Video_Looper
copying build/lib/Adafruit_Video_Looper/omxplayer.py -> build/bdist.linux-armv6l/egg/Adafruit_Video_Looper
copying build/lib/Adafruit_Video_Looper/hello_video.py -> build/bdist.linux-armv6l/egg/Adafruit_Video_Looper
copying build/lib/Adafruit_Video_Looper/model.py -> build/bdist.linux-armv6l/egg/Adafruit_Video_Looper
copying build/lib/Adafruit_Video_Looper/usb_drive.py -> build/bdist.linux-armv6l/egg/Adafruit_Video_Looper
copying build/lib/Adafruit_Video_Looper/usb_drive_copymode.py -> build/bdist.linux-armv6l/egg/Adafruit_Video_Looper
copying build/lib/Adafruit_Video_Looper/playlist_builders.py -> build/bdist.linux-armv6l/egg/Adafruit_Video_Looper
copying build/lib/Adafruit_Video_Looper/directory.py -> build/bdist.linux-armv6l/egg/Adafruit_Video_Looper
copying build/lib/Adafruit_Video_Looper/video_looper.py -> build/bdist.linux-armv6l/egg/Adafruit_Video_Looper
copying build/lib/Adafruit_Video_Looper/__init__.py -> build/bdist.linux-armv6l/egg/Adafruit_Video_Looper
copying build/lib/Adafruit_Video_Looper/usb_drive_mounter.py -> build/bdist.linux-armv6l/egg/Adafruit_Video_Looper
copying build/lib/Adafruit_Video_Looper/alsa_config.py -> build/bdist.linux-armv6l/egg/Adafruit_Video_Looper
byte-compiling build/bdist.linux-armv6l/egg/Adafruit_Video_Looper/omxplayer.py to omxplayer.cpython-35.pyc
byte-compiling build/bdist.linux-armv6l/egg/Adafruit_Video_Looper/hello_video.py to hello_video.cpython-35.pyc
byte-compiling build/bdist.linux-armv6l/egg/Adafruit_Video_Looper/model.py to model.cpython-35.pyc
byte-compiling build/bdist.linux-armv6l/egg/Adafruit_Video_Looper/usb_drive.py to usb_drive.cpython-35.pyc
byte-compiling build/bdist.linux-armv6l/egg/Adafruit_Video_Looper/usb_drive_copymode.py to usb_drive_copymode.cpython-35.pyc
byte-compiling build/bdist.linux-armv6l/egg/Adafruit_Video_Looper/playlist_builders.py to playlist_builders.cpython-35.pyc
byte-compiling build/bdist.linux-armv6l/egg/Adafruit_Video_Looper/directory.py to directory.cpython-35.pyc
byte-compiling build/bdist.linux-armv6l/egg/Adafruit_Video_Looper/video_looper.py to video_looper.cpython-35.pyc
byte-compiling build/bdist.linux-armv6l/egg/Adafruit_Video_Looper/__init__.py to __init__.cpython-35.pyc
byte-compiling build/bdist.linux-armv6l/egg/Adafruit_Video_Looper/usb_drive_mounter.py to usb_drive_mounter.cpython-35.pyc
byte-compiling build/bdist.linux-armv6l/egg/Adafruit_Video_Looper/alsa_config.py to alsa_config.cpython-35.pyc
creating build/bdist.linux-armv6l/egg/EGG-INFO
copying Adafruit_Video_Looper.egg-info/PKG-INFO -> build/bdist.linux-armv6l/egg/EGG-INFO
copying Adafruit_Video_Looper.egg-info/SOURCES.txt -> build/bdist.linux-armv6l/egg/EGG-INFO
copying Adafruit_Video_Looper.egg-info/dependency_links.txt -> build/bdist.linux-armv6l/egg/EGG-INFO
copying Adafruit_Video_Looper.egg-info/requires.txt -> build/bdist.linux-armv6l/egg/EGG-INFO
copying Adafruit_Video_Looper.egg-info/top_level.txt -> build/bdist.linux-armv6l/egg/EGG-INFO
zip_safe flag not set; analyzing archive contents...
creating 'dist/Adafruit_Video_Looper-1.0.8-py3.5.egg' and adding 'build/bdist.linux-armv6l/egg' to it
removing 'build/bdist.linux-armv6l/egg' (and everything under it)
Processing Adafruit_Video_Looper-1.0.8-py3.5.egg
Removing /usr/local/lib/python3.5/dist-packages/Adafruit_Video_Looper-1.0.8-py3.5.egg
Copying Adafruit_Video_Looper-1.0.8-py3.5.egg to /usr/local/lib/python3.5/dist-packages
Adafruit-Video-Looper 1.0.8 is already the active version in easy-install.pth

Installed /usr/local/lib/python3.5/dist-packages/Adafruit_Video_Looper-1.0.8-py3.5.egg
Processing dependencies for Adafruit-Video-Looper==1.0.8
Searching for pyudev
Reading https://pypi.python.org/simple/pyudev/
Couldn't find index page for 'pyudev' (maybe misspelled?)
Scanning index of all packages (this may take a while)
Reading https://pypi.python.org/simple/
No local packages or working download links found for pyudev
error: Could not find suitable distribution for Requirement.parse('pyudev')
pi@raspberrypi:~/pi_video_looper $

jdjuggler
 
Posts: 8
Joined: Fri Sep 30, 2016 7:31 pm

Re: Video looper installation issue with pyudev

by jdjuggler on Sat Nov 27, 2021 4:12 pm

I installed pyudev manually, but the video_looper install still fails with the same error.

Attempting to tag @tdicola for assistance.

Thanks,
JD

jdjuggler
 
Posts: 8
Joined: Fri Sep 30, 2016 7:31 pm

Re: Video looper installation issue with pyudev

by jdjuggler on Sun Nov 28, 2021 7:46 pm

I also attempted to install & update pyudev from the synaptic package manager. The package does show up in the list of packages. But, the video looper installation still does not recognize that it is installed. Any thoughts?

JD

jdjuggler
 
Posts: 8
Joined: Fri Sep 30, 2016 7:31 pm

Please be positive and constructive with your questions and comments.