TPL5110 not toggling

General project help for Adafruit customers

Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.
Post Reply
User avatar
AgrimagWeb
 
Posts: 9
Joined: Thu May 21, 2020 4:26 am

TPL5110 not toggling

Post by AgrimagWeb »

As in topic viewtopic.php?f=8&t=191549&p=927062&hilit=tpl5110, my new TPL5110 breakout board does not toggle.
I only connected VDD and GND.
If I power it on, it never resets (so no timeout is reached).
If I manually put the DONE pin high, it turns off and never goes back to ON.
Tried two different boards.
Tried with the pot all to the left and in middle position.
If I put the pot all to the right, onboard pwr led blinks fast.

What am I doing wrong?

User avatar
mikeysklar
 
Posts: 8420
Joined: Mon Aug 01, 2016 8:10 pm

Re: TPL5110 not toggling

Post by mikeysklar »

What voltage are you using?

Can you post a photo so we can see the soldering and connections?

The thread you linked to that user got their board going with a simple example:
PS: just before "submit " I decided to make this simple circuit: a LED + a resistor and manually DONE pin high. This one is working. I will hold on the order.
Be sure to review the USAGE page:

https://learn.adafruit.com/adafruit-tpl ... kout/usage

User avatar
AgrimagWeb
 
Posts: 9
Joined: Thu May 21, 2020 4:26 am

Re: TPL5110 not toggling

Post by AgrimagWeb »

I'm powering from a 4V Li-Ion battery.
There's really not a circuit: I only connected VDD and GND to the battery and watch the on-board LED.
I can get it working correctly by cutting the pot trace and putting a resistor between DELAY and GND, but the pot never worked.

Now, I connected the TPL5110 to my circuit (Arduino Pro Mini clone + sensors). Connected GND to GND and DRV to VCC of Pro Mini. When TPL5110 is OFF, the circuit still consumes power (4-5 mA) and I can read ~0.4 V on the VCC pin.

Any ideas?
Shouldn't the TPL5110 cut power completely?

User avatar
mikeysklar
 
Posts: 8420
Joined: Mon Aug 01, 2016 8:10 pm

Re: TPL5110 not toggling

Post by mikeysklar »

In the Usage examples with a microcontroller the done pin on the TLP5110 is connection to a GPIO pin on the controller board.
Make sure to provide the power to the VDD and GND pins. Then connect your project to the DRV and GND pin. Use a DONE pin from your microcontroller to signal when the TPL can disable power: when the DONE pin goes from low to high, that will turn off the TPL's power transistor.
tlp5110.png
tlp5110.png (173.62 KiB) Viewed 80 times

User avatar
AgrimagWeb
 
Posts: 9
Joined: Thu May 21, 2020 4:26 am

Re: TPL5110 not toggling

Post by AgrimagWeb »

Dear mikeysklar, it seems you're convinced that I didn't read the Usage page.
I did.
The toggling is working now, as I wrote. I connected the DONE pin to a gpio pin.
The microcontroller turns off, but the voltage on the VCC pin is not zero as I would expect: it's 0.4-0.5 V and the circuit still draws current, which is not what I would expect.
I'm asking for help on how to identify why that voltage exists and why the current get drawn.

User avatar
mikeysklar
 
Posts: 8420
Joined: Mon Aug 01, 2016 8:10 pm

Re: TPL5110 not toggling

Post by mikeysklar »

What size resistor did you end up using in place of the trimpot? Maybe the timing intervals have something to do with the current / voltage you are seeing?

The expected current draw for this TPL5110 board is 20uA and you had mentioned seeing 4-5mA which leads me to think there is still a possible wiring issue. If you can post some photos of your setup that would be helpful.

User avatar
AgrimagWeb
 
Posts: 9
Joined: Thu May 21, 2020 4:26 am

Re: TPL5110 not toggling

Post by AgrimagWeb »

It is hard for me to take a clean photo since I had to solder the module on a breadboard as an "add-on" and added wires to my circuit (this is a test board).

I used a 67 kOhm resistor (47 + 10 + 10 in series). The timing I need is about 15 minutes and this is working fine.
I added a 330 uF capacitor between DRV and GND because otherwise the Arduino Pro Mini wouldn't boot.
I found other topics on this forum who recommended 100+ uF to make it work on an ESP8266.

DRV is connected to Arduino Pro Mini VCC pin.
DONE is connected to D9.

In setup:

Code: Select all

pinMode(9, OUTPUT);
digitalWrite(9, LOW);
In loop:

Code: Select all

digitalWrite(9, HIGH);
delay(1);
digitalWrite(9, LOW);
delay(1);

// Another tweaks to lower the power consumption
ADCSRA &= ~(1<<ADEN); //Disable ADC
ACSR = (1<<ACD); //Disable the analog comparator

// enable sleep (just in case power is still there)
for (float i = seconds / 8.0f; i > 0; i--) {
    Narcoleptic.delay(8 * 1024L);
}

User avatar
AgrimagWeb
 
Posts: 9
Joined: Thu May 21, 2020 4:26 am

Re: TPL5110 not toggling

Post by AgrimagWeb »

With a 100 uF capacitor nothing change.

User avatar
AgrimagWeb
 
Posts: 9
Joined: Thu May 21, 2020 4:26 am

Re: TPL5110 not toggling

Post by AgrimagWeb »

I suspect the problem is with the remaining circuit.
I isoleted piece by piece each component to find the culprit.
In particular, I have a cheap chinese solar charger, whose OUT+ is connected to VDD of TPL5110.
Once I removed that, current goes to almost 0.

It seems to draw current even if I connected VDD to BAT+ and GND to OUT-. I thoudh this would have bypassed the solar charger, but it doesn't seem so.

I now put a diode between OUT+ and VDD and it seems to work fine.
I'm testing the whole thing now.
I'll post the final schematic while I confirm the correct behavior.

User avatar
mikeysklar
 
Posts: 8420
Joined: Mon Aug 01, 2016 8:10 pm

Re: TPL5110 not toggling

Post by mikeysklar »

Thank you for the updates and your methodical approach of going through each component. Looking forward to seeing your final schematic.

Post Reply
Please be positive and constructive with your questions and comments.

Return to “General Project help”