0

Need help with Raspberry Pi RGB LED Matrix Webapp project
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Need help with Raspberry Pi RGB LED Matrix Webapp project

by Bobarian on Mon Apr 16, 2018 2:09 pm

I recently got my Raspberry Pi, my HAT, and my LED panels. I was able to get them up and running following this guide:

https://learn.adafruit.com/raspberry-pi ... ix-display

So I know the panels work and everything is good there. However what I am building is a low rez pixel digital art frame for the wall which I want to put pictures and animated images on it as an art piece. I found a project walk through that looks exactly what I need (ability to create a web interface that I can connect to and load stuff up on it). However this is where I get stuck.

The guide I am trying to follow is this one: https://learn.adafruit.com/raspberry-pi ... p/overview

(Note I am a complete noob to all this, great at following instructions but navigating outside of those instructions becomes a challenge).

I've gotten all the way through without seemingly any errors to the point where I need to run some demos on it. I run the command:

Code: Select all | TOGGLE FULL SIZE
$ cd rpi-rgb-led-matrix/examples-api-use
 
$ sudo ./demo -D -m 0 --led-no-hardware-pulse --led-gpio-mapping=adafruit-hat


And suppose to see a spinning square. My LEDs never light up even though on my monitor the program looks like it is running. I tried the next one to show the scrolling text and same issue there.

One thing to note, when I went through the first tutorial it had me setup some configuration to tell it how the screens were configured and in what order. This second one didn't seem to do that at all.

Another issue further along (I kept going seeing if I could at least finish up and get the web service up) is that I get to a point where it asks to just some commands:

Code: Select all | TOGGLE FULL SIZE
$ java -jar payara-micro-prerelease-2016-11-24.jar --deploy rpi-rgb-led-matrix-webapp-0.0.1-SNAPSHOT.war


It returns that 'java is not found'. Could this be that I am using Rasbian Lite and not the full (need to get a bigger MicroSD card to do that)?

Any help greatly appreciated! Thank you!

Bobarian
 
Posts: 5
Joined: Mon Apr 16, 2018 1:51 pm

Re: Need help with Raspberry Pi RGB LED Matrix Webapp projec

by adafruit_support_mike on Tue Apr 17, 2018 12:18 am

Yeah, you'll probably need to use the full version of Raspian for that project.

adafruit_support_mike
 
Posts: 55902
Joined: Thu Feb 11, 2010 2:51 pm

Re: Need help with Raspberry Pi RGB LED Matrix Webapp projec

by Bobarian on Tue Apr 17, 2018 3:52 pm

So I bought a new SD card and installed the full version of Raspian and went through the same walkthroughs (only this time I did the one I was trying to do with the Webapp first).

The webapp walkthrough did same thing, in that I get to the point of running the application and nothing appears on the panels.

The other walkthrough, which allows you to use it as a duplication of your monitor, works fine.

So I think there is something missing with that first tutorial and I believe it is a piece on how to setup the panels to make it work before running anything. Just not sure how to solve at this point. Suggestions?

Bobarian
 
Posts: 5
Joined: Mon Apr 16, 2018 1:51 pm

Re: Need help with Raspberry Pi RGB LED Matrix Webapp projec

by Bobarian on Tue Apr 17, 2018 10:16 pm

Just another note, I also followed this guide https://learn.adafruit.com/adafruit-rgb-matrix-plus-real-time-clock-hat-for-raspberry-pi/driving-matrices and having same issue. Everything looks fine, but when I run demos, the LEDs don't do anything.

I then went directly to the source and followed this guide https://github.com/hzeller/rpi-rgb-led-matrix, which it looks like is the repository that these other guides are based on, and having same issue.

Not sure how to advance at this point.

Bobarian
 
Posts: 5
Joined: Mon Apr 16, 2018 1:51 pm

Re: Need help with Raspberry Pi RGB LED Matrix Webapp projec

by adafruit_support_mike on Wed Apr 18, 2018 12:45 am

Ah.. the hzeller code gets updated occasionally, and sometimes the changes break back-compatibility with older versions.

Try using our fork of the lirary:

https://github.com/adafruit/rpi-rgb-led-matrix

adafruit_support_mike
 
Posts: 55902
Joined: Thu Feb 11, 2010 2:51 pm

Re: Need help with Raspberry Pi RGB LED Matrix Webapp projec

by Bobarian on Wed May 02, 2018 12:40 pm

So I was able to spend some time trying different things and still a bit stuck but also made it a bit further.

So I tried the fork of the library you have listed and unfortunately that one still would not work. When I wiped everything and tried Hzeller's repository again, I was able to get the demos up and running perfectly.

However when I run the server - this works to the point that I can access it on my network. But when I try to load an image or display text, it will never appear on the LED panels. So it seems that the server needs to be updated to work with Hzeller's latest code base. So until then, I'm stuck again.

Bobarian
 
Posts: 5
Joined: Mon Apr 16, 2018 1:51 pm

Re: Need help with Raspberry Pi RGB LED Matrix Webapp projec

by MrR9 on Fri Dec 07, 2018 8:31 pm

I've gotten the text to work, but i cannot get images or animations working. Just get a quick flash of dots sometimes.

I did it by using this tut, then just switching the python folder from out of bindings into the main folder then just added the web interface stuff and ran it.
https://learn.adafruit.com/adafruit-rgb-matrix-plus-real-time-clock-hat-for-raspberry-pi/driving-matrices
If you do this you will have to edit the runtext.py under /user/rpi-rgb-led-matrix/python/samples

find the line:

font.LoadFont("../.../../fonts/10x20.bdf")

and change it to this:

font.LoadFont("../../fonts/10x20.bdf")

3 less dots to correspond with the folder change for the fonts.

If it doesn't work like that, try doing it under root. I am going to see if i can get it to work without as I have had issues before while not using root.

MrR9
 
Posts: 2
Joined: Sat Dec 01, 2018 10:30 am

Re: Need help with Raspberry Pi RGB LED Matrix Webapp projec

by mickmick54 on Wed Feb 13, 2019 2:05 pm

Hello world,

I try to make works the LED matrix webapp but once I've installed the Payara micro prerelease and the SNAPSHOT.war I run the server, load animated gif but nothing appears on the LED screen.

I use a full installed Raspbian Jessie, a matrix hat and a LED screen 32x32.

Moreover I am obliged to change the name of the directory rpi-rgb-led-matrix-master into rpi-rgb-led-matrix otherwise it gives me an error message:
Error: Cannot run program "/home/pi/rpi-rgb-led-matrix/utils/led-image-viewer": error=2, No such file or directory

So I change the name of the directory by shortening it so there no error message anymore, the console send me request processed and received but it still not working...

Can you help me please?

mickmick54
 
Posts: 1
Joined: Wed Feb 13, 2019 1:52 pm

Please be positive and constructive with your questions and comments.