0

BNO055 Not Working
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

BNO055 Not Working

by edrum22 on Mon Feb 25, 2019 5:37 pm

I'm using the BNO055 IMU to give orientation measurements for use in a toy submarines control systems. I've tried running the sketch provided on the BNO055's page on adafruit, but its not working. I have tried several different sets of wires so that is not the problem. I ran a I2C scanner which says the BNO055 board is using address 0x40 which is the HID-I2C address.
Code: Select all | TOGGLE FULL SIZE
#include <Wire.h>
#include <Adafruit_Sensor.h>
#include <Adafruit_BNO055.h>
#include <utility/imumaths.h>
 
Adafruit_BNO055 bno = Adafruit_BNO055(55);

void setup(void)
{
  Serial.begin(9600);
  Serial.println("Orientation Sensor Test"); Serial.println("");
 
  /* Initialise the sensor */
  if(!bno.begin())
  {
    /* There was a problem detecting the BNO055 ... check your connections */
    Serial.print("Ooops, no BNO055 detected ... Check your wiring or I2C ADDR!");
    while(1);
  }
 
  delay(1000);
   
  bno.setExtCrystalUse(true);
}

void loop(void)
{
  /* Get a new sensor event */
  sensors_event_t event;
  bno.getEvent(&event);
 
  /* Display the floating point data */
  Serial.print("X: ");
  Serial.print(event.orientation.x, 4);
  Serial.print("\tY: ");
  Serial.print(event.orientation.y, 4);
  Serial.print("\tZ: ");
  Serial.print(event.orientation.z, 4);
  Serial.println("");
 
  delay(100);
}
Last edited by adafruit_support_carter on Mon Feb 25, 2019 5:42 pm, edited 1 time in total.
Reason: added [code] tags

edrum22
 
Posts: 1
Joined: Mon Feb 25, 2019 5:29 pm

Re: BNO055 Not Working

by adafruit_support_carter on Mon Feb 25, 2019 5:45 pm

Hmmm. The breakout should have an I2C address of either 0x28 or 0x29.
https://learn.adafruit.com/adafruit-bno ... r-pins-2-2
ADR: Set this pin high to change the default I2C address for the BNO055 if you need to connect two ICs on the same I2C bus. The default address is 0x28. If this pin is connected to 3V, the address will be 0x29


Can you post a photo of your setup showing how you have everything connected.

adafruit_support_carter
 
Posts: 13216
Joined: Tue Nov 29, 2016 2:45 pm

Re: BNO055 Not Working

by coreywan on Thu Jul 25, 2019 5:00 pm

I am experiencing a similar issue.

Using an I2C scanner, I get an address found at 40. Which is in decimal, in hex that is 0x28. So 40 is a correct address to be displayed. The BNO055 worked for about 2 days and then stopped. No wiring change and nothing changed in the code that messes with the IMU.

coreywan
 
Posts: 1
Joined: Thu Jul 25, 2019 4:58 pm

Re: BNO055 Not Working

by adafruit_support_carter on Thu Jul 25, 2019 7:35 pm

@coreywan Please start a new thread for your issue and include photos of your setup.

adafruit_support_carter
 
Posts: 13216
Joined: Tue Nov 29, 2016 2:45 pm

Please be positive and constructive with your questions and comments.