0

Any obvious frackups?
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Any obvious frackups?

by Nonpython on Thu Mar 18, 2010 12:14 am

I just made my first board in CadSoft Eagle, did I do anything particularity boneheaded?
Nonpython
 
Posts: 7
Joined: Thu Mar 18, 2010 12:10 am

Re: Any obvious frackups?

by chankster on Thu Mar 18, 2010 12:57 am

Nonpython wrote:I just made my first board in CadSoft Eagle, did I do anything particularity boneheaded?


Potentially?
... :wink:
"This is not my sig", it said. - I looked at it suspiciously; Who's sig was it, then?

chankster
 
Posts: 121
Joined: Mon Jul 06, 2009 12:59 am

Re: Any obvious frackups?

by zener on Thu Mar 18, 2010 1:52 am

You made your traces way too thin!! HA HA. I have no idea...

zener
 
Posts: 4483
Joined: Sat Feb 21, 2009 2:38 am

Re: Any obvious frackups?

by Nonpython on Thu Mar 18, 2010 2:07 am

Nonpython
 
Posts: 7
Joined: Thu Mar 18, 2010 12:10 am

Re: Any obvious frackups?

by charliex on Thu Mar 18, 2010 11:55 am

C10 looks like its incorrectly wired in the schematic.
http://032.la - Null Space Labs.
charliex
 
Posts: 179
Joined: Sat Nov 28, 2009 5:54 pm
Location: Las Vegas

Re: Any obvious frackups?

by westfw on Thu Mar 18, 2010 6:58 pm

I think your high power traces (it is a high-power motor driver, right?) are MUCH too narrow.
Agree with charlie that there is something wrong with the xtal/c10 wiring. Shouldn't both sides of the crystal connect to the micro? Do you really want trimmer caps here?
Bypass caps should be located close to the power pins of chips.
GND of mega8 doesn't seem to be connected. The 8pin chips also have a disturbing number of unconnected pins, but I didn't look up what they actually are...

It looks vaguely like the board would route better if the mega8 were rotated 180 degrees.
westfw
 
Posts: 1582
Joined: Fri Apr 27, 2007 1:01 pm
Location: SF Bay area

Please be positive and constructive with your questions and comments.