๐Ÿ“ฃ๐Ÿ“ช ๐Ÿšš Adafruit will not be shipping USPS orders Monday October 14, 2019 ๐Ÿ—“. Expedited USPS orders placed after 11am ET ๐Ÿ•š Friday October 11 will go out Tuesday October 15 ๐Ÿ“ฃ๐Ÿ“ช๐Ÿšš
0

Wiring Adafruit OLED to Pi Zero W problem
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Wiring Adafruit OLED to Pi Zero W problem

by m1lkyj0e on Thu Aug 08, 2019 10:09 am

Hello,

I can't seem to get my OLED display to work (black screen) with my Raspberry Pi Zero W.

I don't know if it's a wiring issue or duff device. When I run the command 'i2cdetect -y 1', the device does not show up!? I (think) I'm setting it up in SPI mode and have followed various guides online, but to no avail.

I'm trying to follow this: https://learn.adafruit.com/monochrome-o ... 8x64-oleds and http://www.raspberrypirobotics.com/inte ... pberry-pi/

Do I need to connect all the jumper cables on the top and bottom rows, and are all raspberry pi GPIO pins numbered the same?

I don't really know what I'm doing, lol.

Thanks.
Attachments
20190808_122739.jpg
My current setup.
20190808_122739.jpg (146.96 KiB) Viewed 81 times

m1lkyj0e
 
Posts: 2
Joined: Thu Aug 08, 2019 9:59 am

Re: Wiring Adafruit OLED to Pi Zero W problem

by franklin97355 on Thu Aug 08, 2019 7:52 pm

Can we see closeups of both sides of the display?

franklin97355
 
Posts: 21204
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: Wiring Adafruit OLED to Pi Zero W problem

by m1lkyj0e on Fri Aug 09, 2019 4:51 pm

Now showing this

pi@raspberrypi:~ $ sudo i2cdetect -y 1
0 1 2 3 4 5 6 7 8 9 a b c d e f
00: -- -- -- -- -- -- -- -- -- -- -- -- --
10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
30: -- -- -- -- -- -- -- -- -- -- -- -- -- 3d -- --
40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
70: -- -- -- -- -- -- -- --

I'm now getting this error...

Traceback (most recent call last):
File "/usr/local/bin/lcd-show.py", line 47, in <module>
disp.begin()
File "/usr/local/lib/python2.7/dist-packages/Adafruit_SSD1306/SSD1306.py", line 148, in begin
self._initialize()
File "/usr/local/lib/python2.7/dist-packages/Adafruit_SSD1306/SSD1306.py", line 247, in _initialize
self.command(SSD1306_DISPLAYOFF) # 0xAE
File "/usr/local/lib/python2.7/dist-packages/Adafruit_SSD1306/SSD1306.py", line 129, in command
self._i2c.write8(control, c)
File "build/bdist.linux-armv6l/egg/Adafruit_GPIO/I2C.py", line 116, in write8
File "build/bdist.linux-armv6l/egg/Adafruit_PureIO/smbus.py", line 256, in write_byte_data
IOError: [Errno 121] Remote I/O error
Attachments
20190809_214014.jpg
20190809_214014.jpg (121.54 KiB) Viewed 56 times
20190809_214001.jpg
20190809_214001.jpg (140.64 KiB) Viewed 56 times

m1lkyj0e
 
Posts: 2
Joined: Thu Aug 08, 2019 9:59 am

Please be positive and constructive with your questions and comments.