0

DIY Pocket PiGRRL PowerBoost 1000
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

DIY Pocket PiGRRL PowerBoost 1000

by vanwilder on Mon Aug 19, 2019 6:11 pm

Hi everyone,
recently I bought Pigrlls pocket kit.
I put it together and had a lot of fun with it.
A couple of days ago PowerBoost 1000 started acting funny.
It would cut off suddenly and it would not start by turning on the switch.
It only starts if you plug-in USB cable to charge.
After it starts it runs without a problem, and I can disconnect the USB.
If I turn it off I have to use the USB cable to start it again.
I did some checking just to make sure nothing else causes a problem.
The switch is ok, I tried using a different battery, checked all solder joint.
At this point, I am quite sure that the PowerBoost 1000 is somewhat faulty.

Please advise if this is something that can be fixed.

Thank you in advance.
Best regards,
Marko

vanwilder
 
Posts: 3
Joined: Sat Aug 10, 2019 8:31 pm

Re: DIY Pocket PiGRRL PowerBoost 1000

by adafruit_support_mike on Wed Aug 21, 2019 12:28 am

Post a photo showing your hardware and connections and we'll take a look. 800x600 images usually work best.

adafruit_support_mike
 
Posts: 58799
Joined: Thu Feb 11, 2010 2:51 pm

Re: DIY Pocket PiGRRL PowerBoost 1000

by vanwilder on Sat Aug 24, 2019 1:38 pm

Hi Mike,

here are pictures of the circuit.
The first picture shows the system powered off and charged up.
1.jpg
1.jpg (674.71 KiB) Viewed 32 times


The second picture shows system unplugged from USB and the switch in on position.
At this point nothing happens.
2.jpg
2.jpg (679.24 KiB) Viewed 32 times


The third picture shows that if I plug in a USB power the system turns on.
At this point, I can disconnect USB and it will continue to work until I turn it off.
3.jpg
3.jpg (633.72 KiB) Viewed 32 times


I also did some testing.
If there is no load attached to the booster everything works fine.
Also when I turn on the switch on if the USB power not plugged in the battery voltage goes from 4.23V to just under 1V.
After plugging in USB power everything goes back to normal.
If the switch is in the on position while plugging in the battery into the booster it will turn on.
I also tested everything with two other batteries 4000mAh and 650mAh with the same results.
I tested all of this with RPI plugged into the screen and only powering the screen and amp

Let me know if anything looks weird.

vanwilder
 
Posts: 3
Joined: Sat Aug 10, 2019 8:31 pm

Re: DIY Pocket PiGRRL PowerBoost 1000

by adafruit_support_mike on Sat Aug 24, 2019 9:41 pm

Thank you. Your construction looks pretty good.

With USB disconnected, what voltage do you see between the PowerBoost's BAT and GND pins, and between VS and GND?

adafruit_support_mike
 
Posts: 58799
Joined: Thu Feb 11, 2010 2:51 pm

Please be positive and constructive with your questions and comments.