0

can't adjust TPL5110's timing interval
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

can't adjust TPL5110's timing interval

by trbrooks on Tue Aug 20, 2019 2:27 pm

My tpl5110 was working as it should, but then suddenly became stuck on a timing interval of ~6 seconds.

I tried cutting power, pressing "reset" to discharge any capacitors, and adjusting the trimpot to a new position, including both of the extremes, but that did not work -- it is still stuck on 6 seconds.

I then tried cutting the trace for the trimpot and using several different resistors to set the timer. This also did not change the interval.

Why is it behaving this way?

trbrooks
 
Posts: 4
Joined: Mon Aug 12, 2019 3:14 pm

Re: can't adjust TPL5110's timing interval

by adafruit_support_mike on Wed Aug 21, 2019 3:28 am

Post a photo showing your hardware and connections and we'll take a look. 800x600 images usually work best.

adafruit_support_mike
 
Posts: 58843
Joined: Thu Feb 11, 2010 2:51 pm

Re: can't adjust TPL5110's timing interval

by trbrooks on Wed Aug 21, 2019 2:21 pm

]Hi Mike, thanks for your reply.

You said elsewhere that in diagnosing timing issues, one should disconnect everything, turn the potentiometer all the way clockwise, and see if the the LED flashes at ~10Hz. I have tried that, and it only flashes once about every 6 seconds. Unplugging and resetting everything with the potentiometer adjusted has the same result -- always 6 seconds.

When I power my setup, it turns off and then on again every six seconds. Here is a photo of one of the setups I've used, though the behavior is not specific to this setup. (Please forgive the blurriness).

[attachment=0]setup.jpg[/attachment
Attachments
setup.jpg
setup.jpg (984.56 KiB) Viewed 76 times

trbrooks
 
Posts: 4
Joined: Mon Aug 12, 2019 3:14 pm

Re: can't adjust TPL5110's timing interval

by adafruit_support_mike on Thu Aug 22, 2019 1:11 am

I'm sorry, I can't make out the details in that shot. Could you post one with clearer focus please?

adafruit_support_mike
 
Posts: 58843
Joined: Thu Feb 11, 2010 2:51 pm

Re: can't adjust TPL5110's timing interval

by trbrooks on Fri Aug 23, 2019 5:02 pm

Here is a new image.
Attachments
upload.jpg
upload.jpg (447.44 KiB) Viewed 53 times

trbrooks
 
Posts: 4
Joined: Mon Aug 12, 2019 3:14 pm

Re: can't adjust TPL5110's timing interval

by adafruit_support_mike on Sat Aug 24, 2019 12:04 am

That's much clearer, thank you.

It looks like the solder joints need some work. I can see exposed gold on some of the pads, and that's often a sign that the solder hasn't made a good connection to the pad.

Take a look at our soldering tutorial:

https://learn.adafruit.com/adafruit-gui ... -soldering

Give the joints a dab of flux, and reheat them. See if that helps.

adafruit_support_mike
 
Posts: 58843
Joined: Thu Feb 11, 2010 2:51 pm

Re: can't adjust TPL5110's timing interval

by trbrooks on Mon Aug 26, 2019 11:58 am

Thanks again for your reply, Mike.

I improved the soldering of the joints, but the issue persists. Why might this be?

trbrooks
 
Posts: 4
Joined: Mon Aug 12, 2019 3:14 pm

Re: can't adjust TPL5110's timing interval

by adafruit_support_mike on Wed Aug 28, 2019 1:17 am

Hmm.. try measuring the resistance between the DELAY pin and GND as you connect resistors of different values.. 100 Ohms, 1k, and 10k should be enough to show any patterns.

adafruit_support_mike
 
Posts: 58843
Joined: Thu Feb 11, 2010 2:51 pm

Please be positive and constructive with your questions and comments.