0

M4 receiver/fob not working
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

M4 receiver/fob not working

by johnwargo on Sat Aug 24, 2019 1:36 pm

I bought three receivers and a fob and I'm having a heck of a time getting them to work. I was finally able to get one of them working, but the pins are backwards - Pin D0 runs on button D, D1, buton C, etc. That surprised me and cost me some time.

When I finally did get it to work, it only works some of the time and other times it toggles on/off repeatedly (about 4Hz) as long as I hold the button down (which is not how this is supposed to work)

Are these things that flaky? What do I do here? Replace the fob? receiver? Help!!!

johnwargo
 
Posts: 28
Joined: Mon Jan 28, 2013 9:21 am

Re: M4 receiver/fob not working

by johnwargo on Mon Sep 02, 2019 7:18 pm

Can someone please help me?

johnwargo
 
Posts: 28
Joined: Mon Jan 28, 2013 9:21 am

Re: M4 receiver/fob not working

by adafruit_support_mike on Tue Sep 03, 2019 2:20 am

Sorry for the delay.

Could you post a photo showing the receivers please? 800x600 images usually work best.

adafruit_support_mike
 
Posts: 58856
Joined: Thu Feb 11, 2010 2:51 pm

Re: M4 receiver/fob not working

by johnwargo on Tue Sep 03, 2019 7:10 am

Here's a photo of all of them.
Attachments
2019-09-03 07.02.38_1.png
2019-09-03 07.02.38_1.png (775.29 KiB) Viewed 86 times

johnwargo
 
Posts: 28
Joined: Mon Jan 28, 2013 9:21 am

Re: M4 receiver/fob not working

by adafruit_support_mike on Wed Sep 04, 2019 1:17 am

Thank you. I don't see anything obviously out of place in the hardware.

Try straightening the antennas and see if that has any effect on the range or ability to detect a signal. It won't have any effect on my decision about whether to issue a replacement.. we know that devices have to be hooked up before they can be tested.

adafruit_support_mike
 
Posts: 58856
Joined: Thu Feb 11, 2010 2:51 pm

Re: M4 receiver/fob not working

by johnwargo on Wed Sep 04, 2019 8:04 am

I hooked up two out of three of them with little success. Straighten it like all the way out straight?

johnwargo
 
Posts: 28
Joined: Mon Jan 28, 2013 9:21 am

Re: M4 receiver/fob not working

by adafruit_support_mike on Wed Sep 04, 2019 11:43 pm

Yep.. changing the shape of an antenna changes the way it behaves, sometimes enough to have a noticable effect on reception.

adafruit_support_mike
 
Posts: 58856
Joined: Thu Feb 11, 2010 2:51 pm

Re: M4 receiver/fob not working

by johnwargo on Wed Sep 11, 2019 2:46 pm

OK, so I expanded the antenna on two of the three receivers (I'd let the smoke out of the third one) and it works now, but only at a distance of between 12 and 20 inches. Shouldn't it be longer than that?

johnwargo
 
Posts: 28
Joined: Mon Jan 28, 2013 9:21 am

Re: M4 receiver/fob not working

by adafruit_support_mike on Thu Sep 12, 2019 12:31 am

Yeah, you should get more range than that.

Let's try a new fob and see if that improves things. Send a note containing a link to this page and your order number to support@adafruit.com. The folks there will get you a new keyfob.

adafruit_support_mike
 
Posts: 58856
Joined: Thu Feb 11, 2010 2:51 pm

Please be positive and constructive with your questions and comments.