Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

WS2812B flickering towards the end of the strip
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

WS2812B flickering towards the end of the strip

by MeliodasX on Fri May 22, 2020 5:48 am

Hi,
I am trying to create a ambient light setup for my TV. Everything is working fine except the LEDs start to flicker towards the 2m mark. I have the 30 LEDs/M strip. 84 LEDs are being used for this project. I have injected power at the start, in the middle and at the end but nothing seems to fix the issue. I am stumped. I couldn't find anything online that could fix my issue so I turn here for help. I would be very grateful if somebody could help figure out this problem.

They don't flicker if the LED colors are not updating. They only flicker when the LEDs are constantly being updated with new colors.

P.S: I have worked with electronics in university but this is the first time I am working with addressable LEDs.

MeliodasX
 
Posts: 9
Joined: Fri May 22, 2020 5:00 am

Re: WS2812B flickering towards the end of the strip

by dastels on Fri May 22, 2020 10:09 am

What are you controlling the strips with? What board? What are you powering them with? volts and amps.

Dave

dastels
 
Posts: 3480
Joined: Tue Oct 20, 2015 3:22 pm

Re: WS2812B flickering towards the end of the strip

by MeliodasX on Fri May 22, 2020 10:34 am

I am using an arduino Uno as a controller. The strip is powered by 2 5V 2 Amp Wall Chargers (One on either side). The power to the middle is being supplied by the charger at the end of the strip. Essentially one charger is driving the start of the strip while the second is driving the middle and the end. Now I have done the calculations with 0.06A as the base for current draw of each LED but I don't have a 6A Power supply on hand so I am just using these supplies for testing purposes.

MeliodasX
 
Posts: 9
Joined: Fri May 22, 2020 5:00 am

Re: WS2812B flickering towards the end of the strip

by dastels on Fri May 22, 2020 12:46 pm

As long as those 5v lines aren't connected that should be ok. You're driving the data line of the NeoPixels directly from an UNO pin?

Dave

dastels
 
Posts: 3480
Joined: Tue Oct 20, 2015 3:22 pm

Re: WS2812B flickering towards the end of the strip

by MeliodasX on Fri May 22, 2020 12:55 pm

Yes. I had a jumper wire first but I have since removed it in hopes to get a better connection to remove the flickering. Didn't work sadly.

Here are some videos of when the light flickers and when it doesn't

https://youtu.be/XzdR-KffdUk

https://youtu.be/h5se6npDYVw

MeliodasX
 
Posts: 9
Joined: Fri May 22, 2020 5:00 am

Re: WS2812B flickering towards the end of the strip

by dastels on Fri May 22, 2020 6:22 pm

Grounds are all connected?

dastels
 
Posts: 3480
Joined: Tue Oct 20, 2015 3:22 pm

Re: WS2812B flickering towards the end of the strip

by MeliodasX on Sat May 23, 2020 12:39 am

As far as I have checked, yes. Tho the ground at the end of the strip is not the same as the start (Since I am using a different adaptor for it). Should they be common as well?

MeliodasX
 
Posts: 9
Joined: Fri May 22, 2020 5:00 am

Re: WS2812B flickering towards the end of the strip

by MeliodasX on Sat May 23, 2020 3:12 am

MeliodasX wrote:As far as I have checked, yes. Tho the ground at the end of the strip is not the same as the start (Since I am using a different adaptor for it). Should they be common as well?


Ok I just noticed a slight wiring error in my strip which I have fixed now. Basically the two adaptors were connected to the same 5V line. I have since seperated the line and now they are both running on seperate 5v lines with common ground. However the flicker is still present. I dont know what to do anymore.

MeliodasX
 
Posts: 9
Joined: Fri May 22, 2020 5:00 am

Re: WS2812B flickering towards the end of the strip

by dastels on Sat May 23, 2020 1:13 pm

Yes, all grounds should be connected together. Every other voltage is with respect to ground. If grounds aren't connected they can vary a bit (due to RF noise, induction, etc) and through off the meaning of signals.

Dave

dastels
 
Posts: 3480
Joined: Tue Oct 20, 2015 3:22 pm

Re: WS2812B flickering towards the end of the strip

by MeliodasX on Sat May 23, 2020 1:17 pm

They all share a common ground now. The flicker is still present. It kinda got worse ever since I separated the 5v lines.

MeliodasX
 
Posts: 9
Joined: Fri May 22, 2020 5:00 am

Re: WS2812B flickering towards the end of the strip

by dastels on Sat May 23, 2020 5:57 pm

I just read over the coversation. Is it the second strip that flickers?

Dave

dastels
 
Posts: 3480
Joined: Tue Oct 20, 2015 3:22 pm

Re: WS2812B flickering towards the end of the strip

by MeliodasX on Sat May 23, 2020 8:52 pm

Yea the leds after the 2m mark flickers. Now after seperating the 5v rail, the whole 2nd stril flickers.

MeliodasX
 
Posts: 9
Joined: Fri May 22, 2020 5:00 am

Re: WS2812B flickering towards the end of the strip

by dastels on Sun May 24, 2020 11:53 am

Double check the connections between the strips. I would just resolder them.

Dave

dastels
 
Posts: 3480
Joined: Tue Oct 20, 2015 3:22 pm

Re: WS2812B flickering towards the end of the strip

by MeliodasX on Sat May 30, 2020 1:57 pm

I have been busy lately so I couldn't get to work on this sooner. However I have since swapped out the part of strip that was causing flickering and it now works perfectly. It flickers for a microsecond here and there but its not noticeable and everything works fine considering I am down on the recommended current amperage by 1.5 Amps but everything works fine now.

Thank you for your time.

MeliodasX
 
Posts: 9
Joined: Fri May 22, 2020 5:00 am

Re: WS2812B flickering towards the end of the strip

by dastels on Sat May 30, 2020 4:11 pm

Glad to hear it worked out.

dastels
 
Posts: 3480
Joined: Tue Oct 20, 2015 3:22 pm

Please be positive and constructive with your questions and comments.