Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

trouble compiling M4SK
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

trouble compiling M4SK

by jrraines on Thu Jun 11, 2020 6:23 pm

I was trying to compile the M4SK program without changes. I got these errors :

Code: Select all | TOGGLE FULL SIZE
Arduino: 1.8.12 (Mac OS X), TD: 1.52, Board: "Adafruit MONSTER M4SK (SAMD51), Enabled, 120 MHz (standard), Small (-Os) (standard), 50 MHz (standard), TinyUSB, Off"

/Users/raine001/Documents/Arduino/libraries/Adafruit_TinyUSB_Library/src/Adafruit_USBD_MIDI.cpp: In member function 'bool Adafruit_USBD_MIDI::send(const uint8_t*)':
/Users/raine001/Documents/Arduino/libraries/Adafruit_TinyUSB_Library/src/Adafruit_USBD_MIDI.cpp:117:10: error: 'tud_midi_send' was not declared in this scope
   return tud_midi_send(packet);
          ^~~~~~~~~~~~~
/Users/raine001/Documents/Arduino/libraries/Adafruit_TinyUSB_Library/src/Adafruit_USBD_MIDI.cpp:117:10: note: suggested alternative: 'tud_midi_read'
   return tud_midi_send(packet);
          ^~~~~~~~~~~~~
          tud_midi_read
/Users/raine001/Documents/Arduino/libraries/Adafruit_TinyUSB_Library/src/Adafruit_USBD_MIDI.cpp: In member function 'bool Adafruit_USBD_MIDI::receive(uint8_t*)':
/Users/raine001/Documents/Arduino/libraries/Adafruit_TinyUSB_Library/src/Adafruit_USBD_MIDI.cpp:121:10: error: 'tud_midi_receive' was not declared in this scope
   return tud_midi_receive(packet);
          ^~~~~~~~~~~~~~~~
/Users/raine001/Documents/Arduino/libraries/Adafruit_TinyUSB_Library/src/Adafruit_USBD_MIDI.cpp:121:10: note: suggested alternative: 'tud_midi_write'
   return tud_midi_receive(packet);
          ^~~~~~~~~~~~~~~~
          tud_midi_write

exit status 1
Error compiling for board Adafruit MONSTER M4SK (SAMD51).


I think they relate to changes to a library made 6-7 weeks ago. ?

jrraines
 
Posts: 40
Joined: Sat Jan 23, 2010 1:42 pm

Re: trouble compiling M4SK

by jrraines on Fri Jun 12, 2020 5:36 pm

my mistake. I deleted the whole thing and re-downloaded it and it works fine. I must have typed something somewhere.

jrraines
 
Posts: 40
Joined: Sat Jan 23, 2010 1:42 pm

Please be positive and constructive with your questions and comments.