Adafruit is open and shipping! Let's build back better, together!
0

MCP4725 A0 address line ignored
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

MCP4725 A0 address line ignored

by gvcastellano on Mon Jun 29, 2020 6:44 pm

Not using CircuitPython for this but this seems to be where most of the MCP4725 questions end up. Plz redirect me as appropriate.

I am trying to use the MCP4725 with a Raspberry Pi 2011.12 and had great success with the 4.096 V voltage ref breakout board, driving it from some C code. The only problem is when I try to hook up a second on the same line with the A0 address line pulled high so it shows as ID 0x63, or even have a single with the high address.

This pic https://drive.google.com/file/d/1CQBD0H ... sp=sharing shows the wiring setup with positions for two breakout boards with one having a +Vcc A0. I've tried three different chips, each time verifying *on the leg of the device* that voltage is either the source 5V or the regulated 4.096 which I wire to Vdd (I try both). When I have two MCPs in these slots, they both answer to 0x62 and I can see them both moving the DAC output according to the commands. I also tried having the A0 line unconnected. I power up the DAC first and then the Pi to make sure the devices are recognized. I've tried all three breakout boards in the A0=1 slot and they always show up as device 0x62. My next is to try different Pi models as hosts but that's going to be a bit of work.

I've checked the demo diagram in the 4725 datasheet and scanned the forums and the closest topic is this: viewtopic.php?f=22&t=122090&p=609776 but doesn't seem to apply. I use i2cdetect to scan the bus but it only ever shows the 0x62 device.

Eventually I hope to run the 8-DAC version, plus I've ordered up a bunch with different burnt-in addresses so I'm not stuck but I'd sure like to master this.

"Thanks in advance for any insight you can provide."

gvcastellano
 
Posts: 1
Joined: Mon Jun 29, 2020 5:18 pm

Re: MCP4725 A0 address line ignored

by siddacious on Tue Jun 30, 2020 12:34 pm

I've moved this to the "General Project Help" section because looking at that picture, you appear to have put together your own MCP4725 circuit (props for the initiative!)

I would suggest starting back at square one and replicating exactly a known good circuit such as the Adafruit breakout:
https://learn.adafruit.com/mcp4725-12-b ... l/download

Once you have the most minimal version of that working scanning with the default address, then try tying the address pin high (or low depending on what the default is). We know the adafruit circuit works because we sell lots of 'em and we test every function of every single one before they go out, so it's a good reference. If the issue persists, I'd suggest buying a known good breakout that has schematics available from a reputable source (like Adafruit ;-) ) and using that to compare measurements to.

Don't try introducing a second sensor until you have the second address showing up by itself and make sure to check all the things that "it couldn't possibly be" because that's where we never check our work.

Good luck!

siddacious
 
Posts: 371
Joined: Fri Apr 21, 2017 3:09 pm

Please be positive and constructive with your questions and comments.