Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

Audio FX Soundboard not playing sound
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Audio FX Soundboard not playing sound

by SpaceShark on Thu Aug 06, 2020 7:54 pm

Hi,

I have a Adafruit Audio FX Sound Board - WAV/OGG Trigger with 16MB Flash (https://www.adafruit.com/product/2220) and I was trying to use it for making a custom car horn. I have 3 OGG sound files loaded on (T01.OGG, T02.OGG, T03.OGG). When I plug it in to my circuit, the green light turns on but when I connect the “1” pin and the ground “GND”, nothing happens. I don’t have the pins soldered on because both came broken in half in shipping (not a big deal, I have other wire pins the work fine). I have it hooked up to an amp, and we have tested all of the parts of the circuit and the only faulty part seems to be the board. The board shows it has power, but nothing happens. Please help me troubleshoot it, thank you.
(The circuit is not powered in the photos so the green light is not on, when it is powered it does turn on)
Attachments
BC3FA2E5-D3E4-40E4-B281-E18C4A530BA6.jpeg
The button I am using (green is GND and blue is 1)
BC3FA2E5-D3E4-40E4-B281-E18C4A530BA6.jpeg (94 KiB) Viewed 57 times
47CB08B2-3B37-474C-A246-47E67CE9718C.jpeg
GND and 1 connected (doesn’t work when the circuit is powered)
47CB08B2-3B37-474C-A246-47E67CE9718C.jpeg (113.21 KiB) Viewed 57 times
0B13D92E-FCE3-4B81-95B2-4E169D91D720.jpeg
Entire circuit
0B13D92E-FCE3-4B81-95B2-4E169D91D720.jpeg (346.27 KiB) Viewed 57 times

SpaceShark
 
Posts: 5
Joined: Thu Aug 06, 2020 6:27 pm

Re: Audio FX Soundboard not playing sound

by dastels on Thu Aug 06, 2020 8:06 pm

The board won't play sound when connected to USB, so try powering it a different way. See https://learn.adafruit.com/adafruit-audio-fx-sound-board/powering-it.

Dave

dastels
 
Posts: 3494
Joined: Tue Oct 20, 2015 3:22 pm

Re: Audio FX Soundboard not playing sound

by adafruit_support_carter on Thu Aug 06, 2020 8:08 pm

For the sake of troubleshooting, please try the demo files you can download from here:
https://learn.adafruit.com/adafruit-aud ... udio-files

Also, do you have some headphones? That way we can rule out anything with the amp/speaker.

adafruit_support_carter
 
Posts: 16922
Joined: Tue Nov 29, 2016 2:45 pm

Re: Audio FX Soundboard not playing sound

by SpaceShark on Thu Aug 06, 2020 10:22 pm

I have tried the headphones trick, And it still does not play sound. It also is not connected via usb, rather a converter.

SpaceShark
 
Posts: 5
Joined: Thu Aug 06, 2020 6:27 pm

Re: Audio FX Soundboard not playing sound

by adafruit_support_carter on Fri Aug 07, 2020 11:32 am

Did you also try with the samples linked above?

And just to be sure - it sounds like the board is working OK in terms of showing up on your PC and allowing you to copy over sound files?

adafruit_support_carter
 
Posts: 16922
Joined: Tue Nov 29, 2016 2:45 pm

Re: Audio FX Soundboard not playing sound

by SpaceShark on Fri Aug 07, 2020 5:31 pm

The example sound files did not work, and yes, the board does work normally connecting to my PC and copying files

SpaceShark
 
Posts: 5
Joined: Thu Aug 06, 2020 6:27 pm

Re: Audio FX Soundboard not playing sound

by adafruit_support_carter on Fri Aug 07, 2020 7:05 pm

Can you post a screen shot of what the folder contents look like on the Sound FX board.

Do you ever see the red ACT LED do anything?

adafruit_support_carter
 
Posts: 16922
Joined: Tue Nov 29, 2016 2:45 pm

Re: Audio FX Soundboard not playing sound

by SpaceShark on Sat Aug 08, 2020 11:17 am

Here is the photo of the sound files I want to use
The red light would not light up when we touched GND and #1 - 10 pins. The light did light up when we were fighting around with it trying other kinda of pin combinations so the light works, it just doesn’t turn on when it’s supposed to.
Attachments
B3EE2F20-BDD5-4E34-A536-66F8E961E6FF.jpeg
B3EE2F20-BDD5-4E34-A536-66F8E961E6FF.jpeg (83.23 KiB) Viewed 32 times

SpaceShark
 
Posts: 5
Joined: Thu Aug 06, 2020 6:27 pm

Re: Audio FX Soundboard not playing sound

by BERGIE1 on Sat Aug 08, 2020 6:58 pm

I'm having trouble myself with a 2210 2mb board. green light on. speaker works. running between 3.5 to 5v. NO Red light at all.
Don't know if it's wrong file transfers, OR names, OR if board needs reset..... Newbie to this, but up till this point all has gone as tutorials stated...
Cant get a red light from ANY trigger, with or without files on board.
Actually, I DID get a Red Light - when I accidentally ramped voltage past 6v....! It was a 1-2sec spike, but nothing was triggered or running, just powering up

BERGIE1
 
Posts: 3
Joined: Sat Aug 08, 2020 6:50 pm

Re: Audio FX Soundboard not playing sound

by dastels on Sat Aug 08, 2020 9:37 pm

BERGIE1: Please make a new topic for your issue.

Dave

dastels
 
Posts: 3494
Joined: Tue Oct 20, 2015 3:22 pm

Re: Audio FX Soundboard not playing sound

by BERGIE1 on Sat Aug 08, 2020 9:51 pm

Thought I had. Tried to start new thread, went onto this one. Seemed like there was no answer to your similar prob either, so I thought any answer might help. I don't do forums and had no idea.. thanks for the help answering the problem...

BERGIE1
 
Posts: 3
Joined: Sat Aug 08, 2020 6:50 pm

Re: Audio FX Soundboard not playing sound

by adafruit_support_carter on Mon Aug 10, 2020 10:32 am

@SpaceShark Thanks for the screen photo. Those are not the example files from the zip linked above. Please switch to using those.

adafruit_support_carter
 
Posts: 16922
Joined: Tue Nov 29, 2016 2:45 pm

Re: Audio FX Soundboard not playing sound

by SpaceShark on Tue Aug 11, 2020 10:28 pm

Here are the linked sound files copied onto the board
Attachments
1668D9AB-5BE4-4777-A56C-EFA1C283E5A3.jpeg
1668D9AB-5BE4-4777-A56C-EFA1C283E5A3.jpeg (92.06 KiB) Viewed 11 times
D8EA114F-FDF8-48E0-9FCF-7BB700904880.jpeg
D8EA114F-FDF8-48E0-9FCF-7BB700904880.jpeg (91.37 KiB) Viewed 11 times

SpaceShark
 
Posts: 5
Joined: Thu Aug 06, 2020 6:27 pm

Re: Audio FX Soundboard not playing sound

by adafruit_support_carter on Wed Aug 12, 2020 2:37 pm

Do those files play now?

Note how there's no file extension shown in those screen shots. It looks like you are on Windows and have "hide file extensions" turned on (which is the default behavior). So, the files you were originally using were probably named like T01.OGG.OGG, which is a naming convention the sound board does not support.

adafruit_support_carter
 
Posts: 16922
Joined: Tue Nov 29, 2016 2:45 pm

Please be positive and constructive with your questions and comments.