0

2.8" TFT touch display white screen
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

2.8" TFT touch display white screen

by Bakevaren on Sat May 01, 2021 8:00 am

Hi!

The display: https://www.adafruit.com/product/1770
The guide: https://learn.adafruit.com/adafruit-2-8 ... reakout-v2

I have tried to get the display working using the guide linked above. The display just light up and shows a white screen.

What i have tested:
- 8-BIT and SPI on both arduino MEGA and UNO
- Checked code to make sure the line for shield pin configuration was commented out
- checked wiring multiple times( will check again)
- Tried another computer

When running the example codes, it does not identify the lcd driver, but it's able to identify the resolution of the display. I have been through a lot of threads on forums with similar problems, but none of them was able to work for me.

Any suggestion on how fix this problem?

Thanks in advance!

Bakevaren
 
Posts: 5
Joined: Sat May 01, 2021 7:38 am

Re: 2.8" TFT touch display white screen

by adafruit_support_mike on Sat May 01, 2021 5:42 pm

Post a photo showing your hardware and connections and we'll take a look. 800x600 images usually work best.

adafruit_support_mike
 
Posts: 62768
Joined: Thu Feb 11, 2010 2:51 pm

Re: 2.8" TFT touch display white screen

by Bakevaren on Mon May 03, 2021 7:14 am

Added a photo of the display board. Not sure if that was what you wanted, so let me know if you need more photos.

Thanks!
Attachments
20210503_130944.jpg
20210503_130944.jpg (173.45 KiB) Viewed 178 times

Bakevaren
 
Posts: 5
Joined: Sat May 01, 2021 7:38 am

Re: 2.8" TFT touch display white screen

by adafruit_support_mike on Mon May 03, 2021 10:03 pm

I need to see the signal connections between the display and the microcontroller.

adafruit_support_mike
 
Posts: 62768
Joined: Thu Feb 11, 2010 2:51 pm

Re: 2.8" TFT touch display white screen

by Bakevaren on Tue May 04, 2021 6:06 am

Heres a picture for the digital pins.

For the analog pins it was hard to get it in a picture, but they are connected as listed below:

RD - A0
WR - A1
C/D - A2
CS - A3
Attachments
20210504_115121.jpg
20210504_115121.jpg (166.25 KiB) Viewed 165 times

Bakevaren
 
Posts: 5
Joined: Sat May 01, 2021 7:38 am

Re: 2.8" TFT touch display white screen

by adafruit_support_mike on Tue May 04, 2021 10:40 pm

When you run the test code, does it say an ILI9341 display is connected?

adafruit_support_mike
 
Posts: 62768
Joined: Thu Feb 11, 2010 2:51 pm

Re: 2.8" TFT touch display white screen

by Bakevaren on Wed May 05, 2021 1:01 am

No. When running the code, the serial monitor tells me the lcd driver is unknown.

Bakevaren
 
Posts: 5
Joined: Sat May 01, 2021 7:38 am

Re: 2.8" TFT touch display white screen

by adafruit_support_mike on Thu May 06, 2021 1:23 am

Okay, that gives us a place to start. Double-check the wiring for the CS, C/D, RD, and RW signals. Those are most likely to be involved in a basic communication failure.

Check continuity from one board to the other with a multimeter. Sometimes you can get a jumper whose wire is broken inside the insulation.

adafruit_support_mike
 
Posts: 62768
Joined: Thu Feb 11, 2010 2:51 pm

Re: 2.8" TFT touch display white screen

by Bakevaren on Tue May 11, 2021 5:33 am

Hi, sorry for the late reply.

I tested the continuity of the wires and it all seems to be ok. Also checked the wiring, but it doesn't change anything.
Thanks again for help!

Bakevaren
 
Posts: 5
Joined: Sat May 01, 2021 7:38 am

Re: 2.8" TFT touch display white screen

by adafruit_support_mike on Wed May 12, 2021 9:09 pm

Try removing and reseating the TFT's flex cable: pull the black clips at the ends of the fine-pitch connector toward the slot to release the cable. Pull the cable all the way out of the connector and put it back, making sure it's fully seated all the way across. Then press the clips at the ends of the cable back to lock the cable in place.

adafruit_support_mike
 
Posts: 62768
Joined: Thu Feb 11, 2010 2:51 pm

Re: 2.8" TFT touch display white screen

by gulliver22 on Sat May 22, 2021 2:08 pm

Im having the same problem, though my Arduino Mega 2560, so the display plugs directly onto my Arduino. When I run the grapicstest, i get this from the serial monitor:

ILI9341 Test!
Display Power Mode: 0x0
MADCTL Mode: 0x0
Pixel Format: 0x0
Image Format: 0x0
Self Diagnostic: 0x0
(then a bunch of benchmark times)

I am using the wall wart power supply.

TIA

gulliver22
 
Posts: 3
Joined: Sat May 22, 2021 2:00 pm

Please be positive and constructive with your questions and comments.