0

Relay FeatherWing Signal
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Relay FeatherWing Signal

by EmilyJackson on Thu May 06, 2021 5:12 pm

I have the non-latching featherwing relay signal hooked up to my feather proto M0 pin 13. I'm not getting a voltage when measuring the output terminal block, and the signal LED is not turning on. However, I do get a voltage measurement from the signal port at the appropriate time according to my code. Could this mean I've fried something on the relay board or that I'm missing something in my Arduino sketch? If I've fried something, is there something I can do to avoid doing it again?
The basic code is :
int UVC1 = 13;
void setup() {
pinMode(UVC1, OUTPUT);
digitalWrite(UVC1, LOW);
}
void loop() {
if ... {
digitalWrite(UVC1, HIGH);
delay(1000);
digitalWrite(UVC1, LOW);
}
Attachments
relay.jpg
relay.jpg (396.73 KiB) Viewed 46 times

EmilyJackson
 
Posts: 7
Joined: Thu May 06, 2021 4:44 pm

Re: Relay FeatherWing Signal

by dastels on Thu May 06, 2021 5:48 pm

The 3v connection needs to be connected to the feather as well. It's used to power both the light and the relay.

You won't get any voltage on the output terminal block; the relay is simply a double throw switch. When the relay isn't powered COM and NC are connected. When it's powered COM and NO are connected.

Dave

dastels
 
Posts: 6466
Joined: Tue Oct 20, 2015 3:22 pm

Please be positive and constructive with your questions and comments.