0

Audio FX Sound Board - can only play AO#0 first and internal
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Audio FX Sound Board - can only play AO#0 first and internal

by M28cruiser on Fri May 07, 2021 1:09 am

Hi there,
I brought the Adafruit Audio FX Sound Board + 2x2W Amp - 16MB, and is having issues with it. I was hoping to use the sound board to spruce up the sound effect for the family table hockey game (National anthem, rally sounds, crowd noise, goal horns, etc...)

1. I am only able to get the sound from Audio Out (AO) 0 to play on demand. AO 1 to 10 will only play if AO 0 was played first AND was allowed to completely finish. If I reset the board (Gnd to RST) or power it off/ on, then AO 1 - 10 will not play directly. I must play AO 0 first or the other AO will not respond. I had bypass all buttons and is just using a wire to trigger the AO during troubleshooting.

2. When the board is connected via USB to my computer, the internal storage will no longer show up. Only the green light is lit on the board when it is connected to my laptop (running Windows 10). I have tried waiting over 5 minutes, but nothing shows up. I had swapped out several USB wires as well, and even tried connecting it to other PCs.

The current files stored in the internal storage should be labeled as:
T00.ogg
T01.ogg
T02.ogg
T03.ogg
T04.ogg
T05RAND0.ogg
T05RAND1.ogg
T05RAND2.ogg
T06.ogg
T08.ogg
T09.ogg
T010.ogg

I am powering the board with a USB wall plug / portable battery pack.

Please help. Is there a way to restore the factory default settings? I have no idea what else to try at this point. Thanks.

Regards,
Matt

M28cruiser
 
Posts: 5
Joined: Fri May 07, 2021 12:11 am

Re: Audio FX Sound Board - can only play AO#0 first and inte

by M28cruiser on Fri May 07, 2021 1:47 pm

@adafruit_support_bill - Any recommendations? Thanks.

M28cruiser
 
Posts: 5
Joined: Fri May 07, 2021 12:11 am

Re: Audio FX Sound Board - can only play AO#0 first and inte

by adafruit_support_mike on Sun May 09, 2021 11:37 pm

Post a photo showing your hardware and connections and we'll take a look. 800x600 images usually work best.

adafruit_support_mike
 
Posts: 62799
Joined: Thu Feb 11, 2010 2:51 pm

Re: Audio FX Sound Board - can only play AO#0 first and inte

by M28cruiser on Mon May 10, 2021 5:01 pm

Hi Mike. Here are a few photos. When I’m testing the sound i had bypass the buttons and I m just connecting the AO points to the ground directly. Thanks.
Attachments
4EF10090-17B8-4F57-B3B6-8BA66AA63B5E.jpeg
4EF10090-17B8-4F57-B3B6-8BA66AA63B5E.jpeg (268.83 KiB) Viewed 95 times
C41DA7ED-861E-49F6-98A5-9D101A1A987D.jpeg
C41DA7ED-861E-49F6-98A5-9D101A1A987D.jpeg (160.43 KiB) Viewed 95 times
AB5EBD2A-4D30-4172-870A-58CDB005281F.jpeg
AB5EBD2A-4D30-4172-870A-58CDB005281F.jpeg (246.88 KiB) Viewed 95 times

M28cruiser
 
Posts: 5
Joined: Fri May 07, 2021 12:11 am

Re: Audio FX Sound Board - can only play AO#0 first and inte

by adafruit_support_mike on Mon May 10, 2021 10:51 pm

Hmm.. the solder joints on the FX Board can use some work. I see exposed gold on some of the pads, and can see into a few of the holes.

Take a look at our soldering tutorial:

https://learn.adafruit.com/adafruit-fea ... /downloads

Give the joints a dab of flux, and reheat them. You want a smooth, shiny cone that covers the pad and sweeps up to the wire.

adafruit_support_mike
 
Posts: 62799
Joined: Thu Feb 11, 2010 2:51 pm

Re: Audio FX Sound Board - can only play AO#0 first and inte

by M28cruiser on Fri May 14, 2021 12:17 am

@ adafruit_support_mike thanks for the recommendation to use flux. I did solder it again to cover the hole with the use of flux. Although that did not fix the problem, I was able to identify the issue. The AO#0 and the Reset lines were somehow tapped into each other after the terminal block. I did not see any exposed wires that tapped into each other with the twisted pair Cat 5 cable, but the problem went away after I used a different wire for the reset line after the terminal block.

As for getting the internal storage to show up on the computer, I was able to get that to work after connecting the Gnd to Reset with the USB connected to my computer.

Appreciate the help. Thanks.

M28cruiser
 
Posts: 5
Joined: Fri May 07, 2021 12:11 am

Re: Audio FX Sound Board - can only play AO#0 first and inte

by adafruit_support_mike on Fri May 14, 2021 12:47 am

Glad to hear you got it working. Happy hacking!

adafruit_support_mike
 
Posts: 62799
Joined: Thu Feb 11, 2010 2:51 pm

Please be positive and constructive with your questions and comments.