2mb Audio FX Sound Board triggers not working

Breakout boards, sensors, other Adafruit kits, etc.

Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.
User avatar
Sanksbot
 
Posts: 6
Joined: Sun Mar 24, 2024 1:38 am

2mb Audio FX Sound Board triggers not working

Post by Sanksbot »

Unable to get .wav or .ogg files to trigger. Format seems correct, I initially had 4 files name T01.wav - T04.wav, board shows green led and rst works when grounded but none of the triggers produce sound when grounded. Also tried a single .ogg file named T01.ogg, still no sound when pin 1 is grounded. Thanks for the help!

User avatar
Franklin97355
 
Posts: 23944
Joined: Mon Apr 21, 2008 2:33 pm

Re: 2mb Audio FX Sound Board triggers not working

Post by Franklin97355 »

Have you tried to play the files with your computer? And, have you done any soldering on the board? If so, can you post some pictures? Thanks.

User avatar
Sanksbot
 
Posts: 6
Joined: Sun Mar 24, 2024 1:38 am

Re: 2mb Audio FX Sound Board triggers not working

Post by Sanksbot »

Yes, the sound files play from the board while its plugged in via USB and from source files. On the bottom of the board I soldered the shorter side of the pin set leaving the longer ends up top. I soldered positive button leads to the pins repectively. Next I soldered a ground lead to the ground pin, grouped my button grounds and used a wire nut to join these to the ground lead. After I connected power from 12v to 5v converter in my car, green LED but buttons did not trigger sounds, no activation light shows. I desoldered and removed the pin set to test directly on the board but still no trigger :( I formatted the board to FAT as default, tried .wav and .ogg files inedpendently and no trigger unfortunately. That is most all of my troubleshooting steps and ideas.
Attachments
Full view
Full view
full.jpg (622.27 KiB) Viewed 167 times
Close up
Close up
close.jpg (409.05 KiB) Viewed 167 times

User avatar
adafruit_support_carter
 
Posts: 29522
Joined: Tue Nov 29, 2016 2:45 pm

Re: 2mb Audio FX Sound Board triggers not working

Post by adafruit_support_carter »

After I connected power from 12v to 5v converter in my car
How is that power being applied to the Audio FX Board?

There are known working audio files available here:
https://learn.adafruit.com/adafruit-aud ... udio-files
to help rule out it being something with your audio file formats.

Also remember the caveat that audio playback via triggering does *not* work while plugged into the PC's USB and seeing the audio fx folder.
https://learn.adafruit.com/adafruit-aud ... owering-it

User avatar
Sanksbot
 
Posts: 6
Joined: Sun Mar 24, 2024 1:38 am

Re: 2mb Audio FX Sound Board triggers not working

Post by Sanksbot »

Power is being applied from a 12v to 5v converter in my car which is sent from USB A to the micro USB connection on the board.

I appreciate the sound files! I unzipped and added all of these sounds to the soundboard via USB then disconnected the soundboard from the computer and connected it to 5v power in my car. The 3.5mm audio jack is connected to a known good speaker but there is still no sound produced when any pin is grounded and there is no activation light when any pin is grounded.

I am not trying to trigger sounds when the board is connected to the computer.

User avatar
adafruit_support_carter
 
Posts: 29522
Joined: Tue Nov 29, 2016 2:45 pm

Re: 2mb Audio FX Sound Board triggers not working

Post by adafruit_support_carter »

Seems like a connection issue somewhere.

Is everything soldered here? You mention soldering the header to the Audio FX Board. The wires are also soldered to the header pins (under the heat shrink)?
cnx.png
cnx.png (267.05 KiB) Viewed 124 times

User avatar
Sanksbot
 
Posts: 6
Joined: Sun Mar 24, 2024 1:38 am

Re: 2mb Audio FX Sound Board triggers not working

Post by Sanksbot »

Connection issue was my first thought as well. Yes, initially I soldered each header pin on the underside of the board then soldered the leads to the top and covered with heatshrink. This went well with no overlapping underneath. Unfortunately I did not take a picture. After the initial test failed I unsoldered the header completely and tested directly on the board and but the sounds would still not trigger :(

User avatar
adafruit_support_carter
 
Posts: 29522
Joined: Tue Nov 29, 2016 2:45 pm

Re: 2mb Audio FX Sound Board triggers not working

Post by adafruit_support_carter »

The photo above is the current state of the board?

Or is it currently with the headers removed (from the desoldering)?

User avatar
Beminetonight
 
Posts: 2
Joined: Fri Mar 29, 2024 12:59 pm

Re: 2mb Audio FX Sound Board triggers not working

Post by Beminetonight »

Someone just gave me an Audio FX board, and initially I was frustrated with it because although I was able to load files, and see them on the computer with the board looking like a disk drive, it wouldn't play anything while I had it powered via the USB cable. After some fooling around, I got it to work by disconnecting USB and feeding power in through the Vin+ and Gnd pins. Apparently USB was locking playback out, which was something I hadn't seen in the instructions (but I didn't look very carefully, so maybe it's there). Is this normal behavior, or could I have been doing something wrong?

User avatar
adafruit_support_carter
 
Posts: 29522
Joined: Tue Nov 29, 2016 2:45 pm

Re: 2mb Audio FX Sound Board triggers not working

Post by adafruit_support_carter »

@Beminetonight Yes. That is normal behavior. See the powering info here:
https://learn.adafruit.com/adafruit-aud ... owering-it
You won't be able to play audio while the board is connected to USB, so to actually trigger audio you'll need to unplug the USB cable and power it another way.

User avatar
Beminetonight
 
Posts: 2
Joined: Fri Mar 29, 2024 12:59 pm

Re: 2mb Audio FX Sound Board triggers not working

Post by Beminetonight »

All right, thanks. I'm sure I'd have gone back to read the instructions more carefully if I hadn't figured it out! I wondered if the original poster here had the same problem, but he says he's not powering the board off USB, so that can't be it.

User avatar
adafruit_support_carter
 
Posts: 29522
Joined: Tue Nov 29, 2016 2:45 pm

Re: 2mb Audio FX Sound Board triggers not working

Post by adafruit_support_carter »

@Sanksbot The question about current state of the board, in terms of what's soldered, connected, etc. was to see what other ways we could possible make the GND connection to test triggering.

User avatar
Sanksbot
 
Posts: 6
Joined: Sun Mar 24, 2024 1:38 am

Re: 2mb Audio FX Sound Board triggers not working

Post by Sanksbot »

Here are the front and back of the board as of now. Tried but video (MP4) wont upload shows dedicated 5v power to board, power light, activation light triggers when grounded as well as reset when grounded, still no trigger from pins.
sbfx front.jpg
sbfx front.jpg (649.69 KiB) Viewed 74 times
sbfx back.jpg
sbfx back.jpg (574.92 KiB) Viewed 74 times

User avatar
adafruit_support_carter
 
Posts: 29522
Joined: Tue Nov 29, 2016 2:45 pm

Re: 2mb Audio FX Sound Board triggers not working

Post by adafruit_support_carter »

Try triggering it manually now. Power it for play back (i.e. something other than PC USB for power). Plug in headphones (or something) to audio jack. Then use a jumper wire to manually short GND to the trigger pins.

Also, keep using the audio examples from the Learn guide for now. Focusing on why triggering isn't working.

User avatar
Sanksbot
 
Posts: 6
Joined: Sun Mar 24, 2024 1:38 am

Re: 2mb Audio FX Sound Board triggers not working

Post by Sanksbot »

I have done exactly those steps, both in the original configuration with soldered leads and after all headers were removed. Im certain it's not an issue with the way its being triggered, it must be an issue with the board itself.

Post Reply
Please be positive and constructive with your questions and comments.

Return to “Other Products from Adafruit”