Adafruit MatrixPortal M4 crashes Windows Explorer

EL Wire/Tape/Panels, LEDs, pixels and strips, LCDs and TFTs, etc products from Adafruit

Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.
Post Reply
User avatar
algaib
 
Posts: 4
Joined: Wed May 15, 2024 7:27 am

Adafruit MatrixPortal M4 crashes Windows Explorer

Post by algaib »

I have just bought a new Adafruit MatrixPortal M4. When I connect it via a good data-enabled USB, I see the MATRIXBOOT drive when I double-press the reset button (the light is green), but when I click on the drive in the Windows Explorer, the file path bar fills green like a progress meter for a long time and seems to stop at around 98%. When I click anywhere on the explorer, it crashes, every time.

I've tried restarting the computer etc, but it makes no difference. I'm using Windows 10.

I checked the troubleshooting guide here: https://learn.adafruit.com/welcome-to-c ... leshooting
But I don't have any of the apps installed it suggests to stop. I tried exiting Malwarebytes and Samsung Magician, but it didn't make any difference.

Any thoughts or suggestions? Thanks!

User avatar
algaib
 
Posts: 4
Joined: Wed May 15, 2024 7:27 am

Re: Adafruit MatrixPortal M4 crashes Windows Explorer

Post by algaib »

Update: I managed to get it working in Arduino IDE and upload some code, but now when I connect to the computer, it says Windows does not recognize the device.

Is it just a faulty device? Is there something I can do to 'reset' it?

User avatar
adafruit_support_carter
 
Posts: 29786
Joined: Tue Nov 29, 2016 2:45 pm

Re: Adafruit MatrixPortal M4 crashes Windows Explorer

Post by adafruit_support_carter »

That can sometimes happen. And Windows in general can get confused due to all the connects/disconnects that might happen when uploading new code, etc.

Is it reliably taking new Arduino sketch uploads?

User avatar
Speedy_VI
 
Posts: 43
Joined: Sat Feb 24, 2024 10:58 pm

Re: Adafruit MatrixPortal M4 crashes Windows Explorer

Post by Speedy_VI »

algaib wrote: Wed May 15, 2024 7:30 am I tried exiting Malwarebytes and Samsung Magician, but it didn't make any difference.
I had the same problem with a Feather M0 WiFi. The FEATHERBOOT drive would show up in an Explorer window but I could not click on it select any files, view its properties, or look at it in Disk Manager. Someone from Adafruit support asked if I had Samsung Magician running (I did). He said that program can interfere with the Boot drive mounting properly and I should uninstall Samsung Magician.

This did not seem likely to me but I did exit Magician. That did not fix the problem. Then I uninstalled Magician and the problem vanished. I then went and tested this on another machine, also running Windows 10 with Samsung Magician installed. Same exact thing. I could not do anything with the FEATHERBOOT drive in Windows except look at the Explorer window until I totally uninstalled Samsung Magician. I don't know what Magician is doing, even when the program is not running, but it is doing something that causes this problem.

BTW - I also have Malware Bytes running and it has not caused any problems.

User avatar
algaib
 
Posts: 4
Joined: Wed May 15, 2024 7:27 am

Re: Adafruit MatrixPortal M4 crashes Windows Explorer

Post by algaib »

adafruit_support_carter wrote: Wed May 15, 2024 1:41 pm That can sometimes happen. And Windows in general can get confused due to all the connects/disconnects that might happen when uploading new code, etc.

Is it reliably taking new Arduino sketch uploads?
It did once, but now it's completely unrecognized by windows and just crashes the explorer unfortunately

User avatar
algaib
 
Posts: 4
Joined: Wed May 15, 2024 7:27 am

Re: Adafruit MatrixPortal M4 crashes Windows Explorer

Post by algaib »

Speedy_VI wrote: Wed May 15, 2024 4:36 pm
algaib wrote: Wed May 15, 2024 7:30 am I tried exiting Malwarebytes and Samsung Magician, but it didn't make any difference.
I had the same problem with a Feather M0 WiFi. The FEATHERBOOT drive would show up in an Explorer window but I could not click on it select any files, view its properties, or look at it in Disk Manager. Someone from Adafruit support asked if I had Samsung Magician running (I did). He said that program can interfere with the Boot drive mounting properly and I should uninstall Samsung Magician.

This did not seem likely to me but I did exit Magician. That did not fix the problem. Then I uninstalled Magician and the problem vanished. I then went and tested this on another machine, also running Windows 10 with Samsung Magician installed. Same exact thing. I could not do anything with the FEATHERBOOT drive in Windows except look at the Explorer window until I totally uninstalled Samsung Magician. I don't know what Magician is doing, even when the program is not running, but it is doing something that causes this problem.

BTW - I also have Malware Bytes running and it has not caused any problems.
Interesting, I'll try uninstalling Magician and see what happens. Thanks!

Post Reply
Please be positive and constructive with your questions and comments.

Return to “Glowy things (LCD, LED, TFT, EL) purchased at Adafruit”