How to put AirLift ESP32 coprocessor into BLE mode

For CircuitPython issues, ask in the Adafruit CircuitPython forum.

Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.
Post Reply
User avatar
ka8
 
Posts: 5
Joined: Wed Jul 05, 2023 10:50 am

How to put AirLift ESP32 coprocessor into BLE mode

Post by ka8 »

First post on this subject; couldn't find hints in any documentation.

I have an Adafruit Feather STM32F405 on a breadboard with an Airlift ESP32 coprocessor board, using the Arduino IDE to compile and download code onto the STM. Using examples from the WiFiNINA library, I have successfully scanned for nearby networks and have connected to my home network.

I would now like to try connecting to my laptop using BLE with the AirLift. Although the AirLift documentation notes that you can "reset" the AirLift into BLE mode (WiFi is the default), and has extensive CircuitPython documentation for using BLE, I have not found anything anywhere that indicates how to do this using the Arduino IDE.

I hope that simply adding jumpers for the Rx and Tx pins on the two devices, and setting BLE mode will let me use BLE through the AirLift. How do I get the AirLift into BLE mode???

Any advice appreciated!

User avatar
bidrohini1
 
Posts: 197
Joined: Sun Mar 19, 2023 11:48 am

Re: How to put AirLift ESP32 coprocessor into BLE mode

Post by bidrohini1 »

You have to use the WiFiNINA.h library for your task.
https://github.com/arduino-libraries/WiFiNINA

User avatar
ka8
 
Posts: 5
Joined: Wed Jul 05, 2023 10:50 am

Re: How to put AirLift ESP32 coprocessor into BLE mode

Post by ka8 »

Thank you. I looked through the library (v1.8.14) on GitHub. I saw no BlueTooth or BLE functions. The available classes seem to be WiFi, Client, Server and UDP.

Can you specify a particular class and function in the WiFiNINA.h libary that would set BLE?

Thanks!

Post Reply
Please be positive and constructive with your questions and comments.

Return to “Wireless: WiFi and Bluetooth”