Feather ESP32-S3 2MB PSRAM Ports / COM connectivity issues

This is a special forum devoted to educators using Adafruit and Arduino products for teaching.

Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.
Post Reply
User avatar
Jeffgustafson
 
Posts: 1
Joined: Thu Jun 13, 2024 3:44 pm

Feather ESP32-S3 2MB PSRAM Ports / COM connectivity issues

Post by Jeffgustafson »

Hi y'all,

I'm at my wits end. I have been working to develop a project for our high school students this summer for a weather data logging device and have continually run into issues with the board not connecting well to the Arduino IDE. I have installed and reinstalled the recommended drivers, I have worked on Windows and on MacOS. I have tried different settings that people in forums online have recommended as fixes, all to no avail. When we connect the board to our computers, holding the BOOT button, clicking reset, then releasing the BOOT, it shows up as an option in the devices tab. It will compile and upload the code seemingly successfully but then disconnect once we click reset to start the code execution as the guides say online. Am I missing something super basic?

I had it working well at one point on my Windows 11 PC after it refused to be recognized as a valid COM. The forum answer that seemed to alleviate this issue was not able to solve it when it arose again (https://github.com/espressif/arduino-es ... 1563497918)

I have been recently trying this out on my M1 MacBook Pro. I tried to do a factory reset with copying a new .u2f file like the website said but it wouldn't let me copy it over. In the process, I tried to remove the old one thinking there was some space competition for both of them but now the device just won't connect as a drive at all... Can this be repaired??

We have tried different USB cables as well so that doesn't seem to be the issue. We have installed the latest Arduino IDE and tried following the board setup guides as closely as I'm aware of.

Can someone help me out? Right now I just want to smash this thing with a hammer...
Attachments
errorCodeMessage.txt
Latest error message
(142.66 KiB) Downloaded 1 time

User avatar
mikeysklar
 
Posts: 15471
Joined: Mon Aug 01, 2016 8:10 pm

Re: Feather ESP32-S3 2MB PSRAM Ports / COM connectivity issues

Post by mikeysklar »

Try rolling back the "esp32 by espressif" Board Support Package to 2.0.17. I've found that stabilizes the behavior. I did need to close and restart the Arduino IDE (v2.3.2) on my MacOS M2 Laptop.

Post Reply
Please be positive and constructive with your questions and comments.

Return to “For Educators”