Piano glove project with Version 2 of VS1053 breakout board

General project help for Adafruit customers

Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.
Locked
User avatar
HamuSando
 
Posts: 4
Joined: Tue Oct 20, 2015 4:57 pm

Piano glove project with Version 2 of VS1053 breakout board

Post by HamuSando »

Hi,
I'm a novice. I have been following the Piano Glove tutorial (https://learn.adafruit.com/pianoglove?view=all) to complete this project.

I have completed the project - the color sensor & neopixel parts work great, but no sound is being generated by the vs1053 (BoB).
I see many people have had similar problems due to poor connections in their soldering or changing the sketch.
I used the piano glove sketch exactly as downloaded from the project (https://github.com/adafruit/pianoglove/ ... glove-midi) and have installed the libraries for the neopixel & color sensor.

I am using Adafruit Arduino 10.0.5. The board selected is Adafruit Flora.I also tried sample code to test the midi tones on the vs1053 given in response to someone else's post and get no sound. (I just copied and pasted the code from this thread: http://forums.adafruit.com/viewtopic.ph ... e&start=30)

Using version 2 of the vs1053, I have connected the centre pin of the audio jack to AGND. There is no GND (ground) on the side of the board with the numbered pins, so I've jumped it (from 0 numbered pin) over the board to connect with the row I connected the ground with on the opposite side of the perma proto.

I was also not sure of connecting the audio jack, as there are two prongs each for Left & Right - I tried loosely connecting wires to either side with no difference in the result.

I'm just using alligator clips to connect between the Flora & short, soldered wires on the VS1053. I have left a few ends (connecting to positive or negative row) un-soldered, but think they are still making enough of a connection to test...

I have included 3 photos and am looking forward to some help getting this project working. :)
front of vs1053 breakout version 2
front of vs1053 breakout version 2
pianoGloveVS1053BoB.jpg (273.74 KiB) Viewed 218 times
back of vs1053 breakout version 2
back of vs1053 breakout version 2
vs1053BobBack.jpg (254.92 KiB) Viewed 218 times
overall photo - includes Flora & vs1053 BoB
overall photo - includes Flora & vs1053 BoB
pianoGlove.jpg (264.36 KiB) Viewed 218 times

User avatar
adafruit_support_mike
 
Posts: 65532
Joined: Thu Feb 11, 2010 2:51 pm

Re: Piano glove project with Version 2 of VS1053 breakout bo

Post by adafruit_support_mike »

It looks like you haven't soldered most of the pins into the VS1053 breakout.

You need to do that. The solder makes the electrical connection between the pin and the PCB.

User avatar
HamuSando
 
Posts: 4
Joined: Tue Oct 20, 2015 4:57 pm

Re: Piano glove project with Version 2 of VS1053 breakout bo

Post by HamuSando »

I soldered them all on the back & just 2 on the front. I misunderstood how the directions were written. Will try. hope it works.
No probable issue with using an older IDE?

User avatar
HamuSando
 
Posts: 4
Joined: Tue Oct 20, 2015 4:57 pm

Re: Piano glove project with Version 2 of VS1053 breakout bo

Post by HamuSando »

I soldered each pin front & back. Look like good connections. Nothing happening still with the breakout.

User avatar
HamuSando
 
Posts: 4
Joined: Tue Oct 20, 2015 4:57 pm

Re: Piano glove project with Version 2 of VS1053 breakout bo

Post by HamuSando »

Turns out the alligator clips I was using weren't making an full connection. Working perfectly now. Thank you so much! <3

User avatar
adafruit_support_mike
 
Posts: 65532
Joined: Thu Feb 11, 2010 2:51 pm

Re: Piano glove project with Version 2 of VS1053 breakout bo

Post by adafruit_support_mike »

Glad to hear it's working for you.

Locked
Please be positive and constructive with your questions and comments.

Return to “General Project help”