beta.6 on Funhouse - offline

adafruit.io wippersnapper BETA support, discussions, and more!

Moderators: adafruit_support_bill, adafruit

Forum rules
If you're posting code, please make sure your code does not include your Adafruit IO Active Key or WiFi network credentials.
User avatar
SandPig
 
Posts: 44
Joined: Sun Sep 10, 2017 8:25 am

beta.6 on Funhouse - offline

Post by SandPig »

beta.6 on the funhouse loads great.
update secrets and rest without issue.
restart works through the connection cycle and the new code version is reflected correctly on the dashboard.
unfortunately, the device never leaves an amber state and the dashboard only shows the device as offline.
note, I deleted the device and it popped back up immediately after reboot, probably a completely unnecessary step, but there you go.

serial output:
Registering Board...
18:56:10.646 -> registerBoard()
18:56:10.646 -> Encoding registration message...Encoded!
18:56:20.731 -> Publishing registration message...Published!
18:56:20.731 -> Publishing registration message...Published!
18:56:40.752 -> Publishing registration message...Published!
18:56:40.752 -> Publishing registration message...Published!
18:57:00.740 -> Publishing registration message...Published!
18:57:00.740 -> Publishing registration message...Published!
18:57:20.758 -> Publishing registration message...Published!
18:57:20.758 -> Publishing registration message...Published!
18:57:40.754 -> Publishing registration message...Published!
18:57:40.754 -> Publishing registration message...Published!
18:58:00.733 -> Publishing registration message...Published!
18:58:00.733 -> Publishing registration message...Published!
18:58:20.730 -> Publishing registration message...Published!
18:58:20.730 -> Publishing registration message...Published!
18:58:40.735 -> Publishing registration message...Published!

--- grab a drink ---

19:07:00.759 -> Publishing registration message...Published!
19:07:20.773 -> Publishing registration message...Published!
19:07:20.773 -> Publishing registration message...Published!
19:07:40.808 -> Publishing registration message...Published!

rinse/repeat

User avatar
brubell
 
Posts: 1743
Joined: Fri Jul 17, 2015 10:33 pm

Re: beta.6 on Funhouse - offline

Post by brubell »

HM, haven't seen this yet. We did rework the registration FSM in beta.6 so it won't drop out entirely if there was an error. However, I'm not yet sure why it's getting stuck, I'll couldn't replicate it yet, could you give me some more details about what steps you took and your operating system.

User avatar
brubell
 
Posts: 1743
Joined: Fri Jul 17, 2015 10:33 pm

Re: beta.6 on Funhouse - offline

Post by brubell »

UPDATE: Please try beta.7 and let me know if it works for you.

User avatar
jerryn
 
Posts: 1738
Joined: Sat Sep 14, 2013 9:05 am

Re: beta.6 on Funhouse - offline

Post by jerryn »

FYI -- I was having issues with beta.6 hanging -- happened on funhouse and esp32 feather
tried beta 7 --- funhouse does not boot -- just solid magenta lights
esp32 feather seems to work , but the AIO page does not recognize the firmware setting still says beta.6 or possibly the web tool is not installing beta.7 yet.

edited to add -- funhouse does boot, but is unresponsive.

User avatar
jerryn
 
Posts: 1738
Joined: Sat Sep 14, 2013 9:05 am

Re: beta.6 on Funhouse - offline

Post by jerryn »

ah -- apparently installing beta.7 wiped the secrets.json file - I restored it on the funhouse and it is now working.

the esp32 still appears to be on beta.6 -- has the webtool been updated?

User avatar
SandPig
 
Posts: 44
Joined: Sun Sep 10, 2017 8:25 am

Re: beta.6 on Funhouse - offline

Post by SandPig »

I'm not sure what I can add as far as the process goes, but I am using a MacBook M1 11.5.2, if that helps.
dropped beta.7 (now this is how you use a lunch break!), but while the publishing cadence has picked up, the symptoms are the same.

Registering Board...
12:33:09.309 -> registerBoard()
12:33:09.309 -> Encoding registration message...Encoded!
12:33:10.466 -> Publishing registration message...Published!
12:33:10.466 -> Publishing registration message...Published!
12:33:12.844 -> Publishing registration message...Published!
12:33:12.844 -> Publishing registration message...Published!
12:33:15.231 -> Publishing registration message...Published!
12:33:15.231 -> Publishing registration message...Published!
12:33:17.624 -> Publishing registration message...Published!
12:33:17.624 -> Publishing registration message...Published!
12:33:19.981 -> Publishing registration message...Published!
12:33:19.981 -> Publishing registration message...Published!

dashboard reflects the updated software version

User avatar
brubell
 
Posts: 1743
Joined: Fri Jul 17, 2015 10:33 pm

Re: beta.6 on Funhouse - offline

Post by brubell »

edited to add -- funhouse does boot, but is unresponsive.
Could you open the Arduino Serial Monitor and let me know what it's printing out there?

User avatar
jerryn
 
Posts: 1738
Joined: Sat Sep 14, 2013 9:05 am

Re: beta.6 on Funhouse - offline

Post by jerryn »

It was ok. It had wiped secrets.Jason. It was ok when I repopulated it.

User avatar
ksprayberry
 
Posts: 35
Joined: Tue Feb 05, 2019 8:52 pm

Re: beta.6 on Funhouse - offline

Post by ksprayberry »

jerryn wrote:It was ok. It had wiped secrets.Jason. It was ok when I repopulated it.
I repopulated mine with Beta 7 and it keeps erasing the file. everytime I double click to get to the houseboot, it erases it. I replace it and it does it again.

User avatar
brubell
 
Posts: 1743
Joined: Fri Jul 17, 2015 10:33 pm

Re: beta.6 on Funhouse - offline

Post by brubell »

ksprayberry wrote:
jerryn wrote:It was ok. It had wiped secrets.Jason. It was ok when I repopulated it.
I repopulated mine with Beta 7 and it keeps erasing the file. everytime I double click to get to the houseboot, it erases it. I replace it and it does it again.
What operating system are you using?

User avatar
ksprayberry
 
Posts: 35
Joined: Tue Feb 05, 2019 8:52 pm

Re: beta.6 on Funhouse - offline

Post by ksprayberry »

I am using Windows 10, 64 Bit
Thanks

User avatar
brubell
 
Posts: 1743
Joined: Fri Jul 17, 2015 10:33 pm

Re: beta.6 on Funhouse - offline

Post by brubell »

ksprayberry wrote:
jerryn wrote:It was ok. It had wiped secrets.Jason. It was ok when I repopulated it.
I repopulated mine with Beta 7 and it keeps erasing the file. everytime I double click to get to the houseboot, it erases it. I replace it and it does it again.
Could you please try beta.8? It's on the guide. We've done a lot of filesystem-related bugfixes in the latest version which may squash these issues.

User avatar
SandPig
 
Posts: 44
Joined: Sun Sep 10, 2017 8:25 am

Re: beta.6 on Funhouse - offline

Post by SandPig »

initial load of beta.8 produces a "no name" disk and four amber flashes (repeating) with no serial output
I'll try to make some time later today to poke around.

User avatar
brubell
 
Posts: 1743
Joined: Fri Jul 17, 2015 10:33 pm

Re: beta.6 on Funhouse - offline

Post by brubell »

SandPig wrote:initial load of beta.8 produces a "no name" disk and four amber flashes (repeating) with no serial output
I'll try to make some time later today to poke around.
Open the disk drive, do you see the secrets.json file in it? You'll need to add your credentials to the file.

User avatar
SandPig
 
Posts: 44
Joined: Sun Sep 10, 2017 8:25 am

Re: beta.6 on Funhouse - offline

Post by SandPig »

I'm a little embarrassed that I didn't think to try that...
Good news, it connects after updating the secrets /heavy sigh
Bad news, it never goes "online"
(1.0.0-beta.8)

Registering Board...
22:35:47.960 -> registerBoard()
22:35:47.960 -> Encoding registration message...Encoded!
22:35:49.148 -> Publishing registration message...Published!
22:35:49.148 -> Publishing registration message...Published!
22:35:51.530 -> Publishing registration message...Published!
22:35:51.530 -> Publishing registration message...Published!
22:35:53.921 -> Publishing registration message...Published!
22:35:53.921 -> Publishing registration message...Published!
22:35:56.290 -> Publishing registration message...Published!
22:35:56.290 -> Publishing registration message...Published!

Locked
Forum rules
If you're posting code, please make sure your code does not include your Adafruit IO Active Key or WiFi network credentials.

Return to “Adafruit IO Wippersnapper Beta”