Trying to calibrate my FXOS8700 + FXAS21002 IMU with my ardu

Post here about your Arduino projects, get help - for Adafruit customers!

Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.
Post Reply
User avatar
ryderj
 
Posts: 1
Joined: Tue Jun 21, 2022 1:51 pm

Trying to calibrate my FXOS8700 + FXAS21002 IMU with my ardu

Post by ryderj »

this is what it is supposed to look like
this is what it is supposed to look like
nowrod.PNG (57.03 KiB) Viewed 138 times
this is what outputs when I run the sensor calibration read
this is what outputs when I run the sensor calibration read
unnamed.png (1.8 KiB) Viewed 139 times
https://learn.adafruit.com/how-to-fuse- ... s/overview
I have been following this guide to attempt to calibrate each sensor but for some reason, it doesn't work on my nano 33 IoT. It does work on my regular Arduino that has EEPROM. The IoT has no EPROM but it does have flash memory so shouldn't that work the same.

User avatar
mikeysklar
 
Posts: 8383
Joined: Mon Aug 01, 2016 8:10 pm

Re: Trying to calibrate my FXOS8700 + FXAS21002 IMU with my

Post by mikeysklar »

This looks like the error you should expect to see when using an nRF52 board with SPI flash.
It's OK to see Failed to read file / No calibration loaded/found (we haven't made one yet!)
https://learn.adafruit.com/how-to-fuse- ... -3056177-6

Can you paste in the full output from your console?

User avatar
adafruit2
 
Posts: 21200
Joined: Fri Mar 11, 2005 7:36 pm

Re: Trying to calibrate my FXOS8700 + FXAS21002 IMU with my

Post by adafruit2 »

nano33 iot does not have external flash on it - and its untested, so you will not be able to autocalibrate/store the data.

Post Reply
Please be positive and constructive with your questions and comments.

Return to “Arduino”