Arduino IDE Trinket MO port recognition problems for 20 Trin

Adafruit's tiny microcontroller platform (please tell us which board you are using)

Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.
Locked
User avatar
zackboston
 
Posts: 123
Joined: Mon Feb 25, 2013 12:47 pm

Arduino IDE Trinket MO port recognition problems for 20 Trin

Post by zackboston »

For about a month, I have been posting on the education forum and this Trinket and Trinket MO forum about my troubles with using Trinket MOs for about 20 tried and true edgelit acrylic lightbox projects with my summer Learn 2 Teach, Teach 2 Learn program with teen youth teachers in Boston. We are using Arduino IDE. The problem is that we cannot get the Arduino IDE to recognize that a Trinket MO is on the port on all of the new ones.

So far, I have only gotten one old Trinket MO to be recognized on a port. I have attached a screenshot of the successful Trinket MO. So I know that my libraries, boards, and USB cord are set up correctly.

I can get all the new Trinket MOs to reset and get into bootloader mode. However I cannot get them to be recognized on a port in the Arduino IDE.

My IT friend says the problem is that the Trinket MO does not have a built-in serial to USB converter and our computers are not recognizing the signal. I tried uploading several FTDI drivers recommended by an experienced maker friend but they did not solve the problem.

Several of my friends have had the same problem with Trinket MOs and never got the Arduino IDE working, so they ended up just using Circuit Python. I have only done one or two projects with Circuit Python, neither with neopixel strips, so I have not just given up and turned to Circuit Python. I also taught the youth teachers Arduino programming and they made color fade sketches on an Uno with a Grove Shield, so I REALLY want to use Arduino IDE.

Please can you help with this problem. . . I really have been working overtime on it!
Attachments
Screen Shot 2022-08-05 at 7.03.48 PM.png
Screen Shot 2022-08-05 at 7.03.48 PM.png (904.37 KiB) Viewed 65 times

User avatar
adafruit_support_carter
 
Posts: 24882
Joined: Tue Nov 29, 2016 2:45 pm

Re: Arduino IDE Trinket MO port recognition problems for 20

Post by adafruit_support_carter »

What happens if you try putting the Trinket into booloader mode? Try double pressing the reset button. Does the TRINKETBOOT folder show up? Does the RGB LED in the middle of the Trinket light up? If so, what color?

User avatar
zackboston
 
Posts: 123
Joined: Mon Feb 25, 2013 12:47 pm

Re: Arduino IDE Trinket MO port recognition problems for 20

Post by zackboston »

I am on my MacAir 2020 now with Arduino IDE 1.8.13 installed (and reinstalled on one of my debug tries). I also have restarted my Mac Air.

When I press the reset twice, the bootloader LED fades in and out red for 10 seconds.
However, the TRINKETBOOT does not appear during bootloader. Also, no port appears in Arduino IDE except the bluetooth and wifi ones appears.

Thanks from the bottom of my heart for your quick response. I have 18 lightboxes with teenagers that need code uploaded to these Trinket MOs!

User avatar
zackboston
 
Posts: 123
Joined: Mon Feb 25, 2013 12:47 pm

Re: Arduino IDE Trinket MO port recognition problems for 20

Post by zackboston »

p.s. the LED in the middle does not light on the ones that are not working.

(on the one Trinket MO that IS working, that LED lights up BRIGHT PINK)

User avatar
adafruit_support_carter
 
Posts: 24882
Joined: Tue Nov 29, 2016 2:45 pm

Re: Arduino IDE Trinket MO port recognition problems for 20

Post by adafruit_support_carter »

When I press the reset twice, the bootloader LED fades in and out red for 10 seconds.
Please post a photo of the Trinket used here so we can look for any obvious hardware issues.

User avatar
zackboston
 
Posts: 123
Joined: Mon Feb 25, 2013 12:47 pm

Re: Arduino IDE Trinket MO port recognition problems for 20

Post by zackboston »

Oh I have good news. . . I installed some FTDI drivers for my MacAir 2020. After I contacted you last, my computer battery died and the computer was shut down for 4 hours --- Before this, I restarted the computer, but had not done a complete shut down. I think this triggered the FTDI drivers in a better way, because when the computer started again, all the 18 Trinket MOs worked except for one (I think the youth teacher actually fried that one by over soldering parts. . . ).

So everything is working again after a month! Yesterday, half of the edge-lit acrylic lightboxes with rocker switches got completed!!!!

Or it could have the Trinket MOs fear of your help that triggered them to behave finally!

Thank you soooo much for your encouragement.

Locked
Please be positive and constructive with your questions and comments.

Return to “Trinket and Trinket M0”