CLUE stopped being recognised on my PC

Project postings and help for Adafruit CLUE

Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.
Post Reply
User avatar
xchg.ca
 
Posts: 6
Joined: Sun Mar 31, 2013 5:40 pm

CLUE stopped being recognised on my PC

Post by xchg.ca »

Hi guys,
I have issue that my CLUE stopped being recognized as Adafruit CLUE, i probably uploaded bad sketch from Arduino ide.
Before it was working all fine and detected fine as Adafruit CLUE, Port 5 on Windows 10
Once I uploaded sketchy sketch it stopped being recognized.

BUT when I do double tap on reset it turns into Adafruit Feather nRF52840 and Flash drive showing as FEATHER840 and I can upload stuff but as Feather 52840 and Port 7. Which is bizarre ! What is this about?
So how can I get it back into Adafruit Clue ?

Hitting reset once just keeps running Blinky ( uploaded as Feather board in previous step ) but board it not detected by any Windows !

Please help

Tried also on Windows 7 same story.

Windows 10, Arduino IDE 1.8.19, 16Gb Ram, i5 Cpu
Windows 7, Arduino IDE 1.8.19, 32Gb Ram, i7 Cpu

User avatar
mikeysklar
 
Posts: 8933
Joined: Mon Aug 01, 2016 8:10 pm

Re: CLUE stopped being recognised on my PC

Post by mikeysklar »

You are doing the right thing with the double tap 'reset' and getting into bootloader mode.

Your PC is still recognizing the bootloader USB drive name and just seeing the device on the next available COM port. You should not be concerned about the bootloader drive name or COM port switch.

User avatar
xchg.ca
 
Posts: 6
Joined: Sun Mar 31, 2013 5:40 pm

Re: CLUE stopped being recognised on my PC

Post by xchg.ca »

Thank you @mikeysklar
Sure, it still sort of works. But before it was USB accessible right after regular single reset, but not anymore.
Do you know if there is a way of hardware resetting it back to how it was ?
Reflash bootloader perhaps?

User avatar
xchg.ca
 
Posts: 6
Joined: Sun Mar 31, 2013 5:40 pm

Re: CLUE stopped being recognised on my PC

Post by xchg.ca »

I just pulled the plug on burning bootloader even I was not 100% understanding was was the original issue
And here what I got :

Code: Select all

Upgrading target on COM7 with DFU package C:\Users\3dpriner\AppData\Local\Arduino15\packages\adafruit\hardware\nrf52\1.3.0\bootloader\clue_nrf52840\clue_nrf52840_bootloader-0.6.2_s140_6.1.1.zip. Flow control is disabled, Dual bank, Touch 1200
Touched serial port COM7
Opened serial port COM7
Starting DFU upgrade of type 3, SoftDevice size: 151016, bootloader size: 39000, application size: 0
Sending DFU start packet
Sending DFU init packet
Sending firmware file
########################################
########################################
########################################
########################################
########################################
########################################
########################################
########################################
########################################
############
Activating new firmware

Device programmed.
DFU upgrade took 21.066006660461426s
Looks like we are good now !
Board is detected as
Adafruit Clue S140 6.1.1

User avatar
mikeysklar
 
Posts: 8933
Joined: Mon Aug 01, 2016 8:10 pm

Re: CLUE stopped being recognised on my PC

Post by mikeysklar »

Good work getting the bootloader installed. Glad to hear it resolved the programming issue.

Post Reply
Please be positive and constructive with your questions and comments.

Return to “CLUE”